OpenMarine

Full Version: Compatible multiplexers list
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Post here models and settings and we will add them to the list.
  • ShipModul MiniPlex-42USB. Settings: baudrate 57600.
  • ShipModul MiniPlex-3USB. Settings: baudrate 460800.
  • www.gadgetpool.de SeaTalk NMEA Bridge128SD. Settings: baudrate 38400
  • The Brookhouse line of multiplexers work great. http://www.brookhouseonline.com
(05-20-2016, 08:37 AM)Sailoog Wrote: [ -> ]Post here models and settings and we will add them to the list.
  • ShipModul MiniPlex-42USB. Settings: baudrate 57600.
ShipModul MiniPlex-3USB
I added the multiplexer as a new device ttyOP_1 using USB manager and I added a NMEA 0183 serial input on port /dev/ttyOP_1 with 57600 bauds
No NMEA data stream in OpenCPN
**UPDATE** MiniPlex-3USB runs on 460800 baud
**UPDATE** Fixed with -> sudo stty -F /dev/ttyUSB0 460800
(06-10-2017, 12:06 PM)JeroenAdam Wrote: [ -> ]ShipModul MiniPlex-3USB
I added the multiplexer as a new device ttyOP_1 using USB manager and I added a NMEA 0183 serial input on port /dev/ttyOP_1 with 57600 bauds
No NMEA data stream in OpenCPN
**UPDATE** MiniPlex-3USB runs on 460800 baud
**UPDATE** Fixed with -> sudo stty -F /dev/ttyUSB0 460800

thanks!
I'm trying to configure a DTech serial to USB converter to pick up the NMEA 0183 signals from a Raymarine SmartPilot. See page 4 in the commissioning manual. I have an S1.

My issue is that I do not see the "USB Manager", "NMEA 0183", or "NMEA 2K" tabs as described in the OpenPlotter documentation. All I see is a "Serial" tab, followed by the "Signal K" tab. 

Is there a configuration setting? Have I installed the incorrect version of OP?

(08-14-2018, 05:55 AM)MilesAhead Wrote: [ -> ]I'm trying to configure a DTech serial to USB converter to pick up the NMEA 0183 signals from a Raymarine SmartPilot. See page 4 in the commissioning manual. I have an S1.

My issue is that I do not see the "USB Manager", "NMEA 0183", or "NMEA 2K" tabs as described in the OpenPlotter documentation. All I see is a "Serial" tab, followed by the "Signal K" tab. 

Is there a configuration setting? Have I installed the incorrect version of OP?

BTW, I have a RPi 3 with the latest raspbian and I installed the latest NOOB version of OP/OpenCPN, then I updated OP & OpenCPN using OP.
(05-20-2016, 08:37 AM)Sailoog Wrote: [ -> ]Post here models and settings and we will add them to the list.
  • ShipModul MiniPlex-42USB. Settings: baudrate 57600.
  • ShipModul MiniPlex-3USB. Settings: baudrate 460800.
  • www.gadgetpool.de SeaTalk NMEA Bridge128SD. Settings: baudrate 38400

shipmodul miniplex-2wi Setting: Baudrate 115200
The Brookhouse line of multiplexers work great.

I have an iMux which works perfectly.

http://www.brookhouseonline.com/
(06-13-2017, 12:32 PM)Sailoog Wrote: [ -> ]
(06-10-2017, 12:06 PM)JeroenAdam Wrote: [ -> ]ShipModul MiniPlex-3USB
I added the multiplexer as a new device ttyOP_1 using USB manager and I added a NMEA 0183 serial input on port /dev/ttyOP_1 with 57600 bauds
No NMEA data stream in OpenCPN
**UPDATE** MiniPlex-3USB runs on 460800 baud
**UPDATE** Fixed with -> sudo stty -F /dev/ttyUSB0 460800

thanks!
I have a shipmodule Multiplexor with blue tooth.  Can this be added via bluetooth
(11-10-2018, 09:49 AM)Bojayne@yahoo.com Wrote: [ -> ]
(06-13-2017, 12:32 PM)Sailoog Wrote: [ -> ]
(06-10-2017, 12:06 PM)JeroenAdam Wrote: [ -> ]ShipModul MiniPlex-3USB
I added the multiplexer as a new device ttyOP_1 using USB manager and I added a NMEA 0183 serial input on port /dev/ttyOP_1 with 57600 bauds
No NMEA data stream in OpenCPN
**UPDATE** MiniPlex-3USB runs on 460800 baud
**UPDATE** Fixed with -> sudo stty -F /dev/ttyUSB0 460800

thanks!
I have a shipmodule Multiplexor with blue tooth.  Can this be added via bluetooth

yes, but the serial blutooth has to be set up. connect to the device in the bt-menu.
then do some init with he mac addresses of you devices. i do this before the end of /etc/rc.local but you can do it in any bootfile.

------- chage to your devices: -----------
# bluetooth gps
rfcomm bind 0 20:13:07:31:20:47 # achterschiff Liesbeth
rfcomm bind 2 20:13:07:31:19:51 # L-sensorik
rfcomm bind 1 00:15:4B:11:1A:95 # bt-bluetooth
-------------------------

after init, you should find the serial under /dev/rfcommX in openplotter/kplex tab.

good luck, holger