OpenMarine

Full Version: CAN-USB Stick v2 not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi
I received a new CAN-USB stick and installed it. I have a test network of Simrad MFD,  N2K network, RPI3B+ + Moitessier Hat + OPv1.2. On the first install everything was ok - I could get data from the MFD and see it in SK Diagnostic window. I tried to send AIS data from OP out onto the N2K bus by using the "Convert SignalK to NMEA2000" plug in - I have tried various things but was stuck at this stage. Now I have a further problem. Suddenly no N2K data was available in OP. After a full power down and reboot I went to the serial tab in OP and tried to reinstall the CAN-USB Stick - I now get a message saying "We have not found any recognisable data on your device". I am guesssing that there is something wrong with the CAN-USB stick. Can anyone offer further advice?
Thanks!
in a terminal try the command "lsusb" and see if it shows up there.
Hi Jim
Thanks for your help! I also have a Microsoft USB keyboard/mouse attached. This is what I get:-
pi@Daves-PI:~ $ lsusb
Bus 001 Device 004: ID 045e:07b2 Microsoft Corp.
Bus 001 Device 007: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light
Bus 001 Device 006: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Rgds Dave
(04-27-2019, 09:46 PM)dave.ritten@gmail.com Wrote: [ -> ]Hi Jim
Thanks for your help! I also have a Microsoft USB keyboard/mouse attached. This is what I get:-
pi@Daves-PI:~ $ lsusb
Bus 001 Device 004: ID 045e:07b2 Microsoft Corp.
Bus 001 Device 007: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light
Bus 001 Device 006: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Rgds Dave

Ok I reset the CAN-USB stick in the TX PGN menu and it now seems to working ok. Thanks for your help.