OpenMarine

Full Version: Enabling GPS on RPI 4 (GlobalSat BU 353S4)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Wanted to share my path for those who might also have struggled a bit to get the GPS puck (Global Sat BU 35324 ) running on the PI 4

Problems
(as best I understand it)
1) BU-353 is set to binary mode by default 
2) Linux GPSD prefers NMEA 0183


[Elsewhere there are instructions for installing a RAR package on Raspian for building the Global Sat proprietary driver, but this ended in a dead end for me]

--- 
STEPS 

1) Identify where the device is being assigned

Find the name / company (eg. Prolific ..)


$lsusb

$ Bus 001 Device 011: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port


Then determine the where it's assigned


$dmesg

. . . . 
[ 3616.831274] usb 1-1.3: Manufacturer: Prolific Technology Inc. 



2)
In terminal, change it from binary to NMEA mode (*note, I determined mine was assigned to USB1. 

You might find yours is USB0 etc., modify as required)



$ gpsctl -f -n -s 4800 /dev/ttyUSB1


$ /dev/ttyUSB1 identified as a SiRF 9GSD4e_4.1.2-P1_RPATCH.05-F-GPS-4R-1510281 11/03/2015 307 at 4800 baud.
gpsctl:SHOUT: switching to mode NMEA.


3) Using Open Plotter "serial" menu
assign alias to appropriate device 
/dev/ttyOP_ gps


set data type to NMEA 0183 


"Apply" changes


4 Assign
Open the connections tab, select "ADD to GPSD"


5 Check
in terminal run
cgps -s


6 OpenCPN
Setup: Options / connections
Add connection, Network
Select GPSD
I would suggest changes:

4 Assign
Open the connections tab, select "ADD to Signal K"

5 OpenCPN
Setup: Options / connections
Add connection, Network TCP localhost 10110

This way you will have data in Signal K and OpenCPN at once.