Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Forum Statistics
» Members: 1,742
» Latest member: Dogging Licence
» Forum threads: 857
» Forum posts: 5,331

Full Statistics

Online Users
There are currently 33 online users.
» 3 Member(s) | 30 Guest(s)
Dunic, estai, PaddyB

Latest Threads
Descarga ficheros
Forum: Español
Last Post: Dunic
15 minutes ago
» Replies: 4
» Views: 81
Filter incoming PGNs ?
Forum: How do I...?
Last Post: Lazzz
2 hours ago
» Replies: 2
» Views: 131
Connecting NMEA Wind data...
Forum: How do I...?
Last Post: PaddyB
3 hours ago
» Replies: 42
» Views: 1,851
Pypilot motor controller
Forum: General discussion
Last Post: seandepagnier
11 hours ago
» Replies: 10
» Views: 304
Unreadable output from US...
Forum: How do I...?
Last Post: jim321
Yesterday, 04:43 PM
» Replies: 1
» Views: 24
Implementing /digitalyach...
Forum: How do I...?
Last Post: callmecalanca
Yesterday, 12:30 PM
» Replies: 17
» Views: 3,603
Signal K MQTT Node Red
Forum: How do I...?
Last Post: jim321
Yesterday, 09:53 AM
» Replies: 15
» Views: 321
Introducing OpenPlotter h...
Forum: General discussion
Last Post: Rooney
Yesterday, 09:00 AM
» Replies: 101
» Views: 38,361
WindTrim modes
Forum: How do I...?
Last Post: jim321
Yesterday, 08:50 AM
» Replies: 8
» Views: 416
OpenPlotter para no inici...
Forum: Español
Last Post: gypsylyon
Yesterday, 04:51 AM
» Replies: 63
» Views: 1,756

  [SOLVED] S-63 Plugin
Posted by: Lucy - 06-05-2018, 11:06 AM - Forum: Bug Reports - Replies (8)


So I'm running OpenCPN on Raspberry Pi 3B+ using the Openplotter 1.0.0 Stretch operating system.
I need to be able to use the S-63 plugin with OpenCPN as I live in Norway, and as such all charts are using the S-63 plugin.

I am unable to generate a fingerprint file using the S-63 plugin on OpenCPN.
This is the error I'm getting.
"12:54:37 -02: s63_pi: Cannot execute OCPNsenc utility at {/usr/bin/OCPNsenc}"

When I try cd-ing into usr/bin and running OCPNsenc as sudo. This is what I'm getting
pi@openplotter:~ $ cd ..
pi@openplotter:/home $ cd ..
pi@openplotter:/ $ cd usr
pi@openplotter:/usr $ cd bin
pi@openplotter:/usr/bin $ sudo OCPNsenc
OCPNsenc: Symbol `_ZN12wxTextBuffer6ms_eofE' has different size in shared object, consider re-linking
12:52:38: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1002,wx containers,compatible with 2.8).
*** Error in `OCPNsenc': corrupted size vs. prev_size: 0x01077240 ***
Avbrutt (SIGABRT)
pi@openplotter:/usr/bin $ 

I belive it is because the S-63 plugin was compiled before 3B+was released. But as I don't know, I'm posting this to see if you're able to help.

Attached is the OpenCPN log file.

Attached Files
.txt   opencpn.txt (Size: 6.39 KB / Downloads: 0)

  no rudder feedback
Posted by: kalle - 06-05-2018, 09:11 AM - Forum: General discussion - Replies (4)

I am just testing pypilot with openplotter 1.0.

My setup:

Arduino Nano
Pololu Simpel Motor Controller
MPU 9255
Hydraulic Pump 24 V 20 A
Hall-Effect Rotary Position Sensor output 0,5 - 4,5 V

So far everything is working and the rudder is moving. But I do not get any rudder feedback. On scope and client it is always 0. I also simulated contr. and motor-temp with the same 0 result. Simulated current and voltage show up. Instead I could use end-switches but more complicate and I still have the position sensor from my arduino autopilot project. Any ideas?

Another question, what do the gains D2, FF, DD and PR stand for?

BTW there is a bug in the ocpn-pypilot-controller in manual mode the rudder is moving in the wrong direction. in AP mode everything ok.


  Send info from MPU9250 with a ESP32
Posted by: Pkarl45 - 06-05-2018, 07:11 AM - Forum: How do I...? - Replies (8)

I have ordered a new compass sensor (MPU9250) to replace my old Raymarine fluxgate compass that never works properly.

Now, I got a problem with the distance from the sensor to my Raspberry(Openplotter) (>5meter) and was thinking maybe I could use a ESP32 to deliver the signals to the Raspberry instead of buying a I2C range extender. What do you think, is it possible? I found this page (https://github.com/natanaeljr/esp32-MPU-driver)

  [SOLVED] OP not starting
Posted by: MatsA - 06-05-2018, 05:51 AM - Forum: Bug Reports - Replies (4)

Using RPi 3 and OP V1. Starting OP from Terminal

$ openplotter
Traceback (most recent call last):
  File "/home/pi/.config/openplotter/openplotter", line 3940, in <module>
  File "/home/pi/.config/openplotter/openplotter", line 228, in __init__
  File "/home/pi/.config/openplotter/openplotter", line 749, in read_wifi_conf
    wififile = open(self.conf_network+'/'+self.bak_net_sys+'/hostapd/hostapd.conf', 'r', 2000)
IOError: [Errno 20] Not a directory: '/home/pi/.openplotter/Network/._.DS_Store/hostapd/hostapd.conf'

I have changed "Network mode" to "client" avoiding starting wifi, and upgraded RPi OS.
Any ideas ? 
Thanks /Mats

  Pypilot motor controller
Posted by: quetzal - 06-05-2018, 04:09 AM - Forum: General discussion - Replies (10)


Is this motor controller https://pypilot.0337ml-user.freehosting....duct_id=50 opensourced ? I want to build one to test pypilot with my very old ah2000 drive unit, but I wasn't able to find schemes.

Thanks !

  [SOLVED] OpenGL not Selectable
Posted by: Tigress - 06-04-2018, 10:07 PM - Forum: Bug Reports - Replies (2)

Installed new 1.0.0 on my RPI 3B+ with no issues, and most functions working better than .17. One problem that has surfaced is that I can no longer select "Use Accelerated Graphics (OpenGL)" on the OpenCPN Display/Advanced dialog. I know this is not directly an OPL function, but am wondering if others have seen this as well. It was working with previous versions including .17. Thanks.

  What is Openplotters Passwort for admin (su or sudo)
Posted by: waldmattis - 06-04-2018, 03:54 AM - Forum: How do I...? - Replies (5)

Good morning.
What is Openplotter's password for the administrator account?
In the documentation I find only the password for the user "pi".

I need the administrator password because I need to create a new folder on the SD card.
This is denied to the user "pi".
Thanks to all who try to help.

  How to find license file for O-charts charts
Posted by: LaMare - 06-04-2018, 02:54 AM - Forum: How do I...? - Replies (6)

Hi, when I am on the web site for O-chart and want to register a new hardware, I have to find the license file on my RPI. How do I do that when I can't see the hidden libraries? I have managed to install anyway by making /.opencpn visible and copying the license file to the desktop from where I could insert it for the O-charts page.
How do the rest of you handle this? Is it supposed to work this way? Maybe a question for the OE-senc plugin?


  GPIO Pins
Posted by: Lazzz - 06-04-2018, 01:31 AM - Forum: General discussion - Replies (2)

I have just installed the new version, thanks for a big effort Sailoog & friends, but I cannot connect to my GPIO pins.

The pins I am using don't show in the drop down list.

I read somewhere that the Actions aren't working yet is it the same for the GPIO pins or is it me??

Smile Please be patient with WIFI problems
Posted by: Luckbert - 06-03-2018, 08:21 AM - Forum: General discussion - Replies (2)

Hello, everybody,

The problems related to WiFi in version 1.0.0 are known e-sailing and sailoog.  I am sure that there will be an update as soon as possible and we will continue testing together and have fun. 
Please be patient and wait for the update. 
Greetings Jürgen Blush