Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Forum Statistics
» Members: 1,480
» Latest member: ellagould
» Forum threads: 720
» Forum posts: 4,362

Full Statistics

Online Users
There are currently 40 online users.
» 1 Member(s) | 39 Guest(s)
Luis Palha

Latest Threads
OpenPlotter does not work...
Forum: General discussion
Last Post: paulg567
7 hours ago
» Replies: 7
» Views: 192
BMP180 Pressure Sensor
Forum: General discussion
Last Post: Sailoog
8 hours ago
» Replies: 1
» Views: 48
Install the second wifi
Forum: How do I...?
Last Post: Sailoog
8 hours ago
» Replies: 1
» Views: 65
Raspberry Pi 3 Hardware U...
Forum: General discussion
Last Post: verkerkbr
Today, 07:46 AM
» Replies: 5
» Views: 268
@mxtommy KIP instrument d...
Forum: General discussion
Last Post: PaddyB
03-17-2018, 10:26 AM
» Replies: 26
» Views: 1,721
RPI, OpenCPN and buzzer
Forum: General discussion
Last Post: Douz
03-17-2018, 08:18 AM
» Replies: 20
» Views: 505
Installing Charts
Forum: How do I...?
Last Post: Luckbert
03-17-2018, 05:31 AM
» Replies: 1
» Views: 42
action alert on pressure ...
Forum: How do I...?
Last Post: all1p
03-16-2018, 11:15 AM
» Replies: 5
» Views: 73
UDP Issues - UDP message ...
Forum: How do I...?
Last Post: PaddyB
03-16-2018, 10:19 AM
» Replies: 2
» Views: 151
Openplotter and iKommunic...
Forum: How do I...?
Last Post: holgerw
03-16-2018, 09:48 AM
» Replies: 1
» Views: 46

  Google Mail not working any more since 12.Feb 2017
Posted by: Alpenskipper - 02-13-2017, 11:25 AM - Forum: Bug Reports - Replies (9)

I run OP on my boat unattended to transmit environment data and motion alarms.

Until 11. Feb 2017 OP sent all reports via GoogleMail very stable.
Since 12. Feb 2017, OP does not send mails anymore.

I am shure, I did not change anything.

I still can access the Pi from remote via SSH and transfer files via FTP.

The sensor data is correctly written in weather_log.csv.

My GoogleMail login data is still working, I can send mails via the Webbrowser at home.

"Allow unsecure Apps" in the Google settings is still activated.

I also tried a new Google account - same problem.

I guess, the problem has to do with a change within GoogleMail.

Any idea how to solve this or any idea for a workarround that I could use over SSH?


  ADS1115 works in only one input
Posted by: kste - 02-10-2017, 05:38 PM - Forum: Bug Reports - Replies (2)

I use GY-ADS1115 with openplotter 0.9
ADS1115 works in only one entrance, the first active entry into the openplotter_analog.conf file.
If all inputs are active=1 only works the first
if the first input the are active=0 only works the second ...

  Autopilot remote hack
Posted by: Saqqara - 02-10-2017, 03:04 PM - Forum: General discussion - Replies (2)

I finally found a pinout today to control my ancient Autohelm 4000 by a relay board. I'm sure wired remotes of other autopilots could also be reverse engineered.


If controlling with a wireless remote isn't enough fun, I'm considering tying it into openplotter via relays, since I have the hardware for that on hand.

I expect it's a quantum leap from simply controlling GPIO to pulse a relay to sailing to a waypoint, correcting a cross track error, or steering an apparent wind course based by pulsing +/- 1 or 10 degrees, but one can dream!

  Soft buttons (on web page)
Posted by: Saqqara - 02-10-2017, 02:48 PM - Forum: Feature Requests - Replies (3)

This is one we've discussed on other forums, but I figured I'd repeat it here.

The ability to trigger actions by buttons begs for a web page that can be accessed by a smartphone or browser anywhere on board or around the world.

I see this recipe I may tinker with if I get time:

and there is an iOS app or two that can control GPIO. It looks easy to implement. Of course a proprietary solution doesn't befit openplotter.



  ADS1115 Configuration file
Posted by: kste - 02-10-2017, 02:08 PM - Forum: How do I...? - No Replies

I use openplotter 0.9
The explanation of the variables to be set in the configuration file are few and wonder if can get more information:

gain =

samples =

ohmmeter =

fixed_resistor =

high_voltage = 3000
this serves only in ohmmeter=1 or also for other measures?

voltage_divider =
I have not seen changes by varying this parameter .... what is it?

upper_resistance =
lower_resistance =

adjust =
as you set?

  AIS Output?
Posted by: ottow - 01-28-2017, 04:01 PM - Forum: How do I...? - Replies (2)


Can Openplotter be set to output AIS data on NMEA 0183? If so, how?



  Generate custom NMEA0183 sentence in v0.8
Posted by: Littlechay - 01-23-2017, 03:33 AM - Forum: How do I...? - Replies (3)

Hi all,

Just started seriously playing with OpenPlotter as I have decided to build myself some dedicated hardware. I am running a RPi 3 with OpenPlotter 0.8 with so far a GPS shield a BMP180, HTU210 and an IMU9 9-DOF. All working as advertised. 

I have some temperature probes to add and will soon be adding an RTC module

I have a 800x600 touchscreen but the touch doesn't work - I suspect the USB interface but I'm not worried about that as I don't like touch screens at sea anyway so will use operate it with a waterproof keyboard and trackball. 

Currently in the process of designing and building a high efficiency DC - DC converter to power the PI from 12V  and housing it all in what will be reasonably water resistant housing. 

Now to my question. I want to feed temperature and pressure into OCPN. v0.8 of OP generates the $OSXDR NMEA0183 sentence but OCPN does not handle that so I'd like to generate different sentences appropriate to OCPN (MTA for temperature for example). How do you change the sentences generated by OP is there a hidden interface somewhere? 

I see the in the current manual for 0.9 there does seem to be some form of interface for cusomising sentences but I don't want to play with v0.9 yet because I don't currently have the download capacity or want to play with an alpha version while I am still building and testing hardware. 

I have looked at the OCPN plugin "NMEA Converter" or some similar name but it can't handle multiple instances of the same sentence carrying differing information fields so can't process OSXDR in this case. However if I can change the name of the sentence I can probably process it the NMEA converter plugin. 

Thanks in advance Smile

  rapsberry pi hangs up due to an action in OP
Posted by: Kielzorg - 01-22-2017, 03:22 PM - Forum: Bug Reports - Replies (4)

I have OP 0.9 running on a rasperry pi 3
connected a 1 wire temperature sensor succesfully: good read out and good reactions.
I wanted to do some experiments with actions.
As a test i wanted to show a message  (=25) if the temperature is getting above 25 C.
this this action completely hangs up de pi3 (processor usage 100%)
If I restart the Pi and OP, the action immediately starts again, and I see the usage of the proccesor rising untill 100% and then it hangs again
I have have been able to disable the action and even remove it during this first minute after restarting. but still the action seems to be active.
I I now just start up the pi (and not OP) after a about one minute I get the message (=25) and the pi hangs up.

Is there a way of editing an action before start up?

thank you,

  Error 111 Failed to connect with localhost: 10110
Posted by: Luckbert - 01-20-2017, 07:27 AM - Forum: Bug Reports - No Replies

Hallo alle zusammen , 
ich habe ein anderes Problem nach der Installation des touchdriver. Der Inspektor meldet das folgende Problem. 
Fehler beim Verbinden mit localhost: 10110. Fehler: 111 versuchen, die Verbindung wiederherzustellen. 

Alle diese Fehler werden vom Treiber verursacht. 
Bitte helfen Sie mir mit dieser Angelegenheit. 
Viele Grüße Jürgen

  Power off the pi.
Posted by: dreuf - 01-17-2017, 07:43 AM - Forum: General discussion - Replies (15)

Normally when I leave my boat I flip the mainswitch to be shure all my 12v consumers are off.
I dont know how good this is for the ras-pi to be shut off by power and not by SW.

How do you do it? 
Or do you leave ras-pi running all the time? Would the powerconsumption be so low so its better to connect it past the mainswitch?
I also like to view my temperatures and so on from home on the boat, so this winter my pi is running on the 230v..
During the summer I use the boat minimum one time ever week.