Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Forum Statistics
» Members: 1,274
» Latest member: emecypi
» Forum threads: 640
» Forum posts: 3,853

Full Statistics

Online Users
There are currently 45 online users.
» 0 Member(s) | 45 Guest(s)

Latest Threads
cheap N2K sensors ?
Forum: General discussion
Last Post: Kawanager
6 hours ago
» Replies: 1
» Views: 41
OP USB manager tab : USB ...
Forum: Bug Reports
Last Post: e-sailing
9 hours ago
» Replies: 1
» Views: 40
Anchor Watch
Forum: Feature Requests
Last Post: ASSA
9 hours ago
» Replies: 3
» Views: 38
Forum: How do I...?
Last Post: pandroid
11 hours ago
» Replies: 8
» Views: 72
Introducing OpenPlotter h...
Forum: General discussion
Last Post: Rooney
Yesterday, 10:06 AM
» Replies: 53
» Views: 7,017
CAN USB - Where to buy?
Forum: General discussion
Last Post: Alpenskipper
Yesterday, 08:36 AM
» Replies: 11
» Views: 1,116
[FR] Translation status
Forum: Documentation
Last Post: JeanRCA
Yesterday, 05:23 AM
» Replies: 10
» Views: 1,306
IMU not starting
Forum: General discussion
Last Post: barney2074
Yesterday, 03:01 AM
» Replies: 0
» Views: 28
BME980 Use on OpenPlotter
Forum: General discussion
Last Post: Polos
01-18-2018, 01:28 AM
» Replies: 2
» Views: 76
Send nmea0183 to ethernet...
Forum: How do I...?
Last Post: svtgd
01-17-2018, 10:50 PM
» Replies: 0
» Views: 39

  Upgrade to OP 0.8.0 failed
Posted by: affinite - 03-26-2016, 10:59 AM - Forum: How do I...? - Replies (5)

I just tried an upgrade (on my RPI3)  to OP 0.8.0 from 0.7.1 using instructions on openmarine.net.

Failed as below

pi@openplotter:~ $ python /home/pi/.config/openplotter/openplotter.py
Traceback (most recent call last):
  File "/home/pi/.config/openplotter/openplotter.py", line 18, in <module>
    import wx, sys, os, subprocess, webbrowser, re, json, pyudev, time
ImportError: No module named pyudev
pi@openplotter:~ $ 

Any ideas sailoog ?

Lightbulb Introducing "keywords" feature
Posted by: Sailoog - 03-26-2016, 10:18 AM - Forum: Feature Requests - Replies (4)

As you might know OpenPlotter provides multiple defined actions:

stop NMEA multiplexer
reset NMEA multiplexer
stop Signal K server
reset Signal K server
stop WiFi access point
start WiFi access point
stop SDR-AIS
reset SDR-AIS
publish Twitter
send e-mail
send SMS
play sound
stop all sounds
show message
close all messages
start all actions
stop all actions
set output to High
set output to Low

These actions can be triggered by comparing a custom value with any of these defined magnitudes:

Magnetic Variation
Magnetic Heading
True Heading
Course Over Ground
Speed Over Ground
Speed Trought Water
Water Depth
Apparent Wind Angle
True Wind Angle
Apparent Wind Speed
True Wind Speed
True Wind Direction
Air Pressure
Air Temperature
Air Relative Humidity
Rate of Turn
multiple 1W sensors temperature
multiple switches status
multiple outputs status

"Keyword" is a new trigger. When OpenPlotter receives a Keyword from any source, you could trigger any actions. Keywords are strings defined by user and are source agnostic. We could get a keyword remotely or locally by SMS, gmail, Twitter, OpenCPN and from web/phone apps through OpenMarine cloud.

SMS: Connect your phone or GSM dongle to OpenPlotter. A daemon will check when a SMS containing a keyword has been received and will trigger the defined actions for that keyword.

Gmail: Configure OpenPlotter to check a gmail account with a subject containing a keyword.

Twitter: Configure OpenPlotter to check a Twitter account with a Tweet containing a keyword.

OpenCPN: The plugin Watchdog provides an excellent way to set alarms for anchor, landfall, deadman, boundary... We could configure OpenCPN to send a keyword to OpenPlotter and trigger any actions when an alarm is activated.

OpenMarine: As you might know we are working on a free cloud server to act as bridge between OpenPlotter and Web and phone apps. You could get a keyword from any app in real time and trigger the defined actions for that keyword.

Keywords not only could work as triggers, they could work also as actions. So, we could send keywords by SMS, gmail, twitter, and OpenMarine to any app capable of manage these keywords.

Amazing, isn't it?

  Update from github in gui
Posted by: joabakk - 03-25-2016, 07:59 PM - Forum: Feature Requests - Replies (4)

It would be great if there was a way to update all the dependencies from the gui, as there are a lot of good things happening these days on kplex, openplotter and signal k

  Analog motor sensors
Posted by: manitu - 03-24-2016, 02:15 PM - Forum: Feature Requests - Replies (12)

Is it possible to connect openplotter to resistive motor sensors?  would be great to get coolant temp, oil pressure , turbo pressure and so on. and stndard tank sensors.

Most sensors operate in a 0-500 ohms range , 10-180 being most common in europe , while  240-30 ohms is most common in the US

here are the faria sensor values:http://faria-instruments.com/site_manuals/IS0085E.pdf

Both 2-wire sensors and one wire (resistance to ground) sensors should be supported , but either one would do.

Come to think of it; what about making a Rpi zero signalK motor interface??

Keep up the great work.


  HTU21D humidity value
Posted by: Swokey - 03-22-2016, 09:46 AM - Forum: How do I...? - Replies (5)

I still have a lot of fun with openplotter. Now I'm using it for a new project (creating mine own drying place for meat).  I allready have tried a lot, but I don't have a solution yet. So if anyone can help me it would be great.

The action/triggers are not a solution because I need to combine several input before I do an action.

I need the output of the humidity from the HTU21D. When I use it with openplotter I see the NMEA sentence with the correct value. So I extracted the code from the i2c.py file with that what I think need.

Why don't get I the humidity?


import socket, time, pynmea2, RTIMU, math, csv

humidity_val = RTIMU.RTHumidity(s3)
humidity_val_b = True




print hum



Kind regards

  OpenPlotter v0.7.1beta working
Posted by: sanrab - 03-22-2016, 05:08 AM - Forum: General discussion - Replies (5)

I'm testing OpenPlotter v0.7.1beta.

Raspberry Pi 3 Mod. B and Raspberry Pi 2 B

Seatalk-NMEA bridge

Holux GPSlim236 Bluetooth GPS receiver
NooElec DVB-T USB Stick for AIS

everything seems to work without problems. Nice job !


Bug Calibration failed
Posted by: Didier B - 03-21-2016, 06:20 AM - Forum: Bug Reports - Replies (11)

Hi all Openplotterists !

My config : Rpi2, V7.1beta, connected sensors : MPU9150, BMP180, HTU21, DS18B20 (2)

I couldn't calibrate properly the magnetometers of my MPU9150, Once I got more than 200 counts in each of the counters, I started the ellpsoid phase which terminated quickly, with a message :
      Failed to execute RTEIIipsoidFit.m. Only
      min/max calibration available

I remember having seen a thread on that matter, but couldn't find it ...
2 - I could register on OpenMarine, and posted same thread, which one to favour for bug reporting.

  OpenPlotter getting SAR aircraft AIS signal with SDR dongle
Posted by: Sailoog - 03-18-2016, 03:40 PM - Forum: General discussion - Replies (5)

These small devices are really effective... 5 min ago:


  Feature list
Posted by: Vamonos - 03-17-2016, 04:01 PM - Forum: Feature requests - Replies (3)

Items to monitor:
All of the below items would have triggers associated with them that would generate an alert (emal or SMS) if a threshold is reached.

  • (2) DC voltages 24 V (or higher?)  What precision?

  • (3) temperature probes (ambient inside, outside, refrigerator) or more?

  • (1) AC mains voltage monitor

  • Lat/Lon of boat

  • (?) digital inputs for bilge pump cycling, refrigerator compress cycling, etc.

  • (4) GPIO that can drive a relay board to turn on peripherals such as Air Conditioning or Heat, bilge pump, lights, etc.

  Nmea 0183 Serial Adaptor Problem
Posted by: Giulio78 - 03-17-2016, 03:59 PM - Forum: How do I...? - Replies (14)

I have:
Raspberry 2
Open Plotter 0.6.0
2 wifi Dongle
1 DVB/T Dongle
1 Hub 7 port
1 Nmea 0183 adaptor connected with Raymarine C90W (C90W Nmea Output with R+ and R- on the serial adaptor)
OpenPlotter The Inspector wrote: Connected with localhost:10110.Error:timed out, waiting for data.
The serial adaptor have green led (switch light green and dark green) but openplotter cant' received any data.
In openplotter i have:
system_input UDP 10110 none nothing
nmea SERIAL /dev/ttyUSB0  4800 none nothing
system_output TCP localhost 10110 none nothing
Could you help me?
Sorry for my english
Best Regards