OpenMarine
Documentation links not working? - Printable Version

+- OpenMarine (http://forum.openmarine.net)
+-- Forum: OpenPlotter (http://forum.openmarine.net/forumdisplay.php?fid=1)
+--- Forum: General discussion (http://forum.openmarine.net/forumdisplay.php?fid=2)
+--- Thread: Documentation links not working? (/showthread.php?tid=1690)



Documentation links not working? - Bill_ Maxwell - 03-01-2019

I am a newcomer, setting up 2 RPi3B+ with OpenPlotter. I have both installs working but am having some difficulties in completing the setups, because some of the pages in the Documentation are without content, just giving the buttons to go forward to the next page or backwards to the previous page. Examples include "Charts", which would seem fairly significant, Signal K Server, Diagnostics, Signal K to NMEA0183 etc. etc. I have had this problem for the past week. Are the links perhaps broken? Huh


RE: Documentation links not working? - jim321 - 03-02-2019

here is a link to the old documentation most of it is still the same some tabs have changed
https://sailoog.gitbooks.io/openplotter-documentation/content/en/
the newer doc's have never gotten to completion but use them for networking .
https://docs.sailoog.com/openplotter-v1-x-x/kplex
opencpn manual
https://opencpn.org/wiki/dokuwiki/doku.php?id=opencpn:opencpn_user_manual
signalk
http://signalk.org/specification/1.0.4/doc/signalk.pdf
nodered
https://nodered.org/docs/
mqtt
https://github.com/mqtt/mqtt.github.io/wiki
kplex
http://www.stripydog.com/kplex/configuration.html
as you can see openplotter is made up of several programs working togather..


RE: Documentation links not working? - Sailoog - 03-02-2019

I am afraid this is not an error Sad

Documentation has been always our weak point. Our time/people/money are limited and we have always prioritized development over documentation, now we know that this is a big error. This is not going to happen anymore, OpenPlotter v2.x.x will come with full online and offline documentation.

someday I will publish a post with status, improvements and news about v2.x.x.


RE: Documentation links not working? - Bill_ Maxwell - 03-02-2019

Great news about OpenPlotter 2, many thanks. Thanks for your assistance too, Jim321.

Bill


RE: Documentation links not working? - Sderbyshire - 03-15-2019

Hi Guys

I'm coming back to this after a break, have been using my Pi2 with openplotter successfully for a while on my X-46

Now i'd like to set up a new Pi3B+ that's been sitting in a drawer for a while with Openplotter

what's the bet way to proceed with a completely fresh build, ie what do i download ??

regards

steve


RE: Documentation links not working? - jim321 - 03-15-2019

http://sailoog.com/blog-categories/openplotter-rpi


RE: Documentation links not working? - Bill_ Maxwell - 03-15-2019

I think the best approach would be the fresh Image installation, then updating, as set out in the replies to my recent other post on Updating problems on the RPi 3B+

Bill


RE: Documentation links not working? - Sderbyshire - 03-15-2019

(03-15-2019, 05:36 AM)Bill_ Maxwell Wrote: I think the best approach would be the fresh Image installation, then updating, as set out in the replies to my recent other post on Updating problems on the RPi 3B+

Bill

Thanks

I downloaded the 1.0 img
Installed fine
Tried to upgrade to 1.2 but it failed with an error on hostapd

Any suggestions on how to move forwards?

Steve


RE: Documentation links not working? - Bill_ Maxwell - 03-15-2019

I haven't trid the Image install approach yet, as I'm away from a monitor at the moment. I think though that hostapd was also covered in the responses I received on my other thread?

Bill