OpenMarine
OP2 pypilot 2.0.6 RPI4 - Printable Version

+- OpenMarine (http://forum.openmarine.net)
+-- Forum: OpenPlotter (http://forum.openmarine.net/forumdisplay.php?fid=1)
+--- Forum: Bug Reports (http://forum.openmarine.net/forumdisplay.php?fid=4)
+--- Thread: OP2 pypilot 2.0.6 RPI4 (/showthread.php?tid=2331)



OP2 pypilot 2.0.6 RPI4 - ddelorme - 02-14-2020

Sooo
I noticed we have the sailboat in the calibration screen,
and when the system restarts it activates the actuator? it jammed mine a bit since it is just sitting on the desk.. all good.
is that a auto centre feature?

just as it started i was thinking it would be nice for testing to link the rudder sensor to the actuator.
i guess i will set up a fake rudder for testing with a pot for the pintel
What going on dude, any thing else we should knowSmile 
Also a lot more status messages on the control screen.


RE: OP2 pypilot 2.0.6 RPI4 - seandepagnier - 02-14-2020

I suggest posting on pypilot forum, but basically there is no autocenter feature unless you click the "center" button. I"m not sure what is going on, but pypilot should never move the motor unless engaged or a manual command.


RE: OP2 pypilot 2.0.6 RPI4 - Opie91 - 02-15-2020

(02-14-2020, 10:46 PM)seandepagnier Wrote: I suggest posting on pypilot forum, but basically there is no autocenter feature unless you click the "center" button.   I"m not sure what is going on, but pypilot should never move the motor unless engaged or a manual command.

Sean,

I have noticed a similar thing. If you restart the pi or nano the actuator clutch clicks a few times, but the actuator does not move.

Messed around with it a bit and it appears when the clutch clicks a few times when the serial connection between the pi and the nano is made.


RE: OP2 pypilot 2.0.6 RPI4 - seandepagnier - 02-15-2020

Does it click a few times or just once?

Which motor controller are you using?


RE: OP2 pypilot 2.0.6 RPI4 - Opie91 - 02-15-2020

It clicks a few times. On-off-on-off
Using a VNH5019


RE: OP2 pypilot 2.0.6 RPI4 - ddelorme - 02-15-2020

I did a second reboot and it stop... I dont know what happend


RE: OP2 pypilot 2.0.6 RPI4 - seandepagnier - 02-15-2020

(02-15-2020, 11:42 AM)Opie91 Wrote: It clicks a few times. On-off-on-off
Using a VNH5019
Is this the clutch output (pin 11) correct?


How are you using the clutch?   Normally there is a series resistor and pulldown resistor to a mosfet gate.   The pulldown resistor normally would prevent the clutch enabling at startup, but the code could be improved as well.


RE: OP2 pypilot 2.0.6 RPI4 - Opie91 - 02-15-2020

Yes using pin 11.

Series and pulldown resistor as per your hydraulic sketch. I am using an n-channel mosfet gate (what I had around)