OpenMarine
Star of the Orient - Printable Version

+- OpenMarine (http://forum.openmarine.net)
+-- Forum: OpenPlotter (http://forum.openmarine.net/forumdisplay.php?fid=1)
+--- Forum: How I did it (http://forum.openmarine.net/forumdisplay.php?fid=6)
+--- Thread: Star of the Orient (/showthread.php?tid=952)



Star of the Orient - Saqqara - 01-14-2018

This isn't so much a "Brag" as a confession. This isn't pretty. I post this in hope that folks will advise ways to make this cleaner and easier to work with. I have not done much electronics tinkering, and lack craftsmanship.

My boat came with a set of dead Datamarine instruments. I had all of the old transducers removed and glassed over when I last hauled the boat. In retrospect I wish I had tried to save the paddle wheel. It also has an older 5 inch Garmin chartplotter with sounder.  I  also have a USB GPS dongle for location, but the Garmin is my only source of NMEA depth; it has a transducer epoxied inside the hull. I  use the Garmin at the helm, augmented by tablets and smartphones (Wilhelm SK on iOS is a brilliant app for instrument data). I don't have one of those newer angled pedestal guardrails, so I fashioned this arm that sets the GPS back freeing up room to mount gadgets.  

[Image: d4fdlPK5GuV9jWBAQWjPLqUTA20g9ol104TxRJe9...12-h950-no][Image: F5iKGGK6oCYfJHOxPl-IE-ceZDjd1Ox0dDWTcRWb...34-h949-no]

I added a masthead NMEA wind instrument, from Nasamarine. It didn't last long before water entered it and shorted/rusted out the electronics. I ordered a new circuitboard and gasket from England, and sealed some problem areas with silicone. This time it has lasted much better. I don't like the process of aligning it - shorting a couple of wires while the vane is pointed dead ahead - and wish there was a software offset in Openplotter for wind direction. 

When I pulled out the Datamarine instruments I saved the enclosure that was used for the "brain" of the system. Since there was a big hole cut in my hull liner for it, I thought it might be good to store the Pi there. I replaced the front (top, as I have it oriented) panel with a sheet of black hdpe, so I can put buttons and LEDs and such wherever desired. At the moment I have a momentary button I use to shut down the pi, a power LED, and a power switch. It's basically a bin that I shove the hub, the pi and its proto hat, and a wad of wires into. 

[Image: 0uGKuQcwHSPJvzrAqh7KPMBgDuEoMCyVsn_yJkxp...66-h949-no]

[Image: bXkANRJm7dzq492admD6qmy2xNXKnrlOPZWtXilN...12-h949-no]

Hanging out the bottom of that is a brass terminal strip to which I've zip tied some DB9 breakout boards connected to the USB/Serial converters. The power supply and NMEA 0183 feeds from the Garmin and the masthead terminate here. Yeah, it's a mess. But it's all out of sight when I cram it back in the enclosure. 

[Image: TFySpJ5RZAbbvRqMa3wwj3JmObIMPg8mlNFy4snw...66-h949-no]

[Image: SGVJ1J7IhoJ_14ePFG2AHvED_oX2fuJcWhrFwc5U...66-h949-no]
[Image: 29EqRbbssmx33CHz1]
I have the two i2c components, the IMU and humidity sensor, mounted inside an RJ45 surface mount jack, as I have seen others do. I have this screwed to the bottom of a shelf in my nav station so that it is away from interference and heat of the pi. I also run the 1 wire stuff off of here for no good reason.

[Image: CsgDjtPDpnn6ucidiLsNe-5tnnX7qQfZ_otva20K...66-h949-no][Image: rm5xNI5jQepKlDY-JuOSEKEf7GRI1HKziMD6n3lZ...66-h949-no]

I have 4 one wire temperature probes. One is zip tied to the brass engine water intake thruhull. I call that sea temperature. I have one on the engine exhaust, and the radiator, and one in the ice box to monitor the beer temperature. 

On the proto hat I soldered my first surface mount chip... badly. Broke a leg but got the ADC to work. I measure house bank voltage using a little divider breakout. 

Just in front of the nav station I have a TV for the salon. It is on a mount that pivots 90 degrees so that it can face the seating area or serve as a monitor at the nav station. It is also visible from much of the cockpit in that position.

[Image: LONtLEZzMrRgjczEYTe-FuNCaBIsumKMGFIKVv78...66-h949-no]

Very excited to have installed the Kip app for SignalK. FINALLY a practical (and attractive) instrument display for Openplotter. I also think it looks better than anything that is available for Android. Eager to get it customized to my liking.

I have an SDR going to a rail mounted antenna. This has stopped working, can't be enabled in Openplotter, on this trip to the boat. Not sure why. My home PC sees it. For that matter I have a wifi adapter doing the same thing. Seems like it might be the power from the hub is too weak or cables too long. 

Not pictured I have some inductive sensors, as suggested by Ole Saastad, on a water tank. I don't have them working through Openplotter yet. 

Any suggestions for cleaning up the wiring would be appreciated; connectors, busses, etc. 

I am not sure why my boat shows that it is moving a fractional knot most of the time. It started several openplotter versions ago. 

Greg Vaughan
Laguna 33GT "Star of the Orient"
Slidell, Louisiana, USA


RE: Star of the Orient - Saqqara - 01-17-2018

To reduce some of the fragile wiring clutter, and in light of feedback that interference isn't a problem, I have soldered the IMU and Barometer/Humidity sensor to the proto breadboard hat. I'll run spaghetti wire underneath to wire it up. I'll have to figure out how to mount the Pi in a fixed position. Perhaps upside down from the lid of my enclosure. I'm not concerned about screwing up the temperature reading. The Nasamarine NMEA Wind instrument has that, and adding another probe to onewire is not a problem.

[Image: 12994560.jpg]
I am thinking of stacking something like this with the pi. I could put the front panel (switches, buttons and LEDs) on one, the onewire stuff on another, the water level indicators on a third, adc on the last perhaps. Better ideas for interconnecting things?


RE: Star of the Orient - Saqqara - 01-22-2018

Ok, cleaning some things up this weekend. I have a new MPU-9255 IMU and BME280 environmental sensor, so I eliminated the external "puck" arrangement and the extra tangle of wires it required. I soldered it directly to the proto hat and wired it with spaghetti wire underneath. I will need to mount the pi in a fixed location now - I believe I will screw it to the bottom of the lid of my enclosure, hanging upside down. I need a 90 degree HDMI connector first.

[Image: cTlLHeIiJ5Stdae-QFYeyN_fi2zPfiZpzRl-gaT_...66-h949-no]

I cut up an ethernet cord and zip tied the pigtail to the pi, and made all of the connections for the 1 wire and other sensors at a cat 5 keystone. I can remove the pi much more easily now, and everything is less fragile. I also made the lid of my enclosure removable with a phone cord and coupler. 




[Image: 7r-q8__TrPGIjR15KjqqSCxfZCBOyqlpeSvkIFfs...66-h949-no]

I can almost put it all away neatly now, except I am troubleshooting some USB problems still. I seem to have a bad SDR, a bad USB-serial converter, and I don't trust the hub.


[Image: pgh9lpAJRzPdwcTaMkcqefeusj_1ApuZhHzm3se2...12-h949-no]

I hope to get these inductive sensors working soon - at least in Node Red.


RE: Star of the Orient - Havnjero - 01-31-2018

there is only one photo in this thread. i presume there should be more?


RE: Star of the Orient - Saqqara - 01-31-2018

Thanks, my first attempt to post Google photos after years of Photobucket. Apparently the urls expired. I will try to get to the bottom of it soon but working very long hours now.

Sent from my Moto G (5) Plus using Tapatalk