• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
UDP receive and vnc stop working after approx 10 min
#1
Apologies if there is a solution already, I did my best to search but I am new to the community...

I have a Pi 3 running 0.17 ( installed image on card and then ran all updates) 

Pi has a tested good power supply (2.2a), logitech wireless keyboard/mouse dongle attached and an HDMI monitor

I am not using AP mode and instead am connected to the boat's existing wifi using the pi3 integrated wifi. I have another computer on the network running OpenCPN and transmitting all NMEA data over udp.

When the Pi first starts everything is great, the UDP stream is successfully read in and I can connect over VNC. about 10 min later the stream stops coming in and I can no longer connect via vnc however the wifi connection is still good and I am able to use the browser on the pi to view webpages and ping the other machines on network. I have also verified with an additional computer that the udp stream is still being sent at this point, just not seen by pi. The only way to bring everything back at this point is to reboot the pi.

I read several threads about wifi power management and have experimented with turning it on and off with no change in behavior.

Looking forward to any suggestions 

Will
  Reply
#2
(03-10-2018, 02:17 PM)wmrae Wrote: Apologies if there is a solution already, I did my best to search but I am new to the community...

I have a Pi 3 running 0.17 ( installed image on card and then ran all updates) 

Pi has a tested good power supply (2.2a), logitech wireless keyboard/mouse dongle attached and an HDMI monitor

I am not using AP mode and instead am connected to the boat's existing wifi using the pi3 integrated wifi. I have another computer on the network running OpenCPN and transmitting all NMEA data over udp.

When the Pi first starts everything is great, the UDP stream is successfully read in and I can connect over VNC. about 10 min later the stream stops coming in and I can no longer connect via vnc however the wifi connection is still good and I am able to use the browser on the pi to view webpages and ping the other machines on network. I have also verified with an additional computer that the udp stream is still being sent at this point, just not seen by pi. The only way to bring everything back at this point is to reboot the pi.

I read several threads about wifi power management and have experimented with turning it on and off with no change in behavior.

Looking forward to any suggestions 

Will

Welcome aboard, Will.  Cool

So the NMEA data is coming from the other computer? 
How have you set up openplotter to get the UDP stream - is that in the nmea0183 tab? 

That's basically a front end for a prog called Kplex which does the routing work - does restarting help? 

Also, you can highlight the line which sets up the UDP coming in and see if there is any data by pressing diagnostic.

And you can start openplotter in debugging mode as well in the Pi openplotter menu which will show any debug messages if something goes wrong.
  Reply
#3
(03-10-2018, 04:04 PM)PaddyB Wrote:
(03-10-2018, 02:17 PM)wmrae Wrote: Apologies if there is a solution already, I did my best to search but I am new to the community...

I have a Pi 3 running 0.17 ( installed image on card and then ran all updates) 

Pi has a tested good power supply (2.2a), logitech wireless keyboard/mouse dongle attached and an HDMI monitor

I am not using AP mode and instead am connected to the boat's existing wifi using the pi3 integrated wifi. I have another computer on the network running OpenCPN and transmitting all NMEA data over udp.

When the Pi first starts everything is great, the UDP stream is successfully read in and I can connect over VNC. about 10 min later the stream stops coming in and I can no longer connect via vnc however the wifi connection is still good and I am able to use the browser on the pi to view webpages and ping the other machines on network. I have also verified with an additional computer that the udp stream is still being sent at this point, just not seen by pi. The only way to bring everything back at this point is to reboot the pi.

I read several threads about wifi power management and have experimented with turning it on and off with no change in behavior.

Looking forward to any suggestions 

Will

Welcome aboard, Will.  Cool

So the NMEA data is coming from the other computer? 
How have you set up openplotter to get the UDP stream - is that in the nmea0183 tab? 

That's basically a front end for a prog called Kplex which does the routing work - does restarting help? 

Also, you can highlight the line which sets up the UDP coming in and see if there is any data by pressing diagnostic.

And you can start openplotter in debugging mode as well in the Pi openplotter menu which will show any debug messages if something goes wrong.

NMEA data is coming from the other computer via UDP, I set it up in the nmea0183 tab and it is working when the pi first starts

using the diagnostic window shows the stream when the pi first starts but after a while (roughly 10 min, going to time it this evening) it stops 

restarting kplex (restart button on nmea0183 tab) doesn't restore the stream

when the stream is lost the wifi still works for pinging and web browser

i will try debugging mode next and see if the log provides any insight.
  Reply
#4
(03-11-2018, 06:33 PM)wmrae Wrote: NMEA data is coming from the other computer via UDP, I set it up in the nmea0183 tab and it is working when the pi first starts

using the diagnostic window shows the stream when the pi first starts but after a while (roughly 10 min, going to time it this evening) it stops 

restarting kplex (restart button on nmea0183 tab) doesn't restore the stream

when the stream is lost the wifi still works for pinging and web browser

i will try debugging mode next and see if the log provides any insight.

Hmm, sorry might be beyond me. Another thing you can try -
Ever used node red? It can be a really useful debug tool. 

On the Pi look at 10.10.10.1:1880 then press control 'i' to insert and copy / paste the code below and press deploy. Hopefully that should give you a little piece of node-red which looks for UDP on a port and displays anything coming in it in a debug window, need to turn off kplex looking at the port in the nmea tab . Might let you see if any UDP messages are still coming in but just getting lost somewhere. When you deploy then new code if something else is reading that port you'll get an error message. 

(node red will be faster on the laptop, you can see it there but finding the Openplotter IP address in the Wifi AP tab and using that IP address :1880)

Sorry , bit low on detail but lots node red help on the web, & you seem to know what you're talking about.  Cool

Code:
[
   {
       "id": "1808badf.4316d5",
       "type": "udp in",
       "z": "3f30ea31.da3756",
       "name": "",
       "iface": "",
       "port": "55557",
       "ipv": "udp4",
       "multicast": "false",
       "group": "",
       "datatype": "utf8",
       "x": 295,
       "y": 892,
       "wires": [
           [
               "b6f00441.812bd8"
           ]
       ]
   },
   {
       "id": "b6f00441.812bd8",
       "type": "debug",
       "z": "3f30ea31.da3756",
       "name": "",
       "active": true,
       "console": "false",
       "complete": "false",
       "x": 570,
       "y": 880,
       "wires": []
   }
]
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)