This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mikrotik Groove and Openplotter
#1
I'm having an issue trying to set up my Mikrotic Groove wifi extender with openplotter. I've managed to get it working connected directly to my win10 laptop using a static IP of 192.168.88.2
Subnet Mask         255.255.255.0
Gateway               192.168.88.1
DNS                      192.168.88.1
I was the able to access the groove using winbox (a windows utility provided by Microtik)

I'm both a linux and networking noob, but I was able to set up the same static IP in openplotter and was able to access the Groove via http://192.168.88.1/webfig/ which appears to be very similar to winbox but works outside windows.

I was able to view a list of available wifi networks but when I selected one and gave the password then tried to connect all I got was a status of searching and nothing happened.

I'm wondering if this might be a permissions thing in Openplotter that I'm doing wrong, or possibly something in the firewall that's stopping connection.

Does anyone have any ideas?

Any help would be greatly appreciated.

Colin
  Reply
#2
laptop using a static IP of 192.168.88.2 OK
Subnet Mask 255.255.255.0 OK
Gateway 192.168.88.1 will be assigned by the ap you are connecting to typically 192.168.1.1
DNS 192.168.88.1 use google dns 8.8.8.8 or 8.8.4.4 also could be assigned as above

https://forum.mikrotik.com/viewtopic.php?t=92112

i use an Alfa AWUS036NH connected to the usb hub it draws 450mv to connect to ap's, i just looked to see available connections it showed 46 of them ..i use the onboard wifi for the boat ap sensors tablet ect.. and share with the connected alfa in openplotter. these are one of the best wifi adapters its 2 watt and long range. so basically it does the same thing as an extender.you can use any usb wifi dongle to do the same thing.
mare liberum
  Reply
#3
OK as an update, I got the Groove connected to RPi and was able to connect to the inhouse wifi here and get internet OK.
Next I tried connecting the win10 laptop to the openplotter wifi network, this also worked fine and I can control the RPi through VNC and get internet via the browser on the RPi. What I haven't got is the internet directly from the openplotter wifi connection. Any ideas why this might not be working.

Thanks.
Colin
  Reply
#4
the way it is now "openplotter" you need two networks one to connect to internet the other to be openplotter network.
either connect to the groove thru wired and bridge eth0 under wifi tab.or use a usb wifi adapter to connect to either groove or inhouse wifi and under the same tab pick the usb from the dropdown share internet device .ex wlan1
the groove thing is not necessary and just puts more complexity in the network..
all of this will be changed SOON in the next release .. you will be able to use the onboard wifi for both internet and ap"openplotter net"
mare liberum
  Reply
#5
(05-19-2018, 03:25 PM)jim321 Wrote: the way it is now "openplotter" you need two networks one to connect to internet the other to be openplotter network.
either connect to the groove thru wired and bridge eth0 under wifi tab.or use a usb adapter to connect to either groove or inhouse wifi and under the same tab pick the usb from the dropdown share internet device .ex wlan1
the groove thing is not necessary and just puts more complexity in the network..
all of this will be changed in the next release SOON.. you will be able to use the onboard wifi for both internet and ap"openplotter net"

Not sure I understand what you're saying.

To be clear the set up I have a the moment is the groove connected to the Pi via ethernet and providing internet. I have the bridge eth0 tab checked and I'm connecting wirelessly to the Pi onboard wireless. This is how I want to use it on the boat and seems to be working OK except that I can't get the internet on my laptop via the Pi.
Are you saying that this is not something I'm doing wrong but a limitation of Openplotter until the next release.
  Reply
#6
"the groove connected to the Pi via ethernet and providing internet. I have the bridge eth0 tab checked."

that should work... try to reboot is all that i can think to do in this case..

i just looked try to change internet sharing device  to eth0 reboot
mare liberum
  Reply
#7
change internet sharing device to eth0 reboot
did this work??
mare liberum
  Reply
#8
(05-20-2018, 08:20 AM)jim321 Wrote: change internet sharing device  to eth0 reboot
did this work??

Sorry to be so slow replying.

I checked this and the internet sharing device was set to eth0. I assume your talking about the setting on the "Wifi AP" tab of openplotter and not somewhere else.
Since starting this thread I tried updating openplotter and seem to have broken it so I'll need to fix that issue before being able to try anything else here. I've started another thread to try and solve the update problem.
  Reply
#9
I solved the update problems I was having by waiting for OP v1.0 and reloading.
I was able to connect the Pi to the groove via eth0 and have internet on the Pi. The trouble I'm having now is what wifi mode to set so I can connect the laptop to the openplotter network. There are now several options to choose from and I can't find any documentation on the differences.
Thanks for your help.
Colin
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)