This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New OpenPlotter v1.0.0 available!!!!
#31
If your SD card does not accept Sailoog's img file due to size reasons, you can try this other one which is the same version but cutting the empty space to fit on cards smaller than 8.1 GB.
Its download size is 1.56 Gb and unzipped is 5.9 GB.

https://mega.nz/#!BJQDWTCD!aKWMQdO7V0Nui...Qn7hkBroI4
It's not like the sea has such a bad temper.
The real bastard is the wind.
The sea... simply gets carried away.
  Reply
#32
OpenPlotter works great with the OpenGl driver switched on. With latest kernel the GLXgears without the effect of
the display runs at around 1000 Frames per Second (FPS).

I only had a small problem with the startup. The startup sometimes halted at: checking display 800x480. Then the system lock-up and had to reboot..

Perhaps the startup is going too fast.

In the OpenPlotter config I have set the delay at 1 or 2instead of 0. And now with this delay the systems seems to starts without this problem.

Regards,

Bram
  Reply
#33
I have the same problem using the Full KMS driver so I switched to using the software openGL driver and it doesn't hang at the "checking 800x480 display".

I'll try your suggestion and add in a delay.

Thank you
  Reply
#34
(06-03-2018, 01:24 PM)baltika_no_9 Wrote: I have the same problem using the Full KMS driver so I switched to using the software openGL driver and it doesn't hang at the "checking 800x480 display".

I'll try your suggestion and add in a delay.

Thank you

2 seconds delay worked best here. No longer hang-ups at the start of OpenPlotter with full OpenGL driver on.

Latest kernel 4.14.44.
  Reply
#35
Another small problem arises. Sometimes the network (DHCP) does not start. It appears that the Eth0 setting is gone. Changing to a fixed IP addres then the networks starts
as usual.

All on a RPI3B+ and OpenGL driver to full.
  Reply
#36
Unfortunately mine will not boot reliably even with the delay added. Sometimes it works and sometimes not. I will have to keep using the fake KMS.
  Reply
#37
Same thing happens to me half the times. It freezes when display checking resolution screen. I have chosen to override the corresponding lines in the startup script and it seems to be working. It could be a problem related to the monitor we are using because when I have tested it on a headless system it never fails.
It's not like the sea has such a bad temper.
The real bastard is the wind.
The sea... simply gets carried away.
  Reply
#38
I think you're right, it is to do with the monitor. I forced the preferred HMDI resolution of my monitor by making a change in /boot/config.txt and it boots ok every time now with the full KMS driver.

A result!
  Reply
#39
wahouu !!! I am very impressed about all the work you have done and still doing ! Thank you very much !!!
  Reply
#40
Updated to the new build, Problem is I cannot connect to it with either VNC or SSH...... Bug

when I vnc I get:

Connected to RFB server, using protocol version 3.3
No configured security type is supported by 3.3 VNC Viewer

ssh just keeps asking for a password...whats the password???
Buggy build?

I've tried using default passwords like "pi" "raspberry" "root" none work.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)