This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] AP RPi2
#1
Hello,Sailoog,

I got this morning your image, put it onto the SD card, booted and didn't find anymore the Acces-Point. I fiddled around with the diffenrent Options of network tab, especially RPi3 AP + Client and RPi3+ AP + Client, but without success.

My installation is running on a RPi 2, with the Edimax WiFi-Dongle, which worked nicely in 0.17. Do I understand that you changed the whole networking way when you passed to Raspian stretch? Is hostap still the same?

Thanks for some hints.
Christian
  Reply
#2
If you have a Pi2 with only one usb wifi stick, you have to change the udev rules.(With two wifi sticks it should work)
You can try:
"pi@openplotter:~ $ nano .config/openplotter/Network/pi3_wlan1_wlan0/udev/rules.d/72-static-name.rules"
change the line:
ACTION=="add", SUBSYSTEM=="net", DRIVERS=="brcmfmac", NAME="wlan1"
to
ACTION=="add", SUBSYSTEM=="ieee80211", KERNEL=="phy0",NAME="wlan1"
In openplotter you have to select RPi3: AP + client
click set
click apply
click yes
reboot
Now you should have your wlan1 as AP (I hope so)
  Reply
#3
(06-02-2018, 09:13 AM)e-sailing Wrote: If you have a Pi2 with only one usb wifi stick, you have to change the udev rules.(With two wifi sticks it should work)
You can try:
"pi@openplotter:~ $ nano .config/openplotter/Network/pi3_wlan1_wlan0/udev/rules.d/72-static-name.rules"
change the line:
ACTION=="add", SUBSYSTEM=="net", DRIVERS=="brcmfmac", NAME="wlan1"
to
ACTION=="add", SUBSYSTEM=="ieee80211", KERNEL=="phy0",NAME="wlan1"
In openplotter you have to select RPi3: AP + client
click set
click apply
click yes
reboot
Now you should have your wlan1 as AP (I hope so)
Thank you, e-sailing, for the quick answer. As you said, this is a Pi 2B with just one WiFi-Stick.

I tried to change the udev-rules but no luck, the AP didn't show up. any other ideas?

fair winds
Christian
  Reply
#4
Try:

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", KERNEL=="wlan*", NAME="wlan1"
  Reply
#5
(06-02-2018, 12:04 PM)e-sailing Wrote: Try:

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", KERNEL=="wlan*", NAME="wlan1"
Still no success 
[Image: sad.png]

but thanks for your support
Christian
  Reply
#6
Hello e-sailing,

well, I managed to get it to work - by plugging in a second USB-dongle, still lying around in a drawer - so getting wlan0 for client and wlan1 for AP functionality.

additionally I had to add the modification mentioned in https://github.com/sailoog/openplotter/pull/213

But I'd rather work with only one dongle, and on my standalone system I don't need client functionality, only AP. Where do I need to modify the config?

Thanks in advance
Christian
  Reply
#7
Hello,

I appreciate very much your hard work, but this question has been without new answer since ten days.
Are you going to address this issue, or am I on my own?

In my humble opinion it would be useful to have a config for "just AP" as there is a config for "just client", but this is just my idea.

TIA
Christian
  Reply
#8
Just a guess: Did you try changing the device the "Sharing internet device" menu?
  Reply
#9
Hi CottageCruiser,

yes, I tried every combination. 
I guess it didn't work, because the kernel named the interface always wlan0, and the Accesspoint configs in OP are made for wlan1.
One could probably force the kernel via udev and the usb-id, to have wlan1 for this specific dongle, but I didn't dive further into this


In the end I changed the config directly in /etc/* , I have now a working AP. Just hoping any new update won't undo my changes...

Cheers
Christian
  Reply
#10
Ok. I agree with you, that there should be an option for just AP, which would work out-of-the-box, without such tweaks.

Pekka

Lähetetty minun TA-1032 laitteesta Tapatalkilla
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)