This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] WiFi not working.
#1
The WiFi is not working. I tried to set country from GB to US but would not reset, is there an update or work around. This is on the new img file. 1.0.0.
  Reply
#2
For me it works on my Pi 3 using the NOOBS .zip, any hardware changes, other SD card or other power source?
For others with wifi issues, a bug has been recorded: https://github.com/sailoog/openplotter/pull/213
  Reply
#3
You have to set the option that match your hardware configuration, if not, you will get errors.
Check the manual and report your hardware configuration and details of error conditions: https://docs.sailoog.com/openplotter-v1-x-x/network
  Reply
#4
(06-04-2018, 03:50 PM)Sailoog Wrote: You have to set the option that match your hardware configuration, if not, you will get errors.
Check the manual and report your hardware configuration and details of error conditions: https://docs.sailoog.com/openplotter-v1-x-x/network

Thanks for the help! After a few tries I got it working!
Thx
Dave
  Reply
#5
(06-05-2018, 08:10 AM)addboy Wrote:
(06-04-2018, 03:50 PM)Sailoog Wrote: You have to set the option that match your hardware configuration, if not, you will get errors.
Check the manual and report your hardware configuration and details of error conditions: https://docs.sailoog.com/openplotter-v1-x-x/network

Thanks for the help! After a few tries I got it working!
Thx
Dave

Dave,

I'm putting Open Plotter on a new 3b+, I have reset the country to US successfully but WiFi still does not work.  Can you describe what you did to get it working?

Still struggling with this issue here.

Thanks,

John
  Reply
#6
(09-05-2018, 12:00 PM)John S Wrote:
(06-05-2018, 08:10 AM)addboy Wrote:
(06-04-2018, 03:50 PM)Sailoog Wrote: You have to set the option that match your hardware configuration, if not, you will get errors.
Check the manual and report your hardware configuration and details of error conditions: https://docs.sailoog.com/openplotter-v1-x-x/network

Thanks for the help! After a few tries I got it working!
Thx
Dave

Dave,

I'm putting Open Plotter on a new 3b+, I have reset the country to US successfully but WiFi still does not work.  Can you describe what you did to get it working?

Still struggling with this issue here.

Thanks,

John

Hi, John-

I've experienced this before as well. What I've found is that the key is always in the settings in the OpenPlotter configuration application, specifically on the "network" tab.  It obviously depends on your application, but the setting "client" is what I usually need/want, and once set, allows me to do exactly what I want - have the OpenPlotter Raspberry Pi join my existing network.  Your mileage may vary.

Good luck!
  Reply
#7
(09-06-2018, 05:52 AM)RedRyder Wrote: Hi, John-

I've experienced this before as well. What I've found is that the key is always in the settings in the OpenPlotter configuration application, specifically on the "network" tab.  It obviously depends on your application, but the setting "client" is what I usually need/want, and once set, allows me to do exactly what I want - have the OpenPlotter Raspberry Pi join my existing network.  Your mileage may vary.

Good luck!

Same experience here. After fresh install it was impossible to set WIFI language to DE - "Could not communicate with wpa_supplicant"
No wlan0 Wireless adapter was visible and /etc/wpa_supplicant was unchanged (remained set to default country=GB)
  • updated all packages from within Raspbian and from OP (about 200 MB) 
  • changed network setting in OP to 'client' 
  • edited /etc/wpa_supplicant to look like this
Code:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=DE

network={
    ssid="xxxxxxxxxx"
    psk="yyyyyyyyyy"
    key_mgmt=WPA-PSK
}

only after completing all above mentioned steps (and reboot) wlan0 came alive and connected flawlessly

cheers,
G.
  Reply
#8
(09-06-2018, 02:05 PM)Geronius Wrote:
(09-06-2018, 05:52 AM)RedRyder Wrote: Hi, John-

I've experienced this before as well. What I've found is that the key is always in the settings in the OpenPlotter configuration application, specifically on the "network" tab.  It obviously depends on your application, but the setting "client" is what I usually need/want, and once set, allows me to do exactly what I want - have the OpenPlotter Raspberry Pi join my existing network.  Your mileage may vary.

Good luck!

Same experience here. After fresh install it was impossible to set WIFI language to DE - "Could not communicate with wpa_supplicant"
No wlan0 Wireless adapter was visible and /etc/wpa_supplicant was unchanged (remained set to default country=GB)
  • updated all packages from within Raspbian and from OP (about 200 MB) 
  • changed network setting in OP to 'client' 
  • edited /etc/wpa_supplicant to look like this
Code:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=DE

network={
    ssid="xxxxxxxxxx"
    psk="yyyyyyyyyy"
    key_mgmt=WPA-PSK
}

only after completing all above mentioned steps (and reboot) wlan0 came alive and connected flawlessly

cheers,
G.

Thanks to both of you for your comments!  I will try this today and report back.
  Reply
#9
(09-06-2018, 03:13 PM)John S Wrote:
(09-06-2018, 02:05 PM)Geronius Wrote:
(09-06-2018, 05:52 AM)RedRyder Wrote: Hi, John-

I've experienced this before as well. What I've found is that the key is always in the settings in the OpenPlotter configuration application, specifically on the "network" tab.  It obviously depends on your application, but the setting "client" is what I usually need/want, and once set, allows me to do exactly what I want - have the OpenPlotter Raspberry Pi join my existing network.  Your mileage may vary.

Good luck!

Same experience here. After fresh install it was impossible to set WIFI language to DE - "Could not communicate with wpa_supplicant"
No wlan0 Wireless adapter was visible and /etc/wpa_supplicant was unchanged (remained set to default country=GB)
  • updated all packages from within Raspbian and from OP (about 200 MB) 
  • changed network setting in OP to 'client' 
  • edited /etc/wpa_supplicant to look like this
Code:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=DE

network={
    ssid="xxxxxxxxxx"
    psk="yyyyyyyyyy"
    key_mgmt=WPA-PSK
}

only after completing all above mentioned steps (and reboot) wlan0 came alive and connected flawlessly

cheers,
G.

Thanks to both of you for your comments!  I will try this today and report back.

I can't confirm this!!!
The configuration as network client does work as it should from non updated V1.0.0!
Starting from fresh image.
  1. start openplotter
  2. goto Network page
  3. select client
  4. click set
  5. click apply
  6. click Yes
  7. reboot the raspberry
  8. after startup wait a minute and click on the network symbol in the upper rigth corner (in this case two red x)
  9. a drop down list should open and list the wifi networks it found select the one you want to connect to. (depending on the wifi you need to put in a key)
  10. Now you should have a connection. Set WiFi Country in Raspberry Pi configuration menu ->Preferences->Raspberry Pi Configuration->Page Localisation
done

Note:
The openplotter image has the AP configuration as default. Users which run openplotter without a monitor can directly connect to the openplotter AP and use realvnc client to remote control openplotter. The disadvantage is that the AP blocks the internal wlan. So you need to do the steps mentioned above to disable the AP. 

One of the advantages of openplotter is that it works with low power and is able to work as a router. How much energy does your existing network consums? Is it online all the time?
  Reply
#10
I did not attempt the most recent method to get WiFi working however, I can confirm 100% that the method of manually editing wpa_supplicant in the manner posted by Geronius worked perfectly.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)