This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GPS USB-Mouse is no longer recognized by OpenCPN
#1
Good evening
regrettably my GPS USB-receiver is not recognized by actual Openplotters OpenCPN.

In the previous version all worked fine.

The system recognizes the receiver / see listing from   lsusb
pi@openplotter:~ $ lsusb
Bus 001 Device 006: ID 1546:01a5 U-Blox AG NL-402U
Bus 001 Device 005: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@openplotter:~ $


The device is    Navilock NL-402U

In Openplotters previous version it could be found in the NMEA settings.
After activating per mouseclick and running diagnostics, the GPS data come in
and were used by OpenCPN.


In the new version there is no entry for this GPS device.

Who knows help_
Regards
Karl
  Reply
#2
does it show in the serial tab op ? install it there if not.
i had a problem with the imu true compass i had to set the pypilot to basic before it was sent to ocpn
after update it took a while for my usb gps bu-353 to lock on to a good signal.
mare liberum
  Reply
#3
@jim321
Thank you for Your advice.
I checked the serial Tab.
I think the GPS is shown there.
(when I plug it in and out the list of devices changes)

I switched pylot to basic.
No GPS Signal at all!

The GPS is working fine with
- OpenCPN under Windows
- Navigatrix (regrettably not available for Raspberry)
- OpenCPN under MX Linux

So the device is ok.
Regards
Karl
  Reply
#4
Could you plugin your GPS Maus and copy&paste output messages from following command
Code:
dmesg
  Reply
#5
"I think the GPS is shown there.
(when I plug it in and out the list of devices changes) "

did you select the one that shows when plugged in and push the auto button or name it  and push the apply button.
it needs to be installed there before the sys see's it

   
mare liberum
  Reply
#6
Looks good. Kernel has recognized you GPS
Quote:[ 5356.132237] usb 1-1.4: new full-speed USB device number 6 using dwc_otg
[ 5356.264434] usb 1-1.4: New USB device found, idVendor=1546, idProduct=01a5
[ 5356.264458] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 5356.264468] usb 1-1.4: Product: u-blox 5  -  GPS Receiver
[ 5356.264483] usb 1-1.4: Manufacturer: u-blox AG - http://www.u-blox.com
[ 5356.265812] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device

Now you can test device
Code:
ls -la /dev/ttyACM0
id $USER
minicom -D /dev/ttyACM0 -b <baudrate>

If you havn't "minicom"
Code:
aptitude install minicom
  Reply
#7
(06-08-2018, 05:50 AM)jim321 Wrote: "I think the GPS is shown there.
(when I plug it in and out the list of devices changes) "

did you select the one that shows when plugged in and push the auto button or name it  and push the apply button.
it needs to be installed there before the sys see's it

@jim321
This advice did it!!!   Idea

Thank you so much!
Now the GPS is working fine again.
Now I am going to fix the next problem
Getting my AIS by SDR working.

Thank you so much again.
Smile

(06-08-2018, 06:08 AM)BlackSea Wrote: Looks good. Kernel has recognized you GPS
Quote:[ 5356.132237] usb 1-1.4: new full-speed USB device number 6 using dwc_otg
[ 5356.264434] usb 1-1.4: New USB device found, idVendor=1546, idProduct=01a5
[ 5356.264458] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 5356.264468] usb 1-1.4: Product: u-blox 5  -  GPS Receiver
[ 5356.264483] usb 1-1.4: Manufacturer: u-blox AG - http://www.u-blox.com
[ 5356.265812] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device

Now you can test device
Code:
ls -la /dev/ttyACM0
id $USER
minicom -D /dev/ttyACM0 -b <baudrate>

If you havn't "minicom"
Code:
aptitude install minicom
@BlackSea
Thank you very much for Your efforts to help me.
MeanwhileI got it work with advice from jim321
  Reply
#8
Hopefully one day I will be able to answer RTFM Smile
Sorry guys there are still basic stuff that we need to write on the manual.
  Reply
#9
Question 
(06-08-2018, 01:49 PM)Sailoog Wrote: Hopefully one day I will be able to answer RTFM Smile
Sorry guys there are still basic stuff that we need to write on the manual.

I have a BU-353S4 GPS puck which I managed to configure with OpenCPN so that it reads the GPS data using GPSD. I then set it up to broadcast this information on a local network and the RPI Wifi using UDP. I also have Open CPN running on a Microsoft Surface and Windows desktop and they pick up the GPS data either connected to my home network or to the RPi WiFi. This all works perfectly.

[Image: y4mWi4n3clC4l2TG9xVzUbrCM_InyGB-vzRzfvi3...pmode=none]

However the OpenPlotter documentation states that all NMEA0183, including GPS should go through Kplex. But there is very sparse documentation on how to set up OpenCPN.

OpenPlotter instructions for OpenCPN 

Searching the BB, I came across this thread and followed the instructions, but I just cannot get OP to recognize the GPS puck, so I thought I ask this group for assistance.

I unplugged the GPS and rebooted RPi and then plugged in the puck.

[Image: y4mO55oFxceYgXrrCnDk2W9go-LMMcnTUO3oI5MB...pmode=none]

When I then go into OP, I see the following under Serial.

[Image: y4mmqCm7xsQBuikoBvdUVxZLV_t2jMmhtMl4-mhm...pmode=none]

 It doesn't matter what I name the GPS, or how i assign it, it still doesn't see to be recognized because I get the same message when i click on auto.

However, I assume that the GPS assignment should be Kplex with a baud rate of 4800. When I do this it does appear in Kplex.

[Image: y4mOW3s0mXyjAYqLCg_4DhSlfWX-n0KCdDhhKyS0...pmode=none]

Notice that I added the UDP settings to broadcast the GPS information across the network at home or on the boat as I did in OpenCPN.

However I do not see any messages when I click on Diagnostic in Kplex.

[Image: y4madrCgcNHd72A70xkxU-Go5Lcu9qdjHiH3keUy...pmode=none]

I could also not see the arguments of the timeout exception. That is a full window screen grab.

So I'm frustrated and confused. Any help would be appreciated greatly.

(08-02-2018, 04:57 AM)MilesAhead Wrote:
(06-08-2018, 01:49 PM)Sailoog Wrote: Hopefully one day I will be able to answer RTFM Smile
Sorry guys there are still basic stuff that we need to write on the manual.

I have a BU-353S4 GPS puck which I managed to configure with OpenCPN so that it reads the GPS data using GPSD. I then set it up to broadcast this information on a local network and the RPI Wifi using UDP. I also have Open CPN running on a Microsoft Surface and Windows desktop and they pick up the GPS data either connected to my home network or to the RPi WiFi. This all works perfectly.

I seem to have got it working by assigning GPSD to the puck in the serial tab. I also added the UDP broadcast out on the Kplex tab for my home and boat networks and I can attach to the GPS on the other computers on both networks.

However I am still getting the error when I click on auto on the serial tab. 
  Reply
#10
You do not have to modify default opencpn settings. Remove all your changes there and create only an input: TCP localhost 10110

You need to do nothing in kplex either. Remove all your manual settings.

Assign your GPS in serial tab to GPSD and that is all. Openplotter will send all dat to TCP 10110.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)