This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Openplotter with Navionics?
#1
I'd like to connect my openplotter data (position and AIS) to my ipad running Navionics.  From what I've read Navionics listens to UDP port 2000 for nmea broadcasts. 

I've tried to setup a UDP output under the NMEA 0183 setut tab, but using other plotting software that i know can connect via UDP I don't seem to be getting any UDP broadcasts out of openplotter.  My version is 0.17.1. 

I used UDP output, port 2000 and localhost as the IP.  Doesn't work using 10.10.10.1 either.  Checking using the diagnostic button shows data being generated.  What am I doing wrong?  Thanks!
  Reply
#2
I downloaded the latest version of OP which appears to have reorganized the networking and configuration interface. I'll set that up, test, and report back...
  Reply
#3
V1.0.0 didn't fix the UDP thing. I still can't broadcast with UDP.
  Reply
#4
Nobody uses UDP broadcasts?
  Reply
#5
(07-11-2018, 05:51 PM)jswalwell Wrote: Nobody uses UDP broadcasts?

As the Name implies, you have to use an SPECIAL Broadcast Adress here: with the 10.10.10.1 and Netmask of 255.255.255.0 it will be 10.10.10.255.

https://en.wikipedia.org/wiki/Broadcast_address

good luck
  Reply
#6
So I was able to check something as simple in the kplex configuration as:


[Udp]
address=0.0.0.0
port=2000
coalesce=yes

It is able to send the NMEA data over port 2000 in UDP. I checked it with OpenCpn by creating a UDP network connection, port 2000 and address 0.0.0.0. It works, which shows that there is flow in UDP 2000.

What I don't know is if you've already tried it or if it will work with Navionics.
Why are sailors more daring than other men?
Because: No man is so often afraid
like the sailors.

"Of the questions of the seafaring world", in
The Tree of Science, Ramon Llull
  Reply
#7
Holgerw: one should only have to specify the host address and port for UDP broadcast over a specific port. See pinguino's config.

pinguino: thank you for testing and confirming UDP broadcast. I had been testing with iNavx (ipad app) since I know it to work with TCP broadcast data. i am reading through the kplex documentation and will configure via the config file, test, and report back.
  Reply
#8
(07-16-2018, 06:42 PM)jswalwell Wrote: Holgerw: one should only have to specify the host address and port for UDP broadcast over a specific port.  See pinguino's config.

Of course you have to set an Port. The Adress can be 0.0.0.0 or in this case 10.10.10.255.
PS: pinguino´s config is wrong 0.0.0.0.0 -> only 4 bytes in IP4.
  Reply
#9
(07-03-2018, 03:02 PM)jswalwell Wrote: I'd like to connect my openplotter data (position and AIS) to my ipad running Navionics.  From what I've read Navionics listens to UDP port 2000 for nmea broadcasts. 

I've tried to setup a UDP output under the NMEA 0183 setut tab, but using other plotting software that i know can connect via UDP I don't seem to be getting any UDP broadcasts out of openplotter.  My version is 0.17.1. 

I used UDP output, port 2000 and localhost as the IP.  Doesn't work using 10.10.10.1 either.  Checking using the diagnostic button shows data being generated.  What am I doing wrong?  Thanks!

Hi, with this settings Navionics works well with op, hope this will help

kplex.conf

[tcp]
name=out_nav
direction=out
optional=yes
mode=server
address=192.168.0.10
port=2000

[udp]
name=out_nav_udp
direction=out
optional=yes
device=wlan0
port=2000

Wifi:

wlan0  inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0

Wifi name: GoFree-5670

Also check that you generating correct NMEA messages for Navionics.
  Reply
#10
Is there really no easy way to just UDP broadcast out via a specified port on the configured wifi network? I was able to copy Pinguino and broadcast on 0.0.0.0:2000 and see it in opencpn on the Pi.

I wrote some simple code in Labview to read UDP messages from port 2000 when connected by wifi to my openplotter system and not seeing anything (if a udp network broadcast is created in the openplotter kplex configuration tab to be sent over 10.10.10.1:2000).

So UDP broadcast works locally, just not over the wifi network, using the simple openplotter kplex tab configuration.

Exscess, pardon my Pi ignorance, but where does one edit the network adapter settings?

I am able to setup a TCP broadcast over 10:10:10.1:2000 and receive it using my labview code.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)