This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Adafruit LSM303DLHC
#1
I'm fairly new to OpenPlotter and i'm not a software engineer. Have set up version 1.0.2 on a Rpi3 and now have an Adafruit chipped LSM303DLHC imu which is shown as being supported on the imu documentation page. I have it connected and using i2cdetect -y 1 indicate addresses 19 and 1e and also on the i2c tab detected addresses. Have tried the pypilot settings without any success. any help or advice would be very welcome
  Reply
#2
Connect your imu, open a terminal, type openplotter and press enter. Go to pypilot tab.

Is the imu detected in "Detected IMU:"? If not, press "Reset".
Press "Restart". What the terminal says? Paste here.
  Reply
#3
[attachment=354]
(07-09-2018, 02:36 PM)Sailoog Wrote: Connect your imu, open a terminal, type openplotter and press enter. Go to pypilot tab.

Is the imu detected in "Detected IMU:"? If not, press "Reset".
Press "Restart". What the terminal says? Paste here.

Thanks for your quick reply and hope the screenshot has been correctly added.
I note that the imu name is not what I expected. Are the i2c failed addresses those for the L3G4200D + HMC5883L.
  Reply
#4
Try again, the screenshots are not shown.
  Reply
#5
   
[attachment=365 Wrote:Sailoog pid='6319' dateline='1531418769'][attachment=365]Try again, the screenshots are not shown.

Try again.    
  Reply
#6
(07-19-2018, 10:24 AM)Johnnysails Wrote:
(07-12-2018, 02:06 PM)Sailoog Wrote: Try again, the screenshots are not shown.

Try again.

I have failed dismally in trying to get my Adafruit LSM303DLHC + L3GD20 chipped IMU board working. The i2c addresses are detected as 19 and 1e. I would appreciate any advice on an IMU that is known to work properly on the latest version of openplotter pypilot 1.1.0. alpha.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)