This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
... send Signal K keys in a ST2000 network?
#1
Hi,
I would like to see the battery voltage on my plotter. The workflow should be the same for every Signal K key, that is to be sent in a ST2000 network.

The voltage is measured by an ads1115.

It has the Signal K key „electrical.batteries.service.voltage“in OP.

The PGN for battery related data within a ST2000 network is PGN 127508.

If I activate sending PGN 127508 on the CAN2USB adapter output, the plotter shows 0.0 Volt.
That is clear, as I can see in the CAN tab Diagnostic, that the PGN 127508 contains only zeros.

My question is, how can I link the Signal K key
„electrical.batteries.service.voltage“ to the PGN 127508?

I guess, the format is a bit tricky, because the PGN 127508 contains multiple, battery related, measurments.

May be I could change the Signal K key to an other string? But how to name it?

Martin
  Reply
#2
Yes. You are right.
I think SignalK has changed. There is no Properties.dcSource.voltage anymore.

(To make it work solutions:
1. Replace Properties.dcSource.voltage with electrical.batteries.service.voltage in line 244 of SK-base_d.py.
or
2. Edit openplotter.conf and replace electrical.batteries.service.voltage with Properties.dcSource.voltage.)


Better way is:
Go to SignalK page (openplotter.local:3000) and login
Appstore->Available  install signalk-to-nmea2000
Server->Data Providers OPcan
select Actisense NGT-1 (canboatjs)
apply
press restart (upper right corner)
Server-<Plugin Config  Convert Signal K to NMEA2000
select Active
select Enable (under Battery (127506 & 127508))
select + button
in "Signal K battery id" enter service
in "NMEA2000 Battery Instance Id" enter 1
press submit
press restart (upper right corner)

Martin
  Reply
#3
Great!
I am not on the boat in the moment. When I am, I give it a try.
Martin
  Reply
#4
(08-27-2018, 05:14 PM)e-sailing Wrote: Better way is:
Go to SignalK page (openplotter.local:3000) and login
Appstore->Available  install signalk-to-nmea2000
Server->Data Providers OPcan
select Actisense NGT-1 (canboatjs)
apply
press restart (upper right corner)
Server-<Plugin Config  Convert Signal K to NMEA2000
select Active
select Enable (under Battery (127506 & 127508))
select + button
in "Signal K battery id" enter service
in "NMEA2000 Battery Instance Id" enter 1
press submit
press restart (upper right corner)


Having similar problems sending SK to N2K. Did a lot of troubleshooting, but lost with my knowledge.

Can-USB managed by SK Server. Showing up as "BetaCan Openplotter" in the device list of my Raymarine a65, a95, i70s, but fails to show battery info for instance "0" and "1".
Settings in the plugin for Signal K battery id is "291" as this is the device number reported by Venus GX and works fine on the SignalK side. Can see battery info in WilhelmSK.
For NMEA2000 Battery Instance Id I tried "0" as well as "1".
Was debugging NMEA2000 and can see it as been sent: 2019-06-10T20:15:46.726Z signalk-to-nmea2000 emit {"pgn":127508,"Battery Instance":0,"Instance":0,"Voltage":12.779999732971191,"Current":-8.199999809265137,"Temperature":273.15}
But unfortunately nothing appears on the Raymarine devices.

Now I wonder if there's someone who can give me a helping hand to get that running.


Stefanie
  Reply
#5
Have you setup the can-usb that it is allowed to send  pgn127508 ?
  Reply
#6
Yes. PGN 127508 is activated in signalk-nmea2000-plugin and as said, I can see it being sent when debugging the plugin. But I cannot be sure it ever reaches the N2K network. Tried reading the RX buffers in the Raymarine a65/a95, but that's all in HEX and doesn't help me further debugging.
  Reply
#7
(06-11-2019, 05:22 PM)pi2space Wrote: Yes. PGN 127508 is activated in signalk-nmea2000-plugin and as said, I can see it being sent when debugging the plugin. But I cannot be sure it ever reaches the N2K network. Tried reading the RX buffers in the Raymarine a65/a95, but that's all in HEX and doesn't help me further debugging.

I have asked if canusb is set correctly. You tell me that SignalK is set correctly.

Canusb and actisense ngt-1 have a security system. They send only PGNs which the user activated in Setup! This information is saved in the converter not on the raspberry.
You can reach the hardware setting on page "CAN" "TX RX enable list".
  Reply
#8
Ok, very sorry. Misunderstood your question.

Yes, I have set PGN 127508 enabled in the CAN menu of OpenPlotter and diagnostics tells me that it's being send. Not sure though if it contains any data and if the destination is correct when I look at the screenshot.

What makes me wonder is that when I activate "Managed by Signal K" + "Input/Output CAN-USB", the option "TX PGN Enable List" becomes greyed out. Same when I check "Managed by OpenPlotter" for Input and Output. Only when everything is unchecked, I have access to the TX PGN Enable List.

So maybe I messed something up and made incorrect settings?


Attached Files Thumbnail(s)
           
  Reply
#9
So maybe I messed something up and made incorrect settings? No!


You can't setup the interface while it works with signalk. You can't send N2K while you see the N2K diagnostic output...
BTW use "Managed by Signal K (canboatjs)".

Before starting with 127508 I would test if you are able to send for example depth (128267) or heading (127250).
You should be able to go into your "Data source menu" and use device selection depth or heading. If you can select the device "BetaCan Openplotter" and it shows the value on the plotter you have managed to send N2K data from openplotter to your raymarine mfd. Then you can test if you are able to send 127506/127508. On my Lowrance HDS7 it is easier. I can select the device "BetaCan Openplotter" and see data send from it (I don't see N2K AIS sentences also they are shown on the map).

Signal K -> N2K looks for following pathes:
127506:
electrical.batteries.1.capacity.stateOfCharge
electrical.batteries.1.capacity.stateOfHealth
electrical.batteries.1.capacity.timeRemaining
127508:
electrical.batteries.1.voltage
electrical.batteries.1.current
electrical.batteries.1.temperature
(I don't know if you should use 1 or 0)
  Reply
#10
(06-15-2019, 03:21 PM)e-sailing Wrote: So maybe I messed something up and made incorrect settings? No!


You can't setup the interface while it works with signalk. You can't send N2K while you see the N2K diagnostic output...
BTW use "Managed by Signal K (canboatjs)".

Before starting with 127508 I would test if you are able to send for example depth (128267) or heading (127250).
You should be able to go into your "Data source menu" and use device selection depth or heading. If you can select the device "BetaCan Openplotter" and it shows the value on the plotter you have managed to send N2K data from openplotter to your raymarine mfd. Then you can test if you are able to send 127506/127508. On my Lowrance HDS7 it is easier. I can select the device "BetaCan Openplotter" and see data send from it (I don't see N2K AIS sentences also they are shown on the map).

Signal K -> N2K looks for following pathes:
127506:
electrical.batteries.1.capacity.stateOfCharge
electrical.batteries.1.capacity.stateOfHealth
electrical.batteries.1.capacity.timeRemaining
127508:
electrical.batteries.1.voltage
electrical.batteries.1.current
electrical.batteries.1.temperature
(I don't know if you should use 1 or 0)


Thank you very much for the info.
I've tried exactly what you have described above with no success. But I think there is another problem. For some reason I cannot open the "TX PGN Enable list". With nothing else checked in the Can Menu, the option is not greyed out, but nothing happens when I click on the tab. I expect it to open a list with PGN's to check.
Disconnected CAN-USB physically from the Raspberry. Deactivated signalk-to-nmea2000. Deactivated OPcan in Signalk. Deleted the device from the Serial Menu and set everything up again. Rebooted. Disconnected the CAN-USB from network. Still no luck opening the TX PGN Enable list. 
And since this doesn't work for me, I was not able to setup sending Depth or Heading to the MFD.
So maybe there is a problem with my OP installation? 

And while re-thinking of what I've written in my very first post above, I think I never enabled anything in the TX PGN Enable list and - without knowing what I was doing - enabled 127508 in the Signal K to N2K tab in the CAN menu. So please forgive me for the wrong information.

Stefanie
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)