This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problem with signalk
#1
Hello, everybody, 
I reinstalled surgery. 
I have a problem with signalalk . 
See the screenshot . There are 2 bugs that I don't get fixed. 
Do you have any ideas, or do I have to start over and reinstall? 
Greetings Jürgen

edit. 
I can't insert pictures. 

then I only copy the text

 ID                                          Error                                                                        Status
OPkplex       2018-9-7 16:08:05: Reconnect localhost 30330 retry 10 delay 5000           Connected to localhost 30330

OPpypilot     2018-9-7 16:27:54: Reconnect localhost 20220 retry 247 delay 5000          connect ECONNREFUSED 127.0.0.1:20220


Edith 2:
The bug only occurs after an update to 1.1.0.
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply
#2
Having the same problem, also Signal K server plugin configuration page in browser shows empty frame.

Any ideas?

Mark
  Reply
#3
Can you please post /home/pi/.signalk/settings.json
  Reply
#4
(09-09-2018, 05:20 AM)e-sailing Wrote: Can you please post /home/pi/.signalk/settings.json

Here is my /home/pi/.signalk/settings.json

{
    "enablePluginLogging": true,
    "interfaces": {
        "appstore": true,
        "nmea-tcp": true,
        "plugins": true,
        "providers": true,
        "rest": true,
        "tcp": true,
        "webapps": true,
        "ws": true
    },
    "loggingDirectory": "/home/pi/Logs",
    "mdns": false,
    "pipedProviders": [
        {
            "enabled": false,
            "id": "OPcan",
            "pipeElements": [
                {
                    "options": {
                        "logging": false,
                        "subOptions": {
                            "device": "",
                            "type": "ngt-1"
                        },
                        "type": "NMEA2000"
                    },
                    "type": "providers/simple"
                }
            ]
        },
        {
            "enabled": true,
            "id": "OPpypilot",
            "pipeElements": [
                {
                    "options": {
                        "logging": false,
                        "subOptions": {
                            "host": "localhost",
                            "port": "20220",
                            "type": "tcp"
                        },
                        "type": "NMEA0183"
                    },
                    "type": "providers/simple"
                }
            ]
        },
        {
            "enabled": true,
            "id": "OPkplex",
            "pipeElements": [
                {
                    "options": {
                        "logging": false,
                        "subOptions": {
                            "host": "localhost",
                            "port": "30330",
                            "type": "tcp"
                        },
                        "type": "NMEA0183"
                    },
                    "type": "providers/simple"
                }
            ]
        },
        {
            "enabled": true,
            "id": "OPwifi",
            "pipeElements": [
                {
                    "options": {
                        "logging": false,
                        "subOptions": {
                            "port": "55561",
                            "type": "udp"
                        },
                        "type": "SignalK"
                    },
                    "type": "providers/simple"
                }
            ]
        },
        {
            "enabled": true,
            "id": "OPserial",
            "pipeElements": [
                {
                    "options": {
                        "logging": false,
                        "subOptions": {
                            "port": "55559",
                            "type": "udp"
                        },
                        "type": "SignalK"
                    },
                    "type": "providers/simple"
                }
            ]
        },
        {
            "enabled": true,
            "id": "OPnotifications",
            "pipeElements": [
                {
                    "options": {
                        "logging": false,
                        "subOptions": {
                            "port": "55558",
                            "type": "udp"
                        },
                        "type": "SignalK"
                    },
                    "type": "providers/simple"
                }
            ]
        },
        {
            "enabled": true,
            "id": "OPsensors",
            "pipeElements": [
                {
                    "options": {
                        "logging": false,
                        "subOptions": {
                            "port": "55557",
                            "type": "udp"
                        },
                        "type": "SignalK"
                    },
                    "type": "providers/simple"
                }
            ]
        }
    ],
    "port": 3000,
    "security": {
        "strategy": "@signalk/sk-simple-token-security"
    },
    "ssl": false,
    "sslport": 3443
}


Thanks in advance for help.

Mark
  Reply
#5
You are on SignalK 1.6.0.
There have been bug reports "http://forum.openmarine.net/showthread.php?tid=1216&page=5"
Many thanks to the Signal K Team for there help!!! (Now you can see if something isn't OK and the error with kplex is reduced)
The setting that PyPilot is always online in Signal K is wrong. With the next update this error messages should stop.
If you don't use pypilot you can disable OPpypilot in signalk-server-admin-ui Server->Data Providers. These changes will be overwritten when you change settings on CAN page.
  Reply
#6
(09-09-2018, 12:00 PM)e-sailing Wrote: You are on SignalK 1.6.0.
There have been bug reports "http://forum.openmarine.net/showthread.php?tid=1216&page=5"
Many thanks to the Signal K Team for there help!!! (Now you can see if something isn't OK and the error with kplex is reduced)
The setting that PyPilot is always online in Signal K is wrong. With the next update this error messages should stop.
If you don't use pypilot you can disable OPpypilot in signalk-server-admin-ui Server->Data Providers. These changes will be overwritten when you change settings on CAN page.

Ok, I don,t use PyPilot for now, so this solved the problem for now, thanks for the quick responses.

Mark
  Reply
#7
I have the same entry.

I have to wait for the new update.

Greetings Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply
#8
This should be solved on v1.2.0
Could you check please?
  Reply
#9
I check it in the next 3 days.
The system ist in the boat and the boat ist in the haven.
Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply
#10
(09-18-2018, 02:10 PM)Sailoog Wrote: This should be solved on v1.2.0
Could you check please?
I checked just now, after I enabled OPpypilot the error was back, see error text below.

Id    Last Error    Status 
Convert Signal K to NMEA0183 Started

OPkplex 2018-9-18 21:15:49: Reconnect localhost 30330 retry 0 delay 0 Connected to localhost 30330

OPpypilot 2018-9-18 21:27:31: Reconnect localhost 20220 retry 146 delay 5000 connect ECONNREFUSED 127.0.0.1:20220



Mark
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)