This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error when updating openPlotter (from 1.1 to 1.2) and OpenCPN1.2
#1
When updating OpenPlotter from 1.1. to 1.2, I get the following


UPDATING PACKAGE LIST…
 




Fetched 11.7 MB in 24s (467 kB/s)
Reading package list . . . Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/dpkg/status
E: The package lits or status file could not be parsed or opened
 
#### ERROR. ABORTING, PRESS ENTER TO EXIT ####


I get exactly the same error when updating OpenCPN and OpenCPN plugins.
  Reply
#2
For some reason your package list is corrupted. Open a terminal and type:

sudo rm /var/lib/apt/lists/* -vf

then try to update again and it should work.
  Reply
#3
(09-18-2018, 01:13 PM)Sailoog Wrote: For some reason your package list is corrupted. Open a terminal and type:

sudo rm /var/lib/apt/lists/* -vf

then try to update again and it should work.

Thank you but it did not help. I get the same error.

I shall get a new sd card and start from scratch.
  Reply
#4
oops sorry the error is about dpkg not about apt.
Try to use an old file typing this:

sudo mv /var/lib/dpkg/status /var/lib/dpkg/status.bad
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
  Reply
#5
Thank you, Sailoog, but it did not work either.

I reformatted the SD card, used the NOOBS (OpenPlotter 1.0.0) then upgraded to 1.2 without problem. That was faster than searching for a corrupted file, at least for me (I am new to Raspberry Pi and to Linux/Raspbian.)
  Reply
#6
Hi, getting this error trying to upgrade from 1.1.0 to 1.2.0

DOWNLOADING NEW OPENPLOTTER CODE...

Cloning into 'openplotter_tmp'...
remote: Enumerating objects: 5150, done.
error: RPC failed; curl 56 GnuTLS recv error (-9): A TLS packet with unexpected length was received.
fatal: The remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed

#### ERROR. ABORTING, PRESS ENTER TO EXIT ####
  Reply
#7
(10-12-2018, 09:41 AM)cepicscepics Wrote: Hi, getting this error trying to upgrade from 1.1.0 to 1.2.0

DOWNLOADING NEW OPENPLOTTER CODE...

Cloning into 'openplotter_tmp'...
remote: Enumerating objects: 5150, done.
error: RPC failed; curl 56 GnuTLS recv error (-9): A TLS packet with unexpected length was received.
fatal: The remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed

#### ERROR. ABORTING, PRESS ENTER TO EXIT ####

That sounds like a network error. Maybe it is a temporally connection problem, have you tried again?
  Reply
#8
(10-13-2018, 03:32 PM)Sailoog Wrote:
(10-12-2018, 09:41 AM)cepicscepics Wrote: Hi, getting this error trying to upgrade from 1.1.0 to 1.2.0

DOWNLOADING NEW OPENPLOTTER CODE...

Cloning into 'openplotter_tmp'...
remote: Enumerating objects: 5150, done.
error: RPC failed; curl 56 GnuTLS recv error (-9): A TLS packet with unexpected length was received.
fatal: The remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed

#### ERROR. ABORTING, PRESS ENTER TO EXIT ####

That sounds like a network error. Maybe it is a temporally connection problem, have you tried again?

it worked after changing network settings in openplotter network tab:

AP/client mode upgrade don't work
client mode upgrade work
  Reply
#9
Need to get 0 B/269 MB of archives.
After this operation, 12.7 MB of additional disk space will be used.
apt-listchanges: Reading changelogs...
Extracting templates from packages: 100%
Preconfiguring packages ...
dpkg: unrecoverable fatal error, aborting:
files list file for package 'python' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)

#### ERROR. ABORTING, PRESS ENTER TO EXIT ####

i also get this from 1.0 to 1.2 is there an image with the latest update i tried to reload a fresh image and got the same result
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)