This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Signalk aisreporter
#1
Hello together,
I have set up the aisreporter in Signalalk. 
I send the data for testing to 127.0.0.1 10115.
But I cannot see any data.  Nothing appears in the diagnosis. 
Who does the reporter work for?

Where could my error be?

Greetings Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply
#2
Hello,

Signalalk seems to be making this issue.

"2018-09-20T11:25:06.305Z:[object Object],2018-09-20T11:24:15.258Z:!AIVDM,1,1,,A,H=UoH=18TDdD000000000000000,0*15"


Is that right?

The many zeros don't seem right to me somehow.

Greetings Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply
#3
it's very small AIS message
Decoded:
24/A - Static data report.
MMSI : 912119860
Ship name : RIEKE
  Reply
#4
Hello,
Thank you Blacksea,
This means that the error is probably in SK or in the plugin.
It seems that no dynamic data and only a part of the static data is generated and the data is not sent.
@Tkorki
@sailoog
Could you check it out on occasion?
Greetings Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply
#5
Hello,

I created the second thread here. ( http://forum.openmarine.net/showthread.php?tid=1274 )
It was my mistake. I should have continued the first thread.
Could you merge it with the first one for better clarity?

My described problem doesn't only seem to be my problem.
https://github.com/SignalK/aisreporter/issues/15
The same is described here.

Greetings Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply
#6
(09-20-2018, 09:41 AM)Luckbert Wrote: It seems that no dynamic data and only a part of the static data is generated and the data is not 

Sending static part zero depends on having at least vessel name defined:
https://github.com/SignalK/aisreporter/b...ex.js#L154

and sending static part one requires that you have either
  • shipType
  • callsign
  • or
  • length, beam and gps position (fromCenter, fromBow)
defined, but I just noticed a bug yesterday that length is not using the same SK path that the server admin configuration is using, so unless you fiddle around with defaults.json and set the values that the code uses to fetch the data you won't get output by just using the admin ui. 

I have a fix in the works, I'll try to add a note to this thread when it is available.

The [Object object] output is another bug, but it concerns only the status message, the underlying message may be still ok. This will be fixed in the next version as well.
  Reply
#7
Hello tkurki,
I have not made any changes in the index.js.
I only made changes in signalK (via the webinterface). There I could enter name, MMSI, length, .....
Do I understand you correctly that I still have to change the Index.js manually?

second question:
Do you have any idea why I can't send the AIS signal to 127.0.0.1 10115? At least I can't see an input with diagnosis.

Greetings Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply
#8
Hello Tkurki

I saw the AIS reporter get an update on GitHub. But I can't update it in the web interface of SK yet.
Am I doing something wrong or do I just have to wait? :-)

Greetings Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply
#9
(09-25-2018, 03:02 PM)Luckbert Wrote: Hello Tkurki

I saw the AIS reporter get an update on GitHub.  But I can't update it in the web interface of SK yet.
Am I doing something wrong or do I just have to wait? :-)

Greetings Jürgen

Just wait, npm search functionality that we use takes a little while to show the latest updates. The update should show up in app store shortly.


Quote:Do you have any idea why I can't send the AIS signal to 127.0.0.1 10115? At least I can't see an input with diagnosis.

I don't know what is listening for the messages on port 10115 and I don't know what you mean by diagnosis, so I can't really help uch. 

Are you sure that message is not being received there? Remember that the messages are udp, not tcp. If you have configured the plugin to send to 127.0.0.1 12345 you should be able to receive the messages with 

nc -ul 12345

on your Pi.
  Reply
#10
Hello,
Quote:Just wait, npm search functionality that we use takes a little while to show the latest updates. The update should show up in app store shortly.

Has anyone been able to update that from Reporter?

I don't suggest a new update yet.
Is it possible to uninstall the old plugin and install the new one?s it possible to update it manually?
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)