This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PyPilot doesn't work after upgrade
#21
I added a kpex both directions port 20220 so that anything pypilot has gets sent to system I had the same no compass in ocpn and no imu stuff in openplotter / signalK. Unless i had IMU only
  Reply
#22
(01-11-2019, 09:16 AM)kalle Wrote:
(01-11-2019, 08:35 AM)jim321 Wrote: that looks like its a signalk problem

That seems to be the case. I can start PyPilot and have compass and wind data but in OpenCPN nothing. But how to fix it as my programming skills are bad.

Kalle
Hi Kalle,

it was the same for me. 
In my case it was just that y had to set in OPNCPN the connection again for Openplotter 
Something like Network and TPC and Local-Host (10.10.10.1) and port 10110
Than everything came back to OPENCPN

Hope it helps
Save sailing
Andreas
  Reply
#23
I have noticed some SK weirdness. In the instrument panel I get navigation.attitude as

no_source{"pitch":0.001483529905,"roll":0.006667157926,"yaw":0}

My settings are as followed.

Forced openplotter to do a full update.
Upgraded to current Pypilot as per Sean's directions.
Removed some old config files from .pypilot. ? questionable choice.

Added openplotter/serial device for server.
Servo assignment pypilot

openplotter/kplex
Pypilot TCP both localhost 20220


openplotter/pypilot
basic/auto pilot

This all works.
my settings in OPCN are:
And I noticed that I have no Compass hmmmm 
changed pypilot config
Forward nmea off
Restarted OPCN
Compass is back


debug of my nmea port.

Code:
$OCXDR,A,0.3,D,ROLL*77 //openplotter
$OCXDR,A,0.1,D,PTCH*67 //openplotter
$ARMWV,24.70,R,0.00,N,A*1f
$ARMWV,26.20,R,0.00,N,A*18
$GPGGA,193735.000,4954.3496,N,09707.5222,W,2,7,1.54,230.2,M,-24.6,M,0000,0000*64
$APXDR,A,0.099,D,PTCH*7B //pypilot
$APXDR,A,0.291,D,ROLL*63 //pypilot
$APHDM,280.146,M*3A//pypilot
I have 2 sources for Pitch and roll openplotter does not have heading.. and values are strange...
Removed openplotter generate nmea for pitch and roll..
and changed kplex pypilot to in
one source now) then changed kplex back to both so openplotter Autopilot can see wind and gps?
removed OCPN as source and forward NMEA forward?
Everything seems to work now yup it works but no wind needle at 0 LOL it is working just no wind today and the needle is pointing north.

I hope this helps?
  Reply
#24
My problem is solved.
Folder /home/pi/.signalk was missing after update.
I do not know why?
Had the problem twice with different sd cards.
Perhaps it is better to use ssd.
Thank you for all who tried to help.

Kalle
  Reply
#25
There are multiple ways to route the data.

You can connect to pypilot directly from opencpn with a tcp connection to port 20220
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)