This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems setting up connections
#1
I am just trying to get openplotter set up but am having problems. I am sorry to ask but the new version documentation is a little sparse.

I am running v1.1 on a RPi 3.

Openplotter is set up in AP/client mode and I want to get NMEA and AIS data from a digital yacht iIAS AP.

In kplex I have the standard system and signalk Connections and have added a new input called iais which is a tcp connection to the AP using the specified IP/port number. I have the RPi client connected to the iAIS AP.

I have tested the IP/port number on my ipad using iSailor and I get ships NMEA data and AIS data.

I have opened opencpn and checked the connections there and there is the standard localhost/10110 connection but see nothing and do not have any data for position or AIS.

Opencpn debug window shows no data.

Is there some step I have missed?

P.s. I have tried connecting ipad to the openplotter AP and connecting iSailor to 10.10.10.1/10110 but get no data there either.
  Reply
#2
Hello,
now this is a bit tricky. If the setup tool of Openplotter does not make the NMEA Data from the GPS and AIS Devices running in Openpcn you must do it manually, by installing GPSD first. The PI must be online!

Open a shell and type:

sudo apt-get update

When ready, type

sudo apt-get install gpsd gpsd-clients python-gps

The GPSD-Daemon and the client tools will be installed.

When done, it is a good idea to restart the PI.

If done, open the shell again and test whether the NMEA-Data comes in. First the service has to be started:

sudo gpsd /dev/ttyAMA0 - F /var/run/gpsd.sock
or, if your GPS/AIS is an USB-device instead of ttyAMA0 type ttyUSB0! The last letter means Zero, not "O"!

If done, start gpsmon:

sudo gpsmon

In the window that appears should occur in the upper left corner the address i. E. localhost:2947 or something like that, if everything works fine. This is the address/port number you must add manually as a new connection in Openpcn. Choose tcp network and set the dot on gpsd. Then type in localhost and the port number you have noticed in the gpsmon. Restart Opencpn and test if NMEA Data come in.

That's it. Good luck!

Best Regards,
Werner
  Reply
#3
Hi Werner,

Thanks for the help. I am unsure why openplotter is not doing what it should. I have noticed in the kplex diagnostics that there is an exception of type timeout that has occured, presumably because of the tcp link failing.

Is there some restriction on port addresses? The iIAS device requires address 169.254.1.1:2000 from the app using it.

Unfortunately I’n not sure if the marina wifi will last long enough for an install, I’m at the edge of reception where I am berthed.

Chris
  Reply
#4
(10-04-2018, 04:13 AM)Newt2u Wrote: Hi Werner,

Thanks for the help. I am unsure why openplotter is not doing what it should. I have noticed in the kplex diagnostics that there is an exception of type timeout that has occured, presumably because of the tcp link failing.

Is there some restriction on port addresses? The iIAS device requires address 169.254.1.1:2000 from the app using it.

Unfortunately I’n not sure if the marina wifi will last long enough for an install, I’m at the edge of reception where I am berthed.

Chris

If kplex can't see the data then unlikely gpsd will see it either. Could you use USB just to confirm Openplotter works with the data coming in? I'm not great with network but will try some dummy data from node red into that port with node red just to check it works.

> Sorry, can't make it work. Maybe try 10.10.10.1:2000 ?
  Reply
#5
I will try the usb link but am currently upgrading to v1.2.0 to see if that will change anything.

Is their some documentation on node red? That way I could do some configuration at home.

I do not understand your comment on using 10.10.10.1:2000, the iAIS port is not configurable, has to be 169.254.1.1.
  Reply
#6
(10-04-2018, 05:36 AM)Newt2u Wrote: I will try the usb link but am currently upgrading to v1.2.0 to see if that will change anything.

Is their some documentation on node red? That way I could do some configuration at home.

I do not understand your comment on using 10.10.10.1:2000, the iAIS port is not configurable, has to be 169.254.1.1.

Shot in the dark but might be worth in kplex setting up an input on 10.10.10.1:2000. Also, is the Isailor app turned off? ISTR something about digital yacht not supporting multiple TCP connections, though could be wrong. Sorry can't help more, not great on networking though there should be someone along before too long. 
Node red guide here -
http://noderedguide.com/
Really useful, well worth getting to know a little and not that hard.

Also, the diagnostics times out if no data is coming in, same with serial.
  Reply
#7
Thanks Paddy, will investigate iias connections, although I switched connections on th ipad, i did connect first to check it was working with ipad and maybe the connection did not get shut down.

All in all iias is pretty dumb on networking.
  Reply
#8
Problem solved... just received confirmation from Digital Yacht that iAIS supports only a single TCP connection.
  Reply
#9
(10-04-2018, 03:05 AM)Werner_K Wrote: Hello,
now this is a bit tricky. If the setup tool of Openplotter does not make the NMEA Data from the GPS and AIS Devices running in Openpcn you must do it manually, by installing GPSD first. The PI must be online!

Open a shell and type:

sudo apt-get update

When ready, type

sudo apt-get install gpsd gpsd-clients python-gps

The GPSD-Daemon and the client tools will be installed.

When done, it is a good idea to restart the PI.

If done, open the shell again and test whether the NMEA-Data comes in. First the service has to be started:

sudo gpsd /dev/ttyAMA0 - F /var/run/gpsd.sock
or, if your GPS/AIS is an USB-device instead of ttyAMA0 type ttyUSB0! The last letter means Zero, not "O"!

If done, start gpsmon:

sudo gpsmon

In the window that appears should occur in the upper left corner the address i. E. localhost:2947 or something like that, if everything works fine. This is the address/port number you must add manually as a new connection in Openpcn. Choose tcp network and set the dot on gpsd. Then type in localhost and the port number you have noticed in the gpsmon. Restart Opencpn and test if NMEA Data come in.

That's it. Good luck!

Best Regards,
Werner

I guess you are in openplotter v0.x.x

In v1.x.x gpsd is fully integrated in serial tab
  Reply
#10
(10-06-2018, 12:50 PM)Sailoog Wrote: I guess you are in openplotter v0.x.x

In v1.x.x gpsd is fully integrated in serial tab

No actually, I was using 1.1 then tried 1.2. I believe the problem was a hanging connection from the iPad and a restriction (1 client only) on iAIS. Can’t check till I am back on board.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)