This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Openplotter output UDP
#1
Hello

I have been struggling to get Openplotter to output to UDP port 2000
This is so I can use position/depth data in the Navionics app.

I've followed all the methods in:
http://forum.openmarine.net/showthread.p...291&page=2

Pinguino's last method (entering xxx.xxx.xxx.255 in the kplex tab) does not work for me, although one of the earlier methods of editing kplex.config partially works
As mentioned by Pinguino, I have the OP running in client mode (I have a separate PI zero running as an access point)


[udp]
name=udp_out
direction=out
optional=yes
device=wlan0
port=2000

If I create a test TCP input, and generate some data, say by replaying a log file in OpenCPN, then this data is output to UDP.

[tcp]
name=testin
direction=in
optional=yes
mode=client
persist=yes
retry=10
address=10.10.10.151
port=10109

However, data from the instruments on the boat (I'm using an Actisense NGT-1) is not output to UDP

Everything else works o.k i.e data from the instruments is output to TCP port 10110, or SignalK

thank you in advance for any assistance


Andrew
  Reply
#2
http://forum.openmarine.net/showthread.php?tid=1644
mare liberum
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)