This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AP gone after upgrade
#1
Just did an apt-get update/upgrade and now the Pi 10.10.10.1 access point isn't there anymore. There was a warning about hostapd which I didn't pay much attention to, installing this by the looks of it >
hostapd:armhf (2:2.4-1+deb9u2, 2:2.6-21~bpo9~rpt1)
Anyone else seen this? Is there an easy fix?

Ta

Code:
Start-Date: 2019-03-10  11:09:59
Commandline: apt-get upgrade
Requested-By: pi (1000)
Upgrade: vlc-bin:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), vlc-plugin-video-output:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), vlc-plugin-samba:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), vlc-plugin-qt:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), libpixman-1-0:armhf (0.34.0-1, 0.34.0-1+rpi1), vlc-plugin-skins2:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), vlc-plugin-visualization:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), vlc-l10n:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), openssh-sftp-server:armhf (1:7.4p1-10+deb9u5, 1:7.4p1-10+deb9u6), vlc-plugin-notify:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), libvlc5:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), piclone:armhf (0.11, 0.12), libvlccore9:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), libvlc-bin:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), telegraf:armhf (1.9.5-1, 1.10.0-1), ssh:armhf (1:7.4p1-10+deb9u5, 1:7.4p1-10+deb9u6), vlc:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), vlc-data:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), libsdl1.2debian:armhf (1.2.15+dfsg1-4+rpt1, 1.2.15+dfsg1-4+rpt2), wpasupplicant:armhf (2:2.4-1+deb9u2, 2:2.6-21~bpo9~rpt1), openssh-server:armhf (1:7.4p1-10+deb9u5, 1:7.4p1-10+deb9u6), openssh-client:armhf (1:7.4p1-10+deb9u5, 1:7.4p1-10+deb9u6), hostapd:armhf (2:2.4-1+deb9u2, 2:2.6-21~bpo9~rpt1), vlc-plugin-video-splitter:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), vlc-plugin-base:armhf (3.0.6-0+rpt3+deb9u1, 3.0.6-0+rpt4+deb9u1), wireless-regdb:armhf (2016.06.10-1, 2018.05.09-0~rpt1)
End-Date: 2019-03-10  11:11:47

That was easy Cool
https://www.raspberrypi.org/forums/viewt...&p=1438991

$ sudo su
# apt-cache madison hostapd
hostapd | 2:2.6-21~bpo9~rpt1 | http://archive.raspberrypi.org/debian stretch/main armhf Packages
hostapd | 2:2.4-1+deb9u2 | http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages
# apt-get install hostapd=2:2.4-1+deb9u2 -V

Back in action again.

sudo systemctl enable hostapd.service
seems to work as well without rolling back.
  Reply
#2
I have the same. Clicked to fast and the message was gone.
I remember some lines about config files being moved to an other directory

What you suggest is an rollback of the AP software. Isnt it better to move the config files?
  Reply
#3
As was said in the thread that you posted on raspberrypi.org, what worked for me was uninstalling hostapd and re-installing it.
  Reply
#4
Confirmed, I used remove instead of purge to hold the config files.

sudo apt-get remove hostapd
sudo reboot
sudo apt-get install hostapd

To enable at startup:
sudo update-rc.d hostapd enable
sudo reboot
  Reply
#5
I’m having the upgrade failing on hostapd

Tried the above but the reinstall fails with ‘exit code’ error

Any suggestions?
  Reply
#6
(03-15-2019, 07:16 AM)Sderbyshire Wrote: I’m having the upgrade failing on hostapd

Tried the above but the reinstall fails with ‘exit code’ error

Any suggestions?

Maybe try running this in a terminal first ( from link in the first post) then run the upgrade?

sudo apt-mark hold hostapd
  Reply
#7
Thanks for this! As my hdmi output is damaged I had to use a serial console to install the correct hostapd.
  Reply
#8
I successfully upgraded hostapd to the correct version, 2:2.4-1+deb9u2, and held it

The upgrade then worked successfully

For completeness i then installed usbmuxd and this allowed an iphone to be tethered for mobile internet access.

Thanks for the help guys!
  Reply
#9
Thanks saved a lot of time, if only i had looked here first.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)