This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Adding WiFI adapter for shore connection
#1
First things first, I'm a newbie and not as tech-savvy as others on this forum, so please excuse "dumb" questions.
  • RPI: 3B+
  • OP: 1.2.x
  • WiFi: TP-LINK USB dongle plugged into a powered USB hub
I want to use the RPi as an AP for other equipment, particularly running OpenCPN on another RPi.

I also want to access the internet from shore providers, not just through my Android phone. Which is why I'm trying to set this all up in my home. Everything appears to be working, except I cannot browse the internet. I keep on getting the message "This site cannot be reached" when I try to browse to sites such as Google, CNN, BBC, ...

I have read the manual and I have tried to setup OP as per the manual.

Network settings tab in OP:
  • Network mode: RPi3+: AP + client
  • Sharing Internet Device: wlan0
  • Addresses:
    Multiplexed NMEA 0183:    10.10.10.1:10110    192.86.xx.xx: 10110Signal K Server    10.10.10.1:3000    192.86.xx.xx:3000VNC remote desktop    10.10.10.1:5900    192.168.xx.xx:5900     
Obviously I'm hiding my actual IP address, but it is a valid address.

When I hover over the WiFI symbol on the top right of the screen I get the messages:
  • wlan1: Associated with openplotter
  • wlan1: 10.10.10.1/24
  • wlan0: Associated with "my home network"
  • wlan0: 192.168.xx.xx/24
  • eth0: Link is down
So I'm guessing there is something i'm not setting correctly in RPi itself?

Any and all help very much appreciated.
regards
Trevor
skype: trevor_miles
  Reply
#2
To me it looks like your Pis internal wifi, wlan0, is connecting to your home network when you want your tp-link usb wifi to do so?

The only error I see is i think you should set ‘sharing internet device’ to wlan1 not wlan0

Give that a try and report back.

Steve
  Reply
#3
(03-20-2019, 04:08 PM)Sderbyshire Wrote: To me it looks like your Pis internal wifi, wlan0, is connecting to your home network when you want your tp-link usb wifi to do so?

The only error I see is i think you should set ‘sharing internet device’ to wlan1 not wlan0

Give that a try and report back.

Steve

When I click "Apply" after setting 'sharing internet device' to wlan1 I get an error message: "The device you want to share is in use (bridge or AP)"
regards
Trevor
skype: trevor_miles
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)