This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SignalK-mqtt-gw problem
#1
When I add the above plugin to SignalK and activate it, it locks up SignalK and does not allow you to connect to localhost:3000, also disabling SK in Openplotter. Has anyone had this problem before?

Thanks
  Reply
#2
(04-15-2019, 02:50 AM)AliceJ21 Wrote: When I add the above plugin to SignalK and activate it, it locks up SignalK and does not allow you to connect to localhost:3000, also disabling SK in Openplotter. Has anyone had this problem before?

Thanks

Hi,

I have the exact same issue. Unable to run the MQTT plugin in SingalK. I have been trying it for several months.

For me, I just try and run the local server for the SignalK deltas and it immediately crashes the SignalK server. I recently updated to the 1.4.0 MQTT plugin and still the same issue.

The only way to solve the locked interface is to remove the module via command line.

I hope it gets fixed soon, as I really want to have MQTT export for some sensors related to tank levels.


The temporary fix to get access back to the SignalK terminal is in this thread I posted

http://forum.openmarine.net/showthread.php?tid=1514
  Reply
#3
(04-15-2019, 07:45 AM)craig Wrote: For me, I just try and run the local server for the SignalK deltas and it immediately crashes the SignalK server. I recently updated to the 1.4.0 MQTT plugin and still the same issue.

Might be because there is a local MQTT server running already started by Openplotter? 

WHat about sending to mqtt via node-red?
  Reply
#4
Please put here your settings in mqtt plugin and I will try to reproduce your issue.
  Reply
#5
(04-15-2019, 01:47 PM)Sailoog Wrote: Please put here your settings in mqtt plugin and I will try to reproduce your issue.


At the moment it is difficult to replicate as the Pi I have at home testing things out on gets reformatted every time I try it, I will have a look tomorrow to try and replicate it again.

Thanks
  Reply
#6
Could somebody with a crashing mqtt plugin send me what it says in syslog so I can fix it?


Sent from my iPhone using Tapatalk
  Reply
#7
(04-15-2019, 04:42 PM)tkurki Wrote: Could somebody with a crashing mqtt plugin send me what it says in syslog so I can fix it?


Sent from my iPhone using Tapatalk

Hi, I have sent you my syslog now.

And some background info.
Raspberry Pi
Openplotter 1.2
Signalk-mqtt-gw 1.3? Saw that it should be 1.4 now? Has not got any update alert in signalk server?

Have tried before, and same result, Signalk server won't start after atcivatint the plugin.

Did an update/upgrade now, and also installed mosquitto_clinet package, wasn't installet before.
I can't reach localhost:1883 without name/password, should we not add it to plugin? I can try to clean pid file or what is needed.

In Openplotter, tested both with setup name/pwd for local mqtt instance, and without.

Manage to start the plugin, but not with connection to localthost= doesn't wriet/read anything.

And finally, a BIG thank's @tkurki, for all your work with these plugins and also the Nmea2000 lib for Arduino :-) !

Looking forward to get this plugin to work, the idea sounds perfect to me.

/Leif
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)