This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolution Headless RPT without HDMI connected
#1
I'am using OpenPlotter with a Chromebook via VNC server. If the HDMI screen is connected I get a nice resolution on my Chromebook.

However, when I disconnect the HDMI screen the Chromebook VNC server comes up in a low resolution. I have tried several options but with no results. Is it the screen sensor Edid giving the wrong signals to the system ? What changes the resolution when no HDMI screen is connected ?

Cannot find the solution for this.

Any suggestions where tot look ?

Bram
  Reply
#2
Hello,
Try the settings in the config.txt.
sudo nano /boot/config.txt

remove the # before
framebuffer_width=1280
framebuffer_height=720

I hope it works out.
Greetings Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply
#3
Hi Jurgen,

I have tried all these solutions but without HDMI the VNC viewer defaults in a low resolution. But I have finally found how to get the required resolution
on the VNC client:

install x11vnc

then

x11vnc -configure 1024x600

And now this resolution appears as the VNC viewer on my Chromebook.

Regards,

Bram
  Reply
#4
(04-18-2019, 11:15 AM)verkerkbr Wrote: Hallo Jürgen,

ich habe alle diese Lösungen ausprobiert, aber ohne HDMI ist der VNC-Viewer in einer niedrigen Auflösung eingestellt. Aber ich habe endlich gefunden, wie man die erforderliche Auflösung
auf dem VNC-Client

erhält : Installiere x11vnc und

dann

x11vnc -configure 1024x600

. Nun erscheint diese Auflösung als VNC-Viewer auf meinem Chromebook.

Grüße,

Bram
Cool Big Grin
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply
#5
(04-18-2019, 01:14 PM)Luckbert Wrote:
(04-18-2019, 11:15 AM)verkerkbr Wrote: Hallo Jürgen,

ich habe alle diese Lösungen ausprobiert, aber ohne HDMI ist der VNC-Viewer in einer niedrigen Auflösung eingestellt. Aber ich habe endlich gefunden, wie man die erforderliche Auflösung
auf dem VNC-Client

erhält : Installiere x11vnc und

dann

x11vnc -configure 1024x600

. Nun erscheint diese Auflösung als VNC-Viewer auf meinem Chromebook.

Grüße,

Bram
Cool Big Grin

However I prefer the RealVNC software . Installed the latest RealVNC server (version 6.4.1) on my RPI 3b+.

I have not succeeded to get the VNC client in the high resolution setting via the config.txt.

Software looks first at the HDMI port. If no HDMI monitor is connected it start in the low resolution version.

To simply solve this problem, I have added a Dummy HDMI dongle to the HDMI port then I get high resolution on the Chromebook and other systems as an VNC client. These plugins cost around € 8 to 10,-

Settings in the config.txt:

HDMI_safe=1

HDMI_force_hotplug=1

That is all you have to do.

Works perfect now and fast with the latest kernel version 4.19.36-V7+ and latest updates. VC4 driver (OpenGL) full to on.

Regards,

Bram
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)