This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
USB boot / Wifi / BT issue RPi 3b+
#1
Hello-

I have found a puzzling USB boot issue. System is a Raspberry Pi 3b+ OpenPlotter 1.2.0

First - my setup works fine if I boot from an SD card.
[Image: 2019-05-04_11-05-18.jpg]

Next, I did the following:
  • Copied the SD card to a USB drive (it's using an mSata3-USB3 adapter, the x850)
  • Edited /boot/cmdline.txt to change the boot location
  • Edited /etc/fstab entries for the / and /boot partitions
Findings:
  • Strangely, boot fails part-way through when booting with just the USB drive connected. It starts, gets part way, and stops.
[Image: IMG_2164-L.jpg]
  • I create a new FAT32-formatted SD card with only bootcode.bin on it, insert into Pi
  • Boot succeeds and I get to the desktop. 
[Image: 2019-05-04_11-09-48.jpg]
  • These issues are seen:
  • Bluetooth unavailable
  • Wifi unavailable (the country is still set in wpa_supplicant.conf)
  • Sound/audio is unavailable
  • Attached USB accessories cannot be used. This includes: keyboard, mouse, CAN-USB device
Please help! I have not seen these same issues with a "stock" Raspbian installation.
  Reply
#2
I found much easier to format the USB disk (fat32), copy the  content of Noobs directory, and fire up  ! Noobs will do all the partitioning and pointers handling job, its magic !
Then update OP , OCPN and its plugins ...
Config : RPi 3B+, OP 1.2
Cordialement
Didier B





  Reply
#3
Hi, Didier-

Good suggestions - this worked! A bit frustrating to get all settings moved over to the new installation, but letting NOOBS do the hard configuration work for me overcame most hurdles. Still some Wifi issues, but those are more generally applicable to Raspbian and the Pi - and were eventually overcome with help from the interweb.

Thanks!
Jeremy
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)