This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Update 1.0 to 1.2
#1
I started with a fresh NOOBS download with openplotter as per instructions.  Installed all ok on RP 3+ then changed passwords and went to Updates asked if wanted to update 1.0.0 to 1.2.0 answered yes and got this error in red
Downloading https://files.pythonhosted.org/packages/...ne-any.whl
Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)


  Etc etc 

TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'

#### ERROR. ABORTING, PRESS ENTER TO EXIT ####

Need help
  Reply
#2
(05-08-2019, 10:47 PM)Harryws Wrote: I started with a fresh NOOBS download with openplotter as per instructions.  Installed all ok on RP 3+ then changed passwords and went to Updates asked if wanted to update 1.0.0 to 1.2.0 answered yes and got this error in red
Downloading https://files.pythonhosted.org/packages/...ne-any.whl
Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)


  Etc etc 

TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'

#### ERROR. ABORTING, PRESS ENTER TO EXIT ####

Need help

Hello, 
I am new in the foro, I have the same problem.
If somebody offer a solution I will be very grateful.
Thanks in advance
  Reply
#3
Hi, I also got an error when trying to upgrade from 1.0-1.2

Error code is :
UPDATING PACKAGES...

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up hostapd (2:2.6-21~bpo9~rpt1) ...
Job for hostapd.service failed because the control process exited with error code.
See "systemctl status hostapd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript hostapd, action "restart" failed.
* hostapd.service - Advanced IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator
   Loaded: loaded (/lib/systemd/system/hostapd.service; disabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sat 2019-08-31 10:27:38 AEST; 44ms ago
  Process: 1642 ExecStart=/usr/sbin/hostapd -P /run/hostapd.pid -B $DAEMON_OPTS ${DAEMON_CONF} (code=exited, status=1/FAILURE)

Aug 31 10:27:38 openplotter systemd[1]: hostapd.service: Unit entered failed…te.
Aug 31 10:27:38 openplotter systemd[1]: hostapd.service: Failed with result …e'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package hostapd (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 hostapd
E: Sub-process /usr/bin/dpkg returned an error code (1)

#### ERROR. ABORTING, PRESS ENTER TO EXIT ####

I'm not sure if it has anything to do with it, however my HDMI port is playing up. 
I've tried adjusting the HDMI settings as found on other forums, and basically it hasn't worked in a week. I connect via VNC server, however I came down today to see the HDMI working, however it went off for a while, now back on...currently using.

Any ideas on above upgrade error, and if it could have anything to do with HDMI output?

Thanks
  Reply
#4
Just tried to upgrade Opencpn as well, and get error below...

UPDATING OPENCPN...

Setting up hostapd (2:2.6-21~bpo9~rpt1) ...
Job for hostapd.service failed because the control process exited with error code.
See "systemctl status hostapd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript hostapd, action "restart" failed.
* hostapd.service - Advanced IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator
Loaded: loaded (/lib/systemd/system/hostapd.service; disabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Sat 2019-08-31 10:56:19 AEST; 43ms ago
Process: 8672 ExecStart=/usr/sbin/hostapd -P /run/hostapd.pid -B $DAEMON_OPTS ${DAEMON_CONF} (code=exited, status=1/FAILURE)

Aug 31 10:56:19 openplotter systemd[1]: hostapd.service: Unit entered failed…te.
Aug 31 10:56:19 openplotter systemd[1]: hostapd.service: Failed with result …e'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package hostapd (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
hostapd
E: Sub-process /usr/bin/dpkg returned an error code (1)

#### ERROR. ABORTING, PRESS ENTER TO EXIT ####
  Reply
#5
sudo systemctl enable hostapd.service

then update
you need to update with an ethernet connection or a tethered phone , the wifi is being updated and you will lose connection if you try updating over wifi
mare liberum
  Reply
#6
(08-31-2019, 04:56 AM)jim321 Wrote: sudo systemctl enable hostapd.service

then update
you need to update with an ethernet connection or a tethered phone , the wifi is being updated and you will lose connection if you try updating over wifi

Ran your script, rebooted and tried to upgrade OP, still get this error.
PI is on Ethernet, and wifi turned off.
I've even tried on a fresh new SD card, and complete new install.

After this operation, 0 B of additional disk space will be used.
Setting up hostapd (2:2.6-21~bpo9~rpt1) ...
Job for hostapd.service failed because the control process exited with error code.
See "systemctl status hostapd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript hostapd, action "restart" failed.
* hostapd.service - Advanced IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator
   Loaded: loaded (/lib/systemd/system/hostapd.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sat 2019-08-31 19:22:56 AEST; 46ms ago
  Process: 4242 ExecStart=/usr/sbin/hostapd -P /run/hostapd.pid -B $DAEMON_OPTS ${DAEMON_CONF} (code=exited, status=1/FAILURE)

Aug 31 19:22:56 openplotter systemd[1]: hostapd.service: Control process exi…s=1
Aug 31 19:22:56 openplotter systemd[1]: Failed to start Advanced IEEE 802.11…or.
Aug 31 19:22:56 openplotter systemd[1]: hostapd.service: Unit entered failed…te.
Aug 31 19:22:56 openplotter systemd[1]: hostapd.service: Failed with result …e'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package hostapd (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 hostapd
E: Sub-process /usr/bin/dpkg returned an error code (1)
  Reply
#7
after "sudo systemctl enable hostapd.service" reboot and try again
mare liberum
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)