This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tinypilot network config change
#1
How do I change the network config of tinypilot?

My GPS and AIS have wifi adapters and connect to the boat router. They broadcast UDP packets of the NMEA data.

Each of my opencpn devices, laptop, Orange PI, phone and tablet connect to the same wifi router and configure connections for the GPS and the AIS.

How can I get tinypilot on the same network so it can communicate with the opencpn(s) and GPS?

The default for the tinypilot seems to be an AP. I don't think I want all my boat wifi traffic to go thru tinypilot'a AP.

I would prefer the tinypilot to receive the GPS without using opencpn as a forwarder because I would like the autopilot to function even without opencpn running.

Thanks, Larry
  Reply
#2
You can edit the config file of tinypilot directly, or you can change the network settings from the web interface to make it act as a client.

You can send gps to tinypilot via tcp port 20220. So far there is not support to use a remote gpsd, but this would be very easy to support.
  Reply
#3
I can't find the on the web interface. I installed the stable image of tinypilot_14102018.img. I'll upgrade to latest and look then.
  Reply
#4
The stable image does not support it.
  Reply
#5
(05-27-2019, 07:30 PM)seandepagnier Wrote: The stable image does not support it.

I tried the git upgrade, it didn't get enough of the files in .pypilot.

Then I downloaded the 20042019 image. Still no joy.
I put the sd card in a rpi 2B so I could hook up a display ( I don't have a mini-hdmi adapter yet for the Zero W)  and it still doesn't connect to my wifi.
 
It appears to be missing the packages for dhclient and wpa_supplicant, as I get an error with
sudo sv u wpa_supplicant
fail: wpa_supplicant: unable to change to service directory: file does not exist
and same for dhclient

Is this because of the zero sd card in a rpi2B or is it really missing?

I also see errors flash by during boot on the rpi2B screen, but they are not in /tmp/*.log. I managed to video the boot and these are the errors:
Code:
..
svlogd: warning: unable to open log directory: -b: file does not exist
..
insmod: cant insert modules ... rc-core.ko invalid format
                            ... lirc_dev.ko  invalid format
                            ... lirc_rpi.ko  invalid format
..
wpa_supplicant: unable to change to service directory: file does not exist
dhclient: unable to change to service directory: file does not exist
..
fc-cache: error while loading shared libraries: libharfbuzz.so.0 cannot open shared
object file: no such file or directory
  Reply
#6
If you put a fresh image on the zero w, can you connect to it as an access point and try the web interface to switch it to client mode and reboot?
  Reply
#7
I have tried a fresh image several times. After I use the webapp to change the network and reboot, it does not connect to my router. I do not have a Nokia5110 display so I can't see any possible error messages.
I have taken out the sd card and mounted it on my laptop, the networking.txt file is correct.

Since it does not connect to my router, I cannot ssh in, is there any way to see whats going on? I also tried a serial console cable and get nothing.
  Reply
#8
I will look into it this week. It should not be missing dhclient or wpasupplicant, not sure what is with that.
  Reply
#9
(05-30-2019, 07:19 AM)seandepagnier Wrote: I will look into it this week.  It should not be missing dhclient or wpasupplicant, not sure what is with that.

I looked and it seems you try to start wpa_supplicant as a service, but there are no control files for it to be a service. Same for dhclient. All the info at tinycore.net seem to start wpa_supplicant with a script, wifi.sh.
--
Larry - s/v Katie Lee Passport 45 Ketch (For Sale) - somewhere in Taiwan
  Reply
#10
yes, the client support was not complete. I should have it in the next image.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)