This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Client-less VNC Control in the Browser
#11
how about opt in instead of opt out.
that script was designed for good, but has been used buy some bad character's, it was included in other programs installers and installed without permission.and that ruined it's credibility.
that's why malwarebytes flags it..
it didn't run in my browser uBlock must have blocked it..or it didn't like linux Smile
mare liberum
  Reply
#12
I have tried x11vnc with noVNC.
Now I can connect the rpi desktop with a vnc client (realvnc client does also work).
Or I can connect the rpi desktop with a browser. http://openplotter.local:6080/vnc.html
Copy and paste does work with both. In the browser is a menu on the middle left side with a clipboard.
(When you use tightvnc you can't get the rpi desktop

My configuration starts on every boot. The disadvantage is the unencrypted data.

Installation:
1. Uninstall realVNC and old websockify
Quote:sudo apt purge -y realvnc-vnc-server websockify websockify-common python-websockify

2. Install x11vnc

Quote:sudo apt-get install -y x11vnc
sudo x11vnc -storepasswd /etc/x11vnc.pass

   create file "sudo nano /lib/systemd/system/x11vnc.service" with

Code:
[Unit]
Description="Start X11VNC"
Requires=display-manager.service
After=display-manager.service

[Service]
ExecStart=/usr/bin/x11vnc -display :0 -auth guess -forever -rfbauth /etc/x11vnc.pass -rfbport 5900 -shared
ExecStop=/usr/bin/x11vnc -R stop
Restart=on-failure
Restart-sec=2

[Install]
WantedBy=multi-user.target

  activate load on boot

Quote:sudo systemctl enable x11vnc.service

3. install novnc
Quote:git clone https://github.com/novnc/websockify.git
cd websockify
sudo python setup.py install
cd ..
git clone https://github.com/novnc/noVNC

   create file "sudo nano /etc/systemd/system/novnc.service" with

Quote:[Unit]
Description = start noVNC service
After=syslog.target network.target

[Service]
Type=simple
User=pi
ExecStart=/usr/local/bin/websockify --web /home/pi/noVNC/ 6080 localhost:5900
ExecStop=/usr/bin/killall websockify

[Install]
WantedBy=multi-user.target

  activate load on boot
Quote:sudo systemctl enable novnc


4. test
  start services
Quote:sudo systemctl daemon-reload
sudo systemctl start x11vnc.service
sudo systemctl start novnc.service

Open realvnc client and connect as done before to test if vnc server works.
Open http://openplotter.local:6080/vnc.html (or [ip-address]:6080/vnc.html) in the browser to test if both work.

reboot and check again

5. Resolution
If you doesn't connect a monitor to rpi4. You can't connect. Solution: Use sudo raspi-config to set a resolution.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)