This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pi 3 b+ and WiFi
#1
I am having some trouble getting WiFi (client or access point) going on my fresh (NOOBS) install of OpenPlotter.

Did it the "NOOBS" way, ran the updates for OpenPlotter and OpenCPN, added a Moitessier HAT,  followed the install procedure, everythign is good from that side ..

WiFi though .. thats another matter, it seems what we call in technical terms to be "screwed".

My network setup is RPi3+: AP+ client

sharing: wlan0


but from the network icon on the task bar instead of a list of access points, I just get "no wireless interfaces found"

rfkill list all looks fine, nothing blocked.

iwconfig shows wlan1, not wlan0 ... I have tried configuring openplotter as sharing both wlan0 and wlan1 as the shared device, neither yields a different result.



wpa_supplicant has GB set as the country, but the wpa_supplicant service does nto appear to be running .. and I don't seem to be able to start it:

Failed to start wpa_supplicant.service: Unit wpa_supplicant.service is masked

ideas?
  Reply
#2
wlan1 is the AP not a client. It doesn't make sense to share internet to the AP from the AP.
It seems that your usb wifi stick does not work or isn't compatible.
Have you tried to connect to the AP? Did that work?
  Reply
#3
(06-16-2019, 09:15 AM)e-sailing Wrote: wlan1 is the AP not a client. It doesn't make sense to share internet to the AP from the AP.
It seems that your usb wifi stick does not work or isn't compatible.
Have you tried to connect to the AP? Did that work?

I tried to connect to the AP with my windows laptop, yes, and after a few moment, windows kicks me off and back to my normal home WiFi.

I did manage to set this as "client" and re-installed wpa_supplicant, and I can get it to work as client, it connects OK to my router at home. I will not have a router on the boat.


I don't understand about "wifi stick" .. I do not have one.   Do I need to use a USB wifidongle to work as an AP + Client? I hoped it was possible to use just the onboard Pi 3 b+ wifi for both purposes.  There are some linux setups than do this on a single wireless device .. do I need to buy a WiFi dongle as well to get AP+Client?

All I really need is for this device to work as an AP I guess, it will be the main hub on the boat ... I guess the "slave" devices can just be clients, I should be able to VNC into them ...
  Reply
#4
(06-16-2019, 09:27 AM)rszemeti Wrote: I don't understand about "wifi stick" .. I do not have one.   Do I need to use a USB wifidongle to work as an AP + Client? I hoped it was possible to use just the onboard Pi 3 b+ wifi for both purposes. 
Pretty sure you need a separate usb wifi dongle for the PiB+, the Pi3 can create an access point and log onto a network with just the internal wifi adaptor.
  Reply
#5
I'm confused ... are you saying I DO need a dongle to do AP+Client with the Pi 3 b+ or I don't????
  Reply
#6
(06-16-2019, 09:45 AM)rszemeti Wrote: I'm confused ... are you saying I DO need a dongle to do AP+Client with the Pi 3 b+  or I don't????

Paddy is right.
On pi 3 b+ you need a wifi usb dongle to have internal wifi act as AP (wlan1) and a second wifi device to conect to the client.

It is recommended to have a wifi usb dongle because your boat typical dosen't have a marina wifi AP 10m away from you. For best transmission choose the highest place for the dongle. Use a 10m usb extension and put an active hub on the end of it to supply enough power to your dongle.

Instead of a usb wifi you can use your android mobile as wlan source (connect android with usb cable to your raspberry and activate usb tethering) (nearly the same for Iphone).

(The problem with AP and station on rpi 3 is, that when the client connects to an AP the channel of the client MUST be used also for the openplotter AP (it's one device). You expand the traffic on this channel dramatical ! If every one would do the same in a marina....)
  Reply
#7
OK, I understand.

I don't think I need to connect the plotter to any marina wifi or phone, I don't need this on my plotter. Once it is set up for the season, I will only update the maps over the winter, so I don't think I need any internet connection.

I'll just try to run as an access point on the "main" device in the cabin, and connect the device in the helm position as a client, so it gets the SignalK data etc. I will try again settign the main device as an access point, but there does nto seem to be an option for only AP, which is the best one to try?

So that is my plan:

Device 1 - main cabin Pi 3b+
Moitessier HAT
External Serial
Only onboard WFI unit, no WiFi Dongle
Working only as AP

Device 2 - helm position Pi 3b+
Only onboard WFI unit, no WiFi Dongle
Working only as client connected to Device 1

Does this sound OK?
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)