This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
http://localhost:3000/@signalk.... does not work
#1
Configuration: Rpi 3B+, StromPi3, Moitessier hat
Op 1.2.0 alpha (updated from 1.0 after much frustration caused by the StromPi3 - is finally working serialless on GPIO 21)

Can see the Moitessier hat working, Firmware 4.19.42 V7 installed.
- GPS messages are shown
- I2C sensor configured as per manual

BUT signalK diagnostic is empty and http://localhost:3000/@signalk/server-admin-ui/#/dashboard says localhost sends nothing.

Any advise what to try next - I know the Moitessier hat worked before on the rpi3B, so something must have changed in my desperate efforts to get the StromPi working on rpi3B+ - that bugged up my signalK setting. 

Thanks for help.
  Reply
#2
Tell us details about your configuration of serial and kplex tab.
  Reply
#3
Thank you Sailoog for looking into my problem - here my settings

Serial tab
name: serial0
device: dev/moitessier.tty
port: virtual
serial:
assignment: GPSD
remember: dev

strangely on this tab the label for the "serial0" input shows name dev/ttyOP_ and not dev/moitessier.tty

kplex tab:
system UPD in 10110
signalk TCP out 30330
gpsd TCP in localhost 2947
nodered TCP out 127.0.0.1 10109

hopefully you can point me to a solution Smile
  Reply
#4
And what says the kplex inspector for "gpsd TCP in localhost 2947" and "signalk TCP out 30330"? do you have data there?
if you have data everything works as it should, then go to Signal k administration and confirm you have an input connection created on TCP localhost 30330
  Reply
#5
(07-19-2019, 11:55 AM)Sailoog Wrote: And what says the kplex inspector for "gpsd TCP in localhost 2947" and "signalk TCP out 30330"? do you have data there?
if you have data everything works as it should, then go to Signal k administration and confirm you have an input connection created on TCP localhost 30330

kplex inspector shows NMEA stream HDM and XDR only - no GPx or AISx sentences
but cant start Signalk admin as http://localhost:3000/@signalk/server-admin-ui/#/dashboard
always says localhost does not send any data ERR_EMPTY_RESPONSE

BTW diagnose signal k input dialog is empty
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)