This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Update OC and OP
#1
Been using OP1.0 and OC4.8.4 successfully on a rpi3+ with vesper ais and ray marine instruments.  Tried to update op and OC.  Ended up burning a new sd card img.  Gave up trying to update OP after several failed attempts.  OC updated to 5.0 easily...or so I thought..

Back on the boat tried  to make connections ....all went well on op side, per diagnostics op recieved data from vesper and sent it...BUT OC cannot see it...all settings as before, both on OC and op side.Would send pic but cannot figure out how to get smaller pic.please help....

Can op1 talk to oc5.0?
Have I corrupted connection with aborted OP update efforts?
Have I made a wrong connection or missed a switch ? 
Should I just go back to image with no updates and wait for op2.0? 
Should I be able to update OP beyond 1.0?

Many thanks in advance, especially on behalf of the flat spot of the front of my forehead..
  Reply
#2
Upon further tinkering
I can get ais and gps info to oc via signal k.. 30330... No luck using the 10109 and 10110 connections I used before... And still cannot get route info out of oc into network
Thanks
Cheers
  Reply
#3
opencpn needs nmea 0183, in openplotter you can go to tools nmea generator pick opencpn defaults. or use the sk plugin sk to nmea 0183 and choose the sentences you want and enable.
to get route info out
in opencpn options connections tick the outgoing box for the 10110 connection.
delete the other connections
see if that helps..
mare liberum
  Reply
#4
If you are having troubles upgrading OP try changing the network settings to client only then update, this is what worked for my, you will likely need a monitor attached for this though
  Reply
#5
Thanks for ideas!
As of now, using the unadulterated downloaded image (op1.0, oc4.8.4), I cannot get ais or gps info from the op kplex to OC via local host or 10.10.10.1. The only thing that works is signalk on port 30330.

I do not understand why the output from op on port 10109 (per kplex diagnostics the output is being broadcast) is not seen on the input of OC on port 10109.  It worked before ....honest...I even RTFM....

Btw, don't know if this is relavent but on the network page on op options--all the addresses are blank-- noteably multiplex nema183...
  Reply
#6
(07-31-2019, 01:05 PM)Kcj Wrote: Thanks for ideas!
As of now, using the unadulterated downloaded image (op1.0, oc4.8.4), I cannot get ais or gps info from the op kplex to OC via local host or 10.10.10.1. The only thing that works is signalk on port 30330.

I do not understand why the output from op on port 10109 (per kplex diagnostics the output is being broadcast) is not seen on the input of OC on port 10109.  It worked before ....honest...I even RTFM....

Btw, don't know if this is relavent but on the network page on op options--all the addresses are blank-- noteably multiplex nema183...


on the connections tab of OC you need add and enable TCP port 10110 ?
whats this talk of 30330 and 10109? I am new to all this so forgive me if I am missing something


Attached Files Thumbnail(s)
   
  Reply
#7
PI think I got it sorted!

Op network tab, network mode was set to "client"' thus blanking the addresses...

Changing network mode to "rpi3: ap/client" populated addresses and allowed the 10109 and 10110 ports to talk.

No idea why it works, but it does.....

Thanks again to all...and I'd love to know the why....

Cheers
John
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)