This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
high cpu ussage in opencpn when aouto pilot is using route
#1
i am experiencing very high cpu usage over 90% when auto pilot is following a route in opencpn.. I believe i have some settings wrong and possibly back feeding nmea data . I am at work for a few more weeks before I am on the boat again. Could some one please tell me what i should set for kplex and opencpn. Or screen shots. All software is current and updated. i am using a openplotter v1.2.0 on a rpi3+ with a pypilot motor controller and a marine-pilot 1500 with just the actuator. This winter i would like to change the actuator to something faster as it is too slow to react properly in high wind gusts when close-hauled. To be fair i had too much sail up 150 Genoa and main with 1 reef 14knts gust close to 20knts. recommendations welcome..
my boat is a Tanzer 26 with updated rudder.
  Reply
#2
Which process is using 90% cpu? opencpn?

Are you using the autopilot route plugin or just the inbuilt route following of opencpn?
  Reply
#3
opencpn is causing it. just the built in route following.... with it disengaged the cpu is about 30 to 50%. sorry about the poor spelling the thinkpad's touch pad is a pain.
  Reply
#4
solved i think It was due to opengl not being set in old rpi-config there is an option advanced opengl i set to on then opencpn cpu usage normalized at 20 to 30 %cpu.. I still have to restart kplex in openplotter after reboot
  Reply
#5
(08-09-2019, 05:33 PM)ddelorme Wrote: solved i think It was due to opengl not being set in old rpi-config there is an option advanced opengl i set to on then opencpn cpu usage normalized at 20 to 30 %cpu.. I still have to  restart kplex in openplotter after reboot

So when you reboot you have to log in remotely to openplotter, run open plotter, and restart kplex in order for pypilot to see the motor controller? Or is there some other reason you need to restart kplex?
  Reply
#6
(08-09-2019, 07:47 PM)rastam4n Wrote:
(08-09-2019, 05:33 PM)ddelorme Wrote: solved i think It was due to opengl not being set in old rpi-config there is an option advanced opengl i set to on then opencpn cpu usage normalized at 20 to 30 %cpu.. I still have to  restart kplex in openplotter after reboot

So when you reboot you have to log in remotely to openplotter, run open plotter, and restart kplex in order for pypilot to see the motor controller? Or is there some other reason you need to restart kplex?
I have to restart kplex as the imu data is not getting sent to SignalK or openCPN. but once i restart kplex it all works.. in the new opencpn pypilot app it says it does not see the motor controller but it works.
  Reply
#7
(08-12-2019, 01:21 PM)Lddelorme Wrote:
(08-09-2019, 07:47 PM)rastam4n Wrote:
(08-09-2019, 05:33 PM)ddelorme Wrote: solved i think It was due to opengl not being set in old rpi-config there is an option advanced opengl i set to on then opencpn cpu usage normalized at 20 to 30 %cpu.. I still have to  restart kplex in openplotter after reboot

So when you reboot you have to log in remotely to openplotter, run open plotter, and restart kplex in order for pypilot to see the motor controller? Or is there some other reason you need to restart kplex?
I have to restart kplex as the imu data is not getting sent to SignalK or openCPN. but once i restart kplex it all works.. in the new opencpn pypilot app it says it does not see the motor controller but it works.

Interesting, I have to select and apply the serial port assigned to pypilot I order for it to work. I tried restarting kplex but that did nothing for me,   Sure hope the new OP will resolve some of these inconsistencies got my pi4 ready to go!
  Reply
#8
(08-12-2019, 09:59 PM)rastam4n Wrote:
(08-12-2019, 01:21 PM)Lddelorme Wrote:
(08-09-2019, 07:47 PM)rastam4n Wrote:
(08-09-2019, 05:33 PM)ddelorme Wrote: solved i think It was due to opengl not being set in old rpi-config there is an option advanced opengl i set to on then opencpn cpu usage normalized at 20 to 30 %cpu.. I still have to  restart kplex in openplotter after reboot

So when you reboot you have to log in remotely to openplotter, run open plotter, and restart kplex in order for pypilot to see the motor controller? Or is there some other reason you need to restart kplex?
I have to restart kplex as the imu data is not getting sent to SignalK or openCPN. but once i restart kplex it all works.. in the new opencpn pypilot app it says it does not see the motor controller but it works.

Interesting, I have to select and apply the serial port assigned to pypilot I order for it to work. I tried restarting kplex but that did nothing for me,   Sure hope the new OP will resolve some of these inconsistencies got my pi4 ready to go!

i had that issue with previous usb to serial converter. it showed up as identical to my epsolar cable
  Reply
#9
Any idea what routine in opencpn is causing the excessive cpu usage?

Does using the autopilot route plugin help?
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)