This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tack functionality does not work for me
#1
Question 
I am trying to figure out how tacking work but looks like I have some general problem. But not sure how to troubleshoot what i lost.
Maybe problem that I have no rudder sensor, isn't?

Today I pulled and built and installed master branch pypilot/pypilot and pypilot/pypilot_pi.
In general pypilot works great but tacking functionality does strange things.

Several things are:
1)Attempt to activate button tack from any interface (LCD,GUI or openCPN plugin) when AP is active heading to lost connection to Pypilot server. only way to get connection back i found - restart from openplotter tab pypilot.
2) No reaction on tack button if it is not activated. Looks reasonable.
3) OpenCPN plugin shows configuration control, but in attempt to inc/dec any value values changing in between -1 to +1 or -0.1 to +0.1

any ideas?


Crash log is below; 
Traceback (most recent call last):
  File "/usr/local/bin/pypilot", line 11, in <module>
    load_entry_point('pypilot==0.9', 'console_scripts', 'pypilot')()
  File "/usr/local/lib/python2.7/dist-packages/pypilot-0.9-py2.7-linux-armv7l.egg/pypilot/autopilot.py", line 464, in main
    ap.run()
  File "/usr/local/lib/python2.7/dist-packages/pypilot-0.9-py2.7-linux-armv7l.egg/pypilot/autopilot.py", line 259, in run
    self.iteration()
  File "/usr/local/lib/python2.7/dist-packages/pypilot-0.9-py2.7-linux-armv7l.egg/pypilot/autopilot.py", line 418, in iteration
    if not self.tack.process():
  File "/usr/local/lib/python2.7/dist-packages/pypilot-0.9-py2.7-linux-armv7l.egg/pypilot/tacking.py", line 131, in process
    headingrate = ap.boatimu.SensorValues['headingrate_lowpass'].value
Traceback (most recent call last):
  File "/usr/local/bin/pypilot", line 11, in <module>
    load_entry_point('pypilot==0.9', 'console_scripts', 'pypilot')()
  File "/usr/local/lib/python2.7/dist-packages/pypilot-0.9-py2.7-linux-armv7l.egg/pypilot/autopilot.py", line 464, in main
    ap.run()
  File "/usr/local/lib/python2.7/dist-packages/pypilot-0.9-py2.7-linux-armv7l.egg/pypilot/autopilot.py", line 259, in run
    self.iteration()
  File "/usr/local/lib/python2.7/dist-packages/pypilot-0.9-py2.7-linux-armv7l.egg/pypilot/autopilot.py", line 418, in iteration
    if not self.tack.process():
  File "/usr/local/lib/python2.7/dist-packages/pypilot-0.9-py2.7-linux-armv7l.egg/pypilot/tacking.py", line 131, in process
    headingrate = ap.boatimu.SensorValues['headingrate_lowpass'].value
NameError: global name 'ap' is not defined
  Reply
#2
People, is tack button in current master works for somebody? in my case autopilot stops to work at all.
  Reply
#3
it's clearly a bug, which crashes the ap if you tack. I will look at this tomorrow.
  Reply
#4
(08-10-2019, 06:41 PM)seandepagnier Wrote: it's clearly a bug, which crashes the ap if you tack.  I will look at this tomorrow.

Did you have ever chance to look in?
  Reply
#5
I have the exact same problem sadly!
  Reply
#6
I have fixed it already but did not push git yet.
  Reply
#7
(09-05-2019, 03:08 PM)seandepagnier Wrote: I have fixed it already but did not push git yet.

Thanks, any chance to push ;-)
  Reply
#8
(10-11-2019, 12:25 AM)partyvi Wrote:
(09-05-2019, 03:08 PM)seandepagnier Wrote: I have fixed it already but did not push git yet.

Thanks, any chance to push ;-)

I did recently push some changes, let me know if tacking is still not working.

There are actually a lot of parameters needed to cover tacking all types of boats.
  Reply
#9
(10-11-2019, 11:49 AM)seandepagnier Wrote:
(10-11-2019, 12:25 AM)partyvi Wrote:
(09-05-2019, 03:08 PM)seandepagnier Wrote: I have fixed it already but did not push git yet.

Thanks, any chance to push ;-)

I did recently push some changes, let me know if tacking is still not working.

There are actually a lot of parameters needed to cover tacking all types of boats.

Did pull and rebuilt yesterday, I still have a problem.
  Reply
#10
(10-11-2019, 11:49 AM)seandepagnier Wrote: I did recently push some changes, let me know if tacking is still not working.

There are actually a lot of parameters needed to cover tacking all types of boats.

Where did you push to?
github.com/pypilot/pypilot still shows newest files 12days, 16 days and 17 days.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)