This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OP 2.xx
#1
Hello, everybody,
I've installed OP 2.0.7.
I then installed signalalk in the installer. 
The installation seemed to run without any problems. 
I kept all default settings.
Unfortunately I can't open sk. 
The browser says that the website is not reachable.
Where is the problem or what am I doing wrong?
Greetings Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "deepl.com english"
PN bitte auf german.  Big Grin
  Reply
#2
try
sudo signalk-server-setup
mare liberum
  Reply
#3
(08-24-2019, 07:01 AM)Luckbert Wrote: Hello, everybody,
I've installed OP 2.0.7.
I then installed signalalk in the installer. 
The installation seemed to run without any problems. 
I kept all default settings.
Unfortunately I can't open sk. 
The browser says that the website is not reachable.
Where is the problem or what am I doing wrong?
Greetings Jürgen


Should be reached at http://localhost:3000/admin/#/dashboard
Maybe get some clues with cat  /var/log/syslog | grep -i 'signalk-server' 
Or just cat  /var/log/syslog

Had a similar problem, used a Raspbian Lite without a WEB browser...  Smile
________________________________________

Blogg; https://pysselilivet.blogspot.com/
  Reply
#4
Hello,
I reinstalled the system according to the instructions and now everything is up and running.
Let's see what the next hurdle looks like.
Thank you for your efforts.

@jim321
The external installation did not work the problems remained the same.

Greetings Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "deepl.com english"
PN bitte auf german.  Big Grin
  Reply
#5
even after re-installation localhost:3000 doesnt start.

this is what my cat command shows:
pi@openplotter:~ $ cat /var/log/syslog | grep -i 'signalk-server'
Oct 2 14:15:36 openplotter signalk-server[372]: Could not parse security config
Oct 2 14:15:36 openplotter signalk-server[372]: ENOENT: no such file or directory, open '/home/pi/.signalk/security.json'
Oct 2 14:16:09 openplotter signalk-server[372]: signalk-server running at 0.0.0.0:[object Object]
Oct 2 14:16:09 openplotter signalk-server[372]: 2 Oct 14:16:09 - [info]
Oct 2 14:16:09 openplotter signalk-server[372]: Welcome to Node-RED
Oct 2 14:16:09 openplotter signalk-server[372]: ===================
.....

and indeed the /security.json file does not exist. How to get it?
any advise how to enable localhost?
  Reply
#6
(10-02-2019, 09:13 AM)SkipperEarly Wrote: even after re-installation localhost:3000 doesnt start.

this is what my cat command shows:
pi@openplotter:~ $ cat  /var/log/syslog | grep -i 'signalk-server'
Oct  2 14:15:36 openplotter signalk-server[372]: Could not parse security config
Oct  2 14:15:36 openplotter signalk-server[372]: ENOENT: no such file or directory, open '/home/pi/.signalk/security.json'
Oct  2 14:16:09 openplotter signalk-server[372]: signalk-server running at 0.0.0.0:[object Object]
Oct  2 14:16:09 openplotter signalk-server[372]: 2 Oct 14:16:09 - [info]
Oct  2 14:16:09 openplotter signalk-server[372]: Welcome to Node-RED
Oct  2 14:16:09 openplotter signalk-server[372]: ===================
.....

and indeed the /security.json file does not exist. How to get it?
any advise how to enable localhost?


Try http://localhost/ - assuming that your browser is running on the same machine as your Signal K server.

Longer explanation:
- a computer can have several network interfaces (think network cards, Ethernet or Wifi)
- all computers have a special network interface called loopback: it just loops back to the same machine, not using any external networking
- In computer networking, localhost is a hostname that means this computer. It is used to access the network services that are running on the host via the loopback network interface. https://en.wikipedia.org/wiki/Localhost
- an http service can run on one or more network interfaces
- 0.0.0.0 is a special address that refers to all network interfaces - in this context it means that the SK server can be reached on all interfaces, including the loopback interface that you get by using the hostname localhost
- the signalk server running on 0.0.0.0:[object Object] or signalk server running on 0.0.0.0:3000 tell you that the SK server has started successfully and is listening for incoming connections from your browser on port 80 OR port 3000. Port 80 is the default http port so you don't need to use that - http://localhost/  and http://localhost:80/  do the same thing. 
- [object Object] is (my) stupid logging code that is not very informative - usually it means that you have used signalk-server-setup with defaults so that the server is automatically started and managed by systemd, the process that manages background server processes on modern Linux systems.
- port numbers like 80 and 3000 here are like numbered doors of a house. If there is nobody listening for your "knock" on the particular door you are trying (a process listening for incoming connections on the port) you'll get the Connection refused error message. The root cause is usually either that the server is not on or you are trying a wrong port.

3000 is the default port for Node.js/Express based web servers, as port 80 is not available for normal user processes - like if you just type `signalk-server` on the command line.

So when you say localhost:3000 does not start a more accurate description would be the server seems to start based on the log entries but there is nothing listening on localhost:3000 - oops, maybe it is on port 80 now, let's try!  Smile

The security related messages are not related - they just tell that you have not activated security/access control on your SK server, and look needlessly like showstopper errors. You will get a security.json file if you turn security on on your server.
  Reply
#7
Thank you tkurki for your explanations! appreciate you effort.

what finally worked for me was to enter
in the raspi browser http://localhost:3000/admin/#/dashboard
  Reply
#8
(10-02-2019, 11:56 AM)SkipperEarly Wrote: Thank you tkurki for your explanations! appreciate you effort.

what finally worked for me was to enter
in the raspi browser http://localhost:3000/admin/#/dashboard

Interesting, I was unable to log into SignaK dashboard on port 3000. I eventually managed to login as //localhost.3443/admin/#/dashboard which I use now, how I got there I don’t rememberer. I’m a complete novice with networking so don’t remember how I got to that port. Should I be using port 3000?
  Reply
#9
You have turned on SSL and the non systemd port for https is 3443.


Sent from my iPhone using Tapatalk
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)