This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PyPilot plugin - config seems broken
#1
Both the windows published plugin, but now also the linux source code seem to have an issue with the PyPilot plugin configuration screen, connected to a TinyPilot.

The main thing I want to change is the Max Current.
  • The up and down buttons don't work any more. 
  • Also, when changing it through the SignalK client, the value reverts back upon clicking OK.
In the lab I have a windows client with pypilot plugin, both most recent versions 5.0 downloaded msi's, and here I already could not change the Max Current. I used to do this through a Raspberry / OpenCPN / default plugin, connected to the same TinyPilot. Here I was able change the Max Current. However I recompiled a new plugin from git and now it also does not work on the raspberry anymore, showing simlar symptoms.

The reason I want to change the Max Current so often is because it keeps on doubling up every now and then. I enter 2 Ampere, it suddenly becomes 4 and then 8. I can see there is some background process that could update servo.max_current, but I don't want that functionality: IMHO a manual parameter should not be updated automatically.

Thx for looking into this!

https://youtu.be/ncatU1Yz-eU
  Reply
#2
The signalk client is stateless, so you do not need to hit "ok" to make changes.

I will check the plugin tomorrow closely, it's definitely broken on the spin buttons as you saw.

Do you know the cause for doubling? Normally it doubles the max current if you hit the end so that it can unstick the ram moving the other direction. Did you hit the max current and get a doubling permanent?
  Reply
#3
Ok thx. Indeed I do hit the end now and then, relying in the max current to force a fault and not go further. I have already ordered microswitches for the end-of-travel mechanism, though.

However, I'm not a fan on the doubling mechanism you describe. Can I disable that in some manner? Where does it happen, in what piece of code?
  Reply
#4
If the ram moves to the end, often time the mechanical part gets "stuck" and so the overcurrent will trigger again trying to move the other direction if the current limit isn't raised. Once it moves the other direction the over current limit is lowered.

It turns out there is a problem with the source code that it records this new current limit and it should not. It might happen if you turn off the autopilot while it's stuck at the end, so I can fix this.


It might be useful on drives which have a slip clutch or end of travel switches or rudder feedback to never double the current limit, but for most users with converted tillerpilots, it's probably needed. I will add this option.
  Reply
#5
I have the same issue with pipilot settings from OC plugin.
Does fix exists?
  Reply
#6
(10-11-2019, 12:23 AM)partyvi Wrote: I have the same issue with pipilot settings from OC plugin.
Does fix exists?
Do you mean you have an issue with the ram getting stuck at the end of travel?

Maybe try reducing the slew speed of the motor so it can't accelerate as fast so that you can also reduce the maximum current which should stop the movement before it gets as stuck.   Also maybe put springs on the drive somehow.
  Reply
#7
Thanks.

But my main problem the configuration Pypilot_pi is edit controls are not working, like in second part of the of the original video. I suspect it may be some incompatible modules or configuration file has not some settings.

Could you send me or give me link to working Pypilot.conf file


Sent from my iPhone using Tapatalk
  Reply
#8
Did you try the latest version of the plugin from git? I have reworked all the controls in the pypilot plugin.
  Reply
#9
(10-13-2019, 09:07 PM)seandepagnier Wrote: Did you try the latest version of the plugin from git?   I have reworked all the controls in the pypilot plugin.

I just recompiled from git on linux, but I seem to have lost both the servo settngs (for which I started this thread) and also the SignalK client now. Is there another way I can set the max motor current or invoke the Signal K client now?

Thx,

[Image: attachment.php?aid=584]


Attached Files Thumbnail(s)
   
  Reply
#10
Hi
They are under calibration, setting tab is to the right of the rudder tab at top

Johan
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)