This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(OP2) IMU data from pypilot not being received by SK or OpenCPN
#1
pasted from another thread as per Sailoogs instructions


Quote:
Sailoog Wrote: Wrote:
(09-25-2019, 03:58 PM)rastam4n Wrote: Wrote:
(09-23-2019, 11:08 AM)Sailoog Wrote: Wrote:
(09-18-2019, 01:27 PM)rastam4n Wrote: Wrote:
(09-18-2019, 12:49 PM)Sailoog Wrote: Wrote:Once again [Image: smile.png]
You do not need any connection in opencpn but the input TCP localhost 10110. Remove any one else.
You have to create the connection TCP localhost 20220 in SK.

Remember that Signal K is the heart of this, it is in charge of getting all data from everywhere. Opencpn only listen at TCP localhost 10110. In OpenPlotter 2 there is a useful tool in openplotter settings called "check system". There you will get important clues of what is wrong in your system (pypilot no implemented yet).

Hi Sailoog

I understand about opencpn, I have one connection in the opencpn connection tab which is localhost 10110

I have added a connection in signal k for 1. ttyUSB0 and 2. localhost 20220. 

The connection to 20220 is giving errors, "connect ECONREFUSED 127.0.0.1:20220

check system is not reporting any problems


 "(pypilot no implemented yet)"  what does this mean? I understand that the autopilot function is not working but for IMU only it is, I can see the data the IMU is working and it is calibrated. 

is it set to refuse connections from signal k? I don't understand to enabling the IMU if the data is not accessible?

ops, shit. sorry, it is my fault.

TCP is not the connection you have to create in SK. You have to create UDP localhost port 52000 to get IMU data in SK.

TCP localhost 20220 will be the connection for autopiot and it will be NMEA 0183 (not working yet).

sorry again, too much in my head...

I understand. Thank you for the clarification,

Unfortunately this is still not working.. Is there anything else I need to do? Here is what I added to SK connections tab. I am not getting any error but the connection is not listed on the dashboard and there is no data on my opencpn dashboard.

Has this been confirmed to work?

OK I know what happens here. You are expecting NMEA 0183 data and what you are getting is signal k data.

Pypilot has 2 modes, "only IMU" and "autopilot".
In IMU mode we send signal k data for heading, trim and heel by UDP 52000.
In autopilot mode we send trim and heel by UDP 52000 in signal k format and heading in NMEA 0183 format by TCP 20220.

This will be explained in docs of course.

Thank you Sailoog

So interesting thing, the pitch and roll is being shown in the opencpn pypilot plugin calibration window but the mag.heading is not. So the data is there, how can i get this data showing in my dashboard plugin?
  Reply
#2
(09-30-2019, 12:55 PM)rastam4n Wrote: pasted from another thread as per Sailoogs instructions


Quote:
Sailoog Wrote: Wrote:
(09-25-2019, 03:58 PM)rastam4n Wrote: Wrote:
(09-23-2019, 11:08 AM)Sailoog Wrote: Wrote:ops, shit. sorry, it is my fault.

CP is not the connection you have to create in SK. You have to create UDP localhost port 52000 to get IMU data in SK.

TCP localhost 20220 will be the connection for autopiot and it will be NMEA 0183 (not working yet).

sorry again, too much in my head...

I understand. Thank you for the clarification,

Unfortunately this is still not working.. Is there anything else I need to do? Here is what I added to SK connections tab. I am not getting any error but the connection is not listed on the dashboard and there is no data on my opencpn dashboard.

Has this been confirmed to work?

OK I know what happens here. You are expecting NMEA 0183 data and what you are getting is signal k data.

Pypilot has 2 modes, "only IMU" and "autopilot".
In IMU mode we send signal k data for heading, trim and heel by UDP 52000.
In autopilot mode we send trim and heel by UDP 52000 in signal k format and heading in NMEA 0183 format by TCP 20220.

This will be explained in docs of course.

Thank you Sailoog

So interesting thing, the pitch and roll is being shown in the opencpn pypilot plugin calibration window but the mag.heading is not. So the data is there, how can i get this data showing in my dashboard plugin?

Hi been playing with Signal K and you may be interested in my posts yesterday and this morning
  Reply
#3
Thanks Johnny I found your posts but unfortunately that is not causing my challenges. I already have that set to active and all of the mag compass/pitch/roll etc selected... still nothing in OpenCPN....
  Reply
#4
This has not yet been solved, can someone please assist me with trouble shooting this?
  Reply
#5
If pypilot is in imu only mode, it won't produce nmea messages. In full autopilot mode (you could just never engage it) you will get tcp nmea messages on port 20220 which opencpn can read and use in the dashboard.
  Reply
#6
WOW, Thank you Sean! So basically I need to wait till they enable the Autopilot mode in OP2.

I wonder how Sailogg can report that they are not experiencing the same difficulties. They explicitly asked me to start this thread because they were not having any trouble.
  Reply
#7
Hello rastam4n, 
I also had some problems with different dates today. 
How did you connect your sensors?
In the attachment you can see my settings in SK with which I partially made it. 
I connected a Montessier-HAT. The sensors are connected with I2C.
Maybe it helps. 
Greetings Jürgen


Attached Files Thumbnail(s)
       
Angel  Entschuldigung für mein Englisch. Es ist "google english"
PN bitte auf german.  Big Grin
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)