This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem to start pypilot from master. Several old and new problems.
#1
Hello 

I have Several problems, please help me resolve them. It is very disappointing to have good tool but working so buggy for me.

Master version from  Jul 17 look like working for me but:
1) Any attempt to 'tack' from open CPN or Pypilot interface is crashing pypilot server. I can live without it but something going wrong in general.
2) Open CPN pypilot plugin works well, but pilot settings are not working. Up/down interface buttons just drop value to 0.1 or -0.1.
Looks like some parameters are not accessable.

-------------------------------------

Today I tryed to run pypilot from today master with hope something will be changed, instead, after build and install pypilot server stopped to work at all.


Manual start 'pypilot'  does show errors: 
ERROR loading learning.py No module named pilots.learning

ERROR loading wind.py No module named pilots.wind

ERROR loading basic.py No module named pilots.basic
ERROR loading simple.py No module named pilots.simple
looks like changes was done for python 3.x are not working well for 2.7 (do i need to switch to 3.4+?)

I fixed  this crash by editing pypilot/pilots/__init__.py
line :__import__('pilots.'+module[:-3], locals(), globals())
I removed 'pilots.'+

Then it crashed with attempt /0 in rudder.py. I found the default value in "rudder.scale" was 0.0
After I set it as 1.0 pypilot start work.

Looks like my pypilot.conf file inherited form previous versions has not some valyes.
 Could somebody send me working (or default) pypilot.conf?

Please help!
  Reply
#2
This worked for me: https://github.com/pypilot/pypilot/pull/29/files
replace all in pypilot/pilots/__init__.py by

Code:
import simple, basic, learning, wind

and install again
  Reply
#3
(10-10-2019, 11:27 PM)partyvi Wrote: Hello 

I have Several problems, please help me resolve them. It is very disappointing to have good tool but working so buggy for me

Master version from  Jul 17 look like working for me but:
1) Any attempt to 'tack' from open CPN or Pypilot interfg
Hi,

Sorry for the bugs.  I have neglected pypilot the past few weeks because I am replacing the standing rigging on a sailboat and it's taking all my time to make the tangs, chainplates and stays.   Everything has to be cheapest way possible using galvanized wire and so it takes all my time. I am even forced to make the clevis pins myself from bronze round bar because they cost $7 each otherwise.

Anyway... thanks for reporting that the rudder.scale of zero causes a crash.  I must fix it, but also the default should be 1.0.

The tacking functionality is known issue I will investigate it, and should be fixed in a few weeks.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)