This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Update MXTommy does not work
#1
Just did the latest update of MXTommy. However MXTommy did not start in OpenPlotter. Not with localhost or 127.0.0.1.

Using MXTommy from another system with Ip adres of the OpenPlotter RPI it does work.

If I use the same adress 192.168.1.146 in OpenPlotter MXTommy also works.

There is something missing.

Bram
  Reply
#2
Works fine at my install.
Have you checked /etc/hosts file
Mine looks like this:
127.0.0.1 localhost
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

127.0.1.1 openplotter
10.10.10.1 openplotter.local openplotter
  Reply
#3
It worked fine before. But after the (SignalK) MxTommy upgrade to 0.1.12. But if I use the signalK Ip adres then it is working.
  Reply
#4
don't know if there is somewhere a dedicated MXTommy thread - so allow me to raise a question here ( or move to ? )
- how can coordinates get displayed. I tried "numeric" and "unitless" but that does not display e.g. the position satisfying.

Can anyone advise how to configure displaying position data with Degree Minutes.dec N/S or E/W ?
  Reply
#5
(10-14-2019, 04:25 AM)SkipperEarly Wrote: don't know if there is somewhere a dedicated MXTommy thread - so allow me to raise a question here ( or move to ? )
- how can coordinates get displayed. I tried "numeric" and "unitless" but that does not display e.g. the position satisfying.

Can anyone advise how to configure displaying position data with Degree Minutes.dec N/S or E/W ?

I guess only the author will be able to answer this question
  Reply
#6
MxTommy works very well. Problem with the network settings is not yet solved.

Changing the format of the position data seems allready solved in another application: Instruments.

It is a bit hidden. But if you click on the small icon in the upper left corner, you can change the position data format.

It seems to me, not to be difficult to add this option to MxTommy KIP.
  Reply
#7
When I use the link 10.10.10.1:3000/@mxtommy/kip/#/page/0 on another devise the "customization" of my configuration is not carried over.
Can anyone advise how to copy the configuration to another e.g. android phone or tablet?
  Reply
#8
i think the config is saved in the browser so it would need to be set up again for each device.

http://forum.openmarine.net/showthread.p...36#pid4836

just to clarify MxTommy is the developer, kip is the app.
and he has not logged on here for 3 months and last update for kip on github was 4 months ago.
thread to read for discussions with the dev.
http://forum.openmarine.net/showthread.php?tid=998
mare liberum
  Reply
#9
as for networking
from the pi directly ssh or vnc 127.0.0.1 or localhost or 10.10.10.1 should work.
if connected to the pi's ap with another device
use 10.10.10.1
if connected to another network say pi Ethernet to router you need to use the ip the router assigned to it like 192.168.x.x if you connect thru that network.
openplotter makes a network @10.10.10.1 if you connect to a network with 192.168.x.x.it wont see the 10.10.10.1 localhost network. and it will use the 192.168.x.x to query any web page that openplotter host's
i hope i explained that ok
mare liberum
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)