This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Opencpn does not receive the nmea sentences from the wind station
#1
Hi everyone,
I have a Raspberry pi3 with openplotter 0.8.0 installed. I connected my wind station through a serial / USB converter but on the dashboard opencpn "app. wind speed and direction" I have no indication. On inspector I see nmea data transit but on opencpn nmea debug window I have no data nmea.
What could be the problem?

Thanks 

Gas
  Reply
#2
What make/model is the NMEA Wind Masthead unit Gas ?

Steve/G4MJW
  Reply
#3
(09-25-2016, 07:29 AM)Microyacht Wrote: What make/model is the NMEA Wind Masthead unit Gas ?

Steve/G4MJW

The wind unit is a Navman W100
  Reply
#4
Many thanks for the info Gas.

I have my system working with GPS, AIS and System Clock kept up-to-date by GPS. I also have the whole suite of CM93 Charts covering the entire world:

[Image: AION-1.jpg]


I've not yet got an NMEA Masthead Wind Unit but that's next on the list. It will probably be a NASA unit as they are easily available in the UK and look well made:

[Image: Nasa-Wind-NMEA.jpg]

I wonder if you've had any luck solving your problem yet?

Steve/G4MJW
  Reply
#5
If inspector does show you nmea sentences and opencpn nothing. Then there is something wrong with your connection settings in opencpn.
Opencpn settings should be:
(Net 127.0.0.1:10110 1 TCP Input In:None, Out: None)
(Net 127.0.0.1:10110 1 UDP Output In:None, Out: Send RMB)
  Reply
#6
(09-28-2016, 04:53 AM)e-sailing Wrote: If inspector does show you nmea sentences and opencpn nothing. Then there is something wrong with your connection settings in opencpn.
Opencpn settings should be:
(Net 127.0.0.1:10110 1 TCP Input In:None, Out: None)
(Net 127.0.0.1:10110 1 UDP Output In:None, Out: Send RMB)

I have checked the connection settings in opencpn and it's corrects. The strange things is that GPS sentences are present in inspector and in opencpn and gps  works correctly!
  Reply
#7
It looks like you made a step forward. "On inspector I see nmea data transit but on opencpn nmea debug window I have no data nmea."
So you have on both sides nmea. Please post some wind NMEA sentences from Inspector (MWV, VWR) should look like:
$IIMWV,313,T,08.16,N,A*2B
  Reply
#8
(09-28-2016, 10:48 AM)e-sailing Wrote: It looks like you made a step forward. "On inspector I see nmea data transit but on opencpn nmea debug window I have no data nmea."
So you have on both sides nmea. Please post some wind NMEA sentences from Inspector (MWV, VWR) should look like:
$IIMWV,313,T,08.16,N,A*2B

Here the wind NMEA sentences from Inspector:

$IIVPW,,,,, 
$IIVWT,,,,,,,,, 
$IIVWR,137,R,000,N,,,, 
$PTTKW,137,S,000,B,00.0 
$IIMWV,137,R,000,N,A 
$IIVPW,,,,, 
$IIVWT,,,,,,,,, 
$IIVWR,137,R,000,N,,,, 
$PTTKW,137,S,000,B,00.0
  Reply
#9
There is no checksum at the end of each sentence. Has been discussed before.
http://forum.openmarine.net/archive/inde...d-179.html
Does it solve your problem?
  Reply
#10
Ok, I'll try to disable the checksum control on Opencpn TCP connection.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)