This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Newbie (yes they still are out there) - Link NMEA Simulator to OP2 on Raspi
#1
All,
Am new (like lot's of people) and I try to replicate stuff I have read.
Here my steps:

1. Got OP2 running on my Raspi.
2. Got it running headless (!) And now via VNC I can login to the Raspi
(all over wifi)
 Then I read about (https://chrome.google.com/webstore/detai...ll/related)
3. read about it and then I wanted to try it out
4. Set it up as a TCP Server
5. and pointed OP to the same IP address (and port) - remember I logged in via wifi
(maybe that is the mistake, but I'm not sure ...)
6. then nothing came into OP

So now I'm lost.

(my question - How to get the data in from the simulator ...)

Already very grateful to you all!

Best,

Bart (from Belgium)
  Reply
#2
Welcome to our forum.

In OP2 you need to install Signal K. If you haven't install it.
Enter the Signal K admin page "localhost:3000" or if your hostname is openplotter then "openplotter.local:3000".
login
Select Server->Connections
If you have Connections with Input Type NMEA0183 check if there is already one with "NMEA 0183 Source" "TCP Server".
If not push "+Add"
Select "Input Type" "NMEA 0183"
Input an "ID" (something like "inputNMEA")
Select "NMEA 0183 Source" "TCP Server"
Apply
Restart (upper right corner)

Goto your NMEA Simulator
Press Stop if it is running.
Select "Options"->"Settings" -> "Server" "TCP/IP"
"TCP Client"
IP Address: 127.0.0.1
Port: 10110
Save
Start

On the Signal K Dashboard you should see a yellow line of incomming data.
Martin
  Reply
#3
(11-10-2019, 07:56 AM)Martin,Thanks for clear steps.I can go to localhost:3000But then it stops ... I can not login ... I can not register ... (I can type my email and can create an PW, but it will not allow me to hit "Submit")I can not get past that step ...Help Bart e-sailing Wrote: Welcome to our forum.

In OP2 you need to install Signal K. If you haven't install it.
Enter the Signal K admin page "localhost:3000" or if your hostname is openplotter then "openplotter.local:3000".
login
Select Server->Connections
If you have Connections with Input Type NMEA0183 check if there is already one with "NMEA 0183 Source" "TCP Server".
If not push "+Add"
Select "Input Type" "NMEA 0183"
Input an "ID" (something like "inputNMEA")
Select "NMEA 0183 Source" "TCP Server"
Apply
Restart (upper right corner)

Goto your NMEA Simulator
Press Stop if it is running.
Select "Options"->"Settings" -> "Server" "TCP/IP"
"TCP Client"
IP Address: 127.0.0.1
Port: 10110
Save
Start

On the Signal K Dashboard you should see a yellow line of incomming data.
Martin
  Reply
#4
Have you tried the solution from garysmith http://forum.openmarine.net/showthread.php?tid=1225 ?
  Reply
#5
(11-12-2019, 11:53 AM)e-sailing Wrote: Have you tried the solution from garysmith http://forum.openmarine.net/showthread.php?tid=1225 ?

Yes I have tried 3 things:
(I have signalK Sever 1.18.0)

UN and PW: openplotter
My UN and PW from my Raspi
And the solution from garysmith http://forum.openmarine.net/showthread.php?tid=1225 

None of them work ...

Help 

Bart
  Reply
#6
[attachment=606][attachment=606]I tried to install SignalK again. But once I started it I got this ... Some notion about "could not parse Security config"

All, I solved my own problem .. Wink
Thanks anyway
Bart


Attached Files Thumbnail(s)
   
  Reply
#7
Just to clear up some things:
- not being able to parse security config is not an error, it usually means that security is not enabled and there is no security config
- address in use errors mean that sk server is already running and the ports that the server is trying to bind are already in use. If you have run the sk server setup the server starts during computer startup and manual attempts to start it a second time will fail



Sent from my iPhone using Tapatalk
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)