This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CLOSED] DHCPCD 100% on one core after network loss
#1
Openplotter V2. Network set to create openplotter network and connect to mobile phone hotspot. If I take the phone for a walk and come back the Pi3B+ will connect to the phone again OK but in htop dhcpcd will b maxed out on a core. Reboot solves it. Any ideas where to look? Ta

[Image: gyIcrot.png]

[Image: 3rbfnuE.png]

[Image: RsifQlW.png]
  Reply
#2
I just have tested it. But everything incl. dhcpcd work OK.
Can you reproduce the situation?
Can you check
"systemctl status dhcpcd" and
"route -n"
before and after?

I have watched that sometimes the standard gateway doesn't change.
  Reply
#3
OK, didn't see dhcpcd in htop max out a core but with a laptop connected to 10.10.10.1 and openplotter usb wifi dongle connected to mobile hotspot on 192.168.43.97, disabling the hotspot resulted in the laptop being kicked off 10.10.10.1, unable to connect.

Before:>>>>>>>
pi@openplotter:~ $ systemctl status dhcpcd
● dhcpcd.service - dhcpcd on all interfaces
Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2019-11-10 15:57:34 GMT; 28min ago
Process: 341 ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -b (code=exited, status=0/SUCCESS)
Main PID: 415 (dhcpcd)
Tasks: 2 (limit: 1633)
Memory: 4.6M
CGroup: /system.slice/dhcpcd.service
├─415 /sbin/dhcpcd -q -b
└─517 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan1 -Dnl80211,wext

Nov 10 15:57:44 openplotter dhcpcd[415]: wlan1: adding default route via 192.168.43.219
Nov 10 16:08:51 openplotter dhcpcd[415]: wlan1: carrier lost
Nov 10 16:08:51 openplotter dhcpcd[415]: wlan1: deleting route to 192.168.43.0/24
Nov 10 16:08:51 openplotter dhcpcd[415]: wlan1: deleting default route via 192.168.43.219
Nov 10 16:13:36 openplotter dhcpcd[415]: wlan1: carrier acquired
Nov 10 16:13:37 openplotter dhcpcd[415]: wlan1: rebinding lease of 192.168.43.97
Nov 10 16:13:37 openplotter dhcpcd[415]: wlan1: probing address 192.168.43.97/24
Nov 10 16:13:42 openplotter dhcpcd[415]: wlan1: leased 192.168.43.97 for 3600 seconds
Nov 10 16:13:42 openplotter dhcpcd[415]: wlan1: adding route to 192.168.43.0/24
Nov 10 16:13:42 openplotter dhcpcd[415]: wlan1: adding default route via 192.168.43.176
pi@openplotter:~ $ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.43.176 0.0.0.0 UG 304 0 0 wlan1
0.0.0.0 10.10.10.1 0.0.0.0 UG 510 0 0 wlan9
10.10.10.0 0.0.0.0 255.255.255.0 U 510 0 0 wlan9
192.168.43.0 0.0.0.0 255.255.255.0 U 304 0 0 wlan1
pi@openplotter:~ $

after ->>>>>
pi@openplotter:~ $ systemctl status dhcpcd
● dhcpcd.service - dhcpcd on all interfaces
Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2019-11-10 15:57:34 GMT; 29min ago
Process: 341 ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -b (code=exited, status=0/SUCCESS)
Main PID: 415 (dhcpcd)
Tasks: 2 (limit: 1633)
Memory: 5.0M
CGroup: /system.slice/dhcpcd.service
├─415 /sbin/dhcpcd -q -b
└─517 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan1 -Dnl80211,wext

Nov 10 16:08:51 openplotter dhcpcd[415]: wlan1: deleting default route via 192.168.43.219
Nov 10 16:13:36 openplotter dhcpcd[415]: wlan1: carrier acquired
Nov 10 16:13:37 openplotter dhcpcd[415]: wlan1: rebinding lease of 192.168.43.97
Nov 10 16:13:37 openplotter dhcpcd[415]: wlan1: probing address 192.168.43.97/24
Nov 10 16:13:42 openplotter dhcpcd[415]: wlan1: leased 192.168.43.97 for 3600 seconds
Nov 10 16:13:42 openplotter dhcpcd[415]: wlan1: adding route to 192.168.43.0/24
Nov 10 16:13:42 openplotter dhcpcd[415]: wlan1: adding default route via 192.168.43.176
Nov 10 16:26:51 openplotter dhcpcd[415]: wlan1: carrier lost
Nov 10 16:26:51 openplotter dhcpcd[415]: wlan1: deleting route to 192.168.43.0/24
Nov 10 16:26:51 openplotter dhcpcd[415]: wlan1: deleting default route via 192.168.43.176
pi@openplotter:~ $ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 10.10.10.1 0.0.0.0 UG 510 0 0 wlan9
10.10.10.0 0.0.0.0 255.255.255.0 U 510 0 0 wlan9
pi@openplotter:~
  Reply
#4
I can see the same entrys when I disable my mobil hotspot. No high cpu strain.
Then I switched on mobile hotspot again. Auto connecting and everything is fine.
  Reply
#5
(11-10-2019, 06:09 PM)e-sailing Wrote: I can see the same entrys when I disable my mobil hotspot. No high cpu strain.
Then I switched on mobile hotspot again. Auto connecting and everything is fine.

Thanks. I need to dig deeper I think, learn more about how wifi works on raspbian. 
Something is definitely up , I've an ESP32 sending data, if it's trying to log onto the OP network it really struggles to get connected on 10.10.10.1 and not many udp packets get through if it does, but try on the mobile network of 192.168.43.97 it logs on quickly an all the data seems to be sent OK. 

Will explore further & report back Smile
  Reply
#6
Fingers crossed found it - I'd a little node red running a speedtest flow to plot upload/download speeds of a mobile data sim, disable that and the esp seems to log on OK now, hopely the dhcpcd issues were related. Was interesting though, not much a Pi can't do Smile

[Image: nvwe993.png]
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)