This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SignalK connection: instrument panel shows no displays
#1
First post, having a blast but slower progress as I am not too technical.

I am trying to make simple racing display showing SOG, heading etc.  

I can't see any instruments and I don't think my signalK Instrument panel is connecting.  I click on button to connect (far right upper corner) and then click on: Connect to ws//localhost:80  I have setup an Input: SignalK TCP  localhost 10110 connection in Signal K 

I have installed the Instrument Panel under SignalK from Github.  

Running 2.0.11-beta Openplotter settings, RPi3+, Globalsat ND-105c

Thanks in advance!  Presume I know no networking or coding terms but I can google of course and plod through it

Edit: typing Openplotter-network in a terminal gives me: bash o--n--: command not found
  Reply
#2
Instrumentpanel is installed with the SK server, I don’t understand your comment about installing it from github.

And if you install it from github you have to install dependencies and build it. Far easier to just use it and install updates from the app store.

But first things first: what data sources do you have in the system? Is it just that you have no data?






Sent from my iPhone using Tapatalk
  Reply
#3
(11-24-2019, 06:50 AM)kailolo Wrote: First post, having a blast but slower progress as I am not too technical.

I am trying to make simple racing display showing SOG, heading etc.  

I can't see any instruments and I don't think my signalK Instrument panel is connecting.  I click on button to connect (far right upper corner) and then click on: Connect to ws//localhost:80  I have setup an Input: SignalK TCP  localhost 10110 connection in Signal K 

I have installed the Instrument Panel under SignalK from Github.  

Running 2.0.11-beta Openplotter settings, RPi3+, Globalsat ND-105c

Thanks in advance!  Presume I know no networking or coding terms but I can google of course and plod through it

Edit: typing Openplotter-network in a terminal gives me: bash o--n--: command not found

At first make a connection to the internet to get the latest updates. Go to the icon Raspberry (left upper corner) then go to OpenPlotter settings. Add sources and then update candidates.

Restart your OpenPlotter RPI and you have the latest updates.

Then you have to add your GPS module. Go the SignalK icon, login with user pi and password raspberry. Go to connections and click on add. Choose nmea183 input, set enabeld to on. Give gps a name. Say gpsmouse or other name. Then set the serial port. There allready an indication what port is available, then the baudrate (4800). Apply. Then after restart (left upper corner) you must see the nummers changing. Now the GPS works in SignalK. If you don't see this try another port.

In the latest updates you see in the OpenPlotter section OpenPlotter Dasboard. Click on one of these and then the view icon. Now you see the working of your GPS.

With a right mouseclick you can place icons on your Desktop.

Bram
  Reply
#4
the baud rate on my gps puck is 9600 so if you get gibberish at 4800 try changing the baud rate.
mare liberum
  Reply
#5
(11-24-2019, 03:13 PM)tkurki Wrote: Instrumentpanel is installed with the SK server, I don’t understand your comment about installing it from github.

And if you install it from github you have to install dependencies and build it. Far easier to just use it and install updates from the app store.

But first things first: what data sources do you have in the system? Is it just that you have no data?



I should clarify, I installed SignalK (which launches a tab in Chromium) then, when I click on @SignalK/Instrumentpanel (via Webapps) It doesn't show any widgets as demo does but it has a link in the center that says SignalK Instrument Panel that takes me to Github.  I then cloned that and installed that.  Is that needed?  

The data source is the Globalsat GPS dongle that I can see data from.  I have the connection as TCP localhost 10110.  Enabled.  Is that the best way to get GPS serial data?  I saw in the Openplotter document it lists several connections- how does one know which one to use and when?  

I am hoping to be able to display the widgets then, feed my GPS data to them.  Thanks tkurki
  Reply
#6
(11-24-2019, 04:00 PM)verkerkbr Wrote:
(11-24-2019, 06:50 AM)kailolo Wrote: First post, having a blast but slower progress as I am not too technical.

I am trying to make simple racing display showing SOG, heading etc.  

I can't see any instruments and I don't think my signalK Instrument panel is connecting.  I click on button to connect (far right upper corner) and then click on: Connect to ws//localhost:80  I have setup an Input: SignalK TCP  localhost 10110 connection in Signal K 

I have installed the Instrument Panel under SignalK from Github.  

Running 2.0.11-beta Openplotter settings, RPi3+, Globalsat ND-105c

Thanks in advance!  Presume I know no networking or coding terms but I can google of course and plod through it

Edit: typing Openplotter-network in a terminal gives me: bash o--n--: command not found

At first make a connection to the internet to get the latest updates. Go to the icon Raspberry (left upper corner) then go to OpenPlotter settings. Add sources and then update candidates.

Restart your OpenPlotter RPI and you have the latest updates.

Then you have to add your GPS module. Go the SignalK icon, login with user pi and password raspberry. Go to connections and click on add. Choose nmea183 input, set enabeld to on. Give gps a name. Say gpsmouse or other name. Then set the serial port. There allready an indication what port is available, then the baudrate (4800). Apply. Then after restart (left upper corner) you must see the nummers changing. Now the GPS works in SignalK. If you don't see this try another port.

In the latest updates you see in the OpenPlotter section OpenPlotter Dasboard. Click on one of these and then the view icon. Now you see the working of your GPS.

With a right mouseclick you can place icons on your Desktop.

Bram


Hi Bram, appreciate the complete, simple steps.  I was off by 2 versions on SignalK (now running 2.0.6-beta) and upgraded the rest to current.  Fwiw, I see I didn't install Network... I am guessing that is important lol.. I also don't need XyGrib I don't think as I won't need Grib files nor I2c, PyPliot, Mhat or CanBus but I am open to hear more as it relates to my simple instrument goal.

I added the GPS NMEA0183 and after seeing a pipe error, I changed the USBttyAmo to USBtty0 and.. seeing no errors, went back to SignalK Node Server and clicked on Instrument panel and.. Boom.. instruments appear. I am stoked so thank you!  Before that I installed some other Dashboards that I didn't have available. 

I launch mxtommy/kip and wow.. looks killer.  I want to take my 22in monitor, waterproof house it and put it up by the mast haha.  

Interesting, when I launch SignalK from menu or click on desktop icon, I get Site Connection Error localhost refused connection.  The URL says simply localhost:3000 

Ideas on that?  I get to SignalK NS from new tab and icons in the middle of that, from previous launches I imagine.  

Cheers and thanks all! Now to find a bright enough (1000nits+) (maybe touch) screen and waterproof house it.  I will power it with Prius modules as I have many of them and run wires to the box.  

(11-25-2019, 06:48 AM)jim321 Wrote: the  baud rate on my gps puck is 9600 so if you get gibberish at 4800 try changing the baud rate.

Thanks Jim.  Good to know.  The specs for this one are 4800 and it appears to be working.  I'll rig up a mobile powered unit and screen and test it out here soon.  Got it working thanks to everyone's help.
  Reply
#7
(11-24-2019, 04:00 PM)verkerkbr Wrote: Interesting, when I launch SignalK from menu or click on desktop icon, I get Site Connection Error localhost refused connection.  The URL says simply localhost:3000 

Ideas on that? 

I get the same happening - waiting for ideas as well Smile
  Reply
#8
(11-29-2019, 01:03 AM)Lazzz Wrote:
(11-24-2019, 04:00 PM)verkerkbr Wrote: Interesting, when I launch SignalK from menu or click on desktop icon, I get Site Connection Error localhost refused connection.  The URL says simply localhost:3000 

Ideas on that? 

I get the same happening - waiting for ideas as well Smile

try the IP localhost ip 127.0.0.1:3000
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)