This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Testing Moitessier 2.0.3-beta
#1
Hi All!

I've installed the Moitessier 2.0.3 beta, and managed to get the driver updated to moitessier_4.19.75-vl+.ko

I'm on a p4, started from scratch (not the NOOB), and have moitessier v1.

In the Moitessier app, the system check all OK:

Code:
Moitessier HAT is attached.
I2C is enabled.
SPI is enabled.
Moitessier HAT package is installed.
Package: moitessier
Status: install ok installed
Maintainer: Thomas POMS <hwsw.development@gmail.com>
Architecture: armhf
Version: 1.4.0
Description: Moitessier HAT (AIS/GNSS navigation)
 This package provides all the relevant tools, binaries and scripts to communicate, control and update the Moitessier HAT.
Homepage: https://www.rooco.eu

The configuration a bit less so:

Code:
AIS - GNSS
Device: /dev/moitessier.tty
Alias: /dev/ttyOP_moit
Connection: App = Pypilot, Device = /dev/ttyOP_moit, ID = 1, Status = enabled
Compass - Trim - Heel
Pypilot mode: autopilot
Connection: Signal K connection ID = Pypilot NMEA 0183
Signal K to NMEA 0183 plugin: enabled
   Heading conversion: enabled
   Trim - Heel conversion: enabled
Pressure - Temperature
I2C - Signal K key for pressure: none
I2C - Signal K key for temperature: none
Connection: not connected

The OpenPlotter setting check system seems OK:

Code:
Checking OpenPlotter autostart... | enabled
Checking user "pi" password... | changed
Checking screensaver state... | disabled
Checking headless state... | disabled
Checking OpenPlotter packages source... | added
Checking Signal K server... | running
Checking I2C sensors...Checking WIFI Access Point password... | changed
Checking OpenCPN... | running | autostart enabled
Checking Pypilot... | Autopilot
Checking Moitessier HAT... | attached | I2C enabled | SPI enabled | package installed
Checking serial connections alias... | All your serial connections have an assigned alias
Checking serial connections conflicts... | no conflicts
Checking network connections conflicts...
CHECK SYSTEM FINISHED

In the Serial app, I've added the moitessier.tty  with default settings(SignalK?)
There's 2 more devices in the serial app: ttyAMA0 and ttyS0

in PyPilot I see the device (/dev/ttyOP_moit) with 2 connections (NMEA over TCP and Signal K over UDP, both port 20220)


So, bit mixed. Can't get any data from the HAT, anywhere. I'm quite sure I'm missing a few steps, i anyone has a bit of a structured guide to set this up I'd be much obliged..

Thanks!
  Reply
#2
Drivers

Installed and working ok

 
AIS - GNSS

With your current configuration you should get data in signal k and opencpn. If you do not get position or AIS blanks you may have bad reception, satellite coverage, or you are inside a building. Open the NMEA debug window in OpenCPN to check if you get NMEA data.

Why do you want to get AIS and GNSS in pypilot? use this only if you are connecting a pypilot controller. The normal use is creating a signal k connection for the hat in serial app.

Compass - Trim - Heel

The same. Why "autopilot" mode? use "only compass" if you are not using a pypilot controller.

Pressure - Temperature

You have an error in I2C app. You have installed the latest version without removing the old settings as we warned. Open file /home/pi/.openplotter/openplotter.conf and remove any data under [I2C] tag. After configuring the sensors again everything will work including another error you have in network app.
  Reply
#3
(01-10-2020, 06:25 AM)Sailoog Wrote: Pressure - Temperature

You have an error in I2C app. You have installed the latest version without removing the old settings as we warned. Open file /home/pi/.openplotter/openplotter.conf and remove any data under [I2C] tag. After configuring the sensors again everything will work including another error you have in network app.

Thanks Sailoog
So I have deleted everything under the [12C] tag and reinstalled 12C, now the 12C app opens. 
There were two 12C addresses listed  68 and 77+

SO I added them both on the sensor tab and created the connections sk - NMEA 0183. 

I now get GPS connection and I get Pressure but I am not getting temperature. Do you know what might cause this?


Attached Files Thumbnail(s)
   
  Reply
#4
(01-10-2020, 10:19 AM)rastam4n Wrote:
(01-10-2020, 06:25 AM)Sailoog Wrote: Pressure - Temperature

You have an error in I2C app. You have installed the latest version without removing the old settings as we warned. Open file /home/pi/.openplotter/openplotter.conf and remove any data under [I2C] tag. After configuring the sensors again everything will work including another error you have in network app.

Thanks Sailoog
So I have deleted everything under the [12C] tag and reinstalled 12C, now the 12C app opens. 
There were two 12C addresses listed  68 and 77+

SO I added them both on the sensor tab and created the connections sk - NMEA 0183. 

I now get GPS connection and I get Pressure but I am not getting temperature. Do you know what might cause this?

Do you have a BME280 sensor connected? if not, remove it from the list.

If you want to have temperature reading just define a signal k key for temperature in MS5607-02BA03 sensor (this is the moitessier sensor for pressure and temperature). Select temperature and click on edit.
  Reply
#5
(01-10-2020, 11:07 AM)Sailoog Wrote: Do you have a BME280 sensor connected? if not, remove it from the list.

If you want to have temperature reading just define a signal k key for temperature in MS5607-02BA03 sensor (this is the moitessier sensor for pressure and temperature). Select temperature and click on edit.

I thought it might be on the Moitessier hat since it was listed in the addresses.. I have removed it and added a signal K key for temerature.. everything seems to be working fine now.  

Well except I have magnetic interference from the fan on my RPi so I will have to figure that out next.

what pins are used by the Hat? I will need to extend the hat away from the Rpi, my riser header is not high enough apparently. I will have to separate them I guess... is there anyway to block the interference from the fan other then space?

Thank you.
  Reply
#6
BME280 is not listed in the addresses, that x68 is the IMU address. Fans and speakers make a high magnetic interference but are you sure you need a fan? with moitessier hat 2 we include a header extension to make place for static headsinks, that should be enough for raspberry 4. If you have your raspberry and hat inside a closed enclosure add the fan to the enclosure far from the hat.
  Reply
#7
(01-10-2020, 12:04 PM)Sailoog Wrote: BME280 is not listed in the addresses, that x68 is the IMU address. Fans and speakers make a high magnetic interference but are you sure you need a fan? with moitessier hat 2 we include a header extension to make place for static headsinks, that should be enough for raspberry 4. If you have your raspberry and hat inside a closed enclosure add the fan to the enclosure far from the hat.

The fan module is a hat which gives me the option to power the RPi with wire leads instead of a USB plug, and it gives me a physical shut down switch. So I will use it, I just need to mount the hat away fro the RPI. I have jumpers I just need to know which pins are used so I don’t have to jumper them all.
  Reply
#8
(01-10-2020, 11:07 AM)Sailoog Wrote:
(01-10-2020, 10:19 AM)rastam4n Wrote:
(01-10-2020, 06:25 AM)Sailoog Wrote: Pressure - Temperature

You have an error in I2C app. You have installed the latest version without removing the old settings as we warned. Open file /home/pi/.openplotter/openplotter.conf and remove any data under [I2C] tag. After configuring the sensors again everything will work including another error you have in network app.

Thanks Sailoog
So I have deleted everything under the [12C] tag and reinstalled 12C, now the 12C app opens. 
There were two 12C addresses listed  68 and 77+

SO I added them both on the sensor tab and created the connections sk - NMEA 0183. 

I now get GPS connection and I get Pressure but I am not getting temperature. Do you know what might cause this?

Do you have a BME280 sensor connected? if not, remove it from the list.

If you want to have temperature reading just define a signal k key for temperature in MS5607-02BA03 sensor (this is the moitessier sensor for pressure and temperature). Select temperature and click on edit.

Thanks for the reply.
Removed data under the I2C header, un- and re-installed I2C app.
Now the I2C app starts, and shows 2 sensors-  (BME280 and MS5607-02BA03) but I have to guess the ports? 
With the port copied from above for the MS5607-02BA03  (0x77) and the signal K key for environment.outside.temperature added, I now get an error free status report:


Code:
Checking OpenPlotter autostart... | enabled
Checking user "pi" password... | changed
Checking screensaver state... | disabled
Checking headless state... | disabled
Checking OpenPlotter packages source... | added
Checking Signal K server... | running
Checking I2C sensors... | running | I2C enabled
Checking WIFI Access Point password... | changed
Checking OpenCPN... | running | autostart enabled
Checking Pypilot... | Only compass
Checking Moitessier HAT... | attached | I2C enabled | SPI enabled | package installed
Checking serial connections alias... | All your serial connections have an assigned alias
Checking serial connections conflicts... | no conflicts
Checking network connections conflicts... | no conflicts
CHECK SYSTEM FINISHED

Still, no data to be seen. At least, the OpenCPN nmea debug window is blank (well, grey) nothing happening there. Shouldn't I at least see data from the GPS , even if it has no fix? Also no mag hdg, pitch, heel, pressure or temp data anywhere
Not sure how to view data in Signal K atm, so not much progress here.

Maybe I'll wait until more documentation becomes available, thanks for the effort though!

I sh
  Reply
#9
Just did a semi- full re-install: Uninstalled all OpenPlotter apps, and installed again. (is there a full reset option? For some reason bits of the configuration seemed sticky..)

Much better this time around- at least I am getting compass, heel and pitch data as well as temp and pressure.
Interestingly the temp is a fixed 20C, the pressure a fixed (forgaot hte value) mbars. Temp according to the moitessier app would ne in the 40C range- am I getting debug / simulated data?

The compass, pitch and heel kept changing, adding approximately 1 degree per few seconds (each!) I thought it might be a calibration issue, but could not find a calibrate option anywhere. Slowly turning it around an axis did not stop the slow climb of the readings.

Maybe I'll do a full re-install with the reconfigured Moitessier build later.
  Reply
#10
(01-14-2020, 07:01 AM)fishy Wrote: The compass, pitch and heel kept changing, adding approximately 1 degree per few seconds (each!) I thought it might be a calibration issue, but could not find a calibrate option anywhere. Slowly turning it around an axis did not stop the slow climb of the readings.

The latest version of PyPilot seems to have fixed this problem for me. Thanks!
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)