This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A Question About WiFi
#1
Hi All, 

I'm very new to this so my questions here may be obvious to some/most. 

I am currently working on setting up a Raspberry Pi4 B+ to run on my boat. The boat is completely void of any navigation equipment as its a new interior build, and i plan to use openplotter for nearly all of it (bar paper charts) 

I have ordered and i am waiting on a Moitessier HAT 2 and in the meantime i am trying to set up the Pi with a LCD screen that i plan to mount at the chart table with a keyboard and integrated mouse. 

So. 

First, i installed the Starting Edition image and it worked very well. 

Secondly, i installed the Headless image and again it worked very well, i could remote in with my tablet with RealVNC, however i couldn't connect to my home wifi at all. I tried to follow various guides on how to fix this and kept getting the error 

"Could not connect to wpa_supplicant"

I thought maybe i would try the Moitessier image to see if that would work and i was able to connect to wifi again, but i have lost the ability to remote in unless i have both the pi and my tablet connected to my home network. This won't be ideal on my boat as i want to run my tablet headless at the helm. 

In summary and my questions:

Ultimately i want to be able to use the Moitessier HAT, so i assume i will need to use the Moitessier image to get me started. So is there a way i can set up the Moitessier image to use the Pi as a wifi network so i can remote into it with my tablet?

And can i do this while also maintaining the ability to connect to wifi?

Thanks 
Rhys
  Reply
#2
Rhys,

I have a Pi3 and it is both a WIFI Access Point (interface wlan0) for my tablet on the 10.10.10.x network  (wlan0) is also a client on my home network( 192.168.2.x)  while I  learn about, and configure OP. I think the Pi4 works the same. in the "Openplotter Network" tool be sure you have  the network mode set to  "AP and Station". Click the pencil and add the WIFI details that you want the PI access point to recognize. Then in
/etc/wpa_supplicant/wpa_supplicant.conf add this for your environment:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US  <--- change to your county code

network={
       ssid="yourhomessid"
       psk="yourhomepass"
       key_mgmt=WPA-PSK
}

I did not need to make these changes to my wpa_supplicant.conf file because I initially came up with the PI on my home network (not headless) and this file was built on the first config screen ( I think ). Anyway a reboot will after this will activate the changes.
  Reply
#3
Ok thank you very much, I won't be near my pi until Sunday but i will try.

In an effort to help me understand the above;

I have the Moistessier image on the pi now, and it picks up the wifi at home but headless is turned off.

Will the sequence of steps you wrote out for me above fix that?

Would you be able to tell me what this will do? In "Openplotter Network" tool be sure you have the network mode set to "AP and Station". Click the pencil and add the WIFI details that you want the PI access point to recognize"

Do you mean add the 10.10.10.x IP address and details to this?

Thanks again in helping me to understand.

Rhys
  Reply
#4
I figured this out,

Summary of Problem:

When the Moistessier image was loaded, i couldn't figure out how to set up the headless function while also maintaining WIFI.

Solution:

I just had to set up the access point in Network Settings, see image below, and make sure it was on a free Channel

Probably extremely obvious to 99.9% of the people here... but i'm very new to this and maybe the next person to read this with be too Smile

[Image: YYaMB1W.jpg]
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)