This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[OP2] Output NMEA0183 data through serial port
#1
Hi all,

I've got a Garmin chartplotter / depth sounder (the ECHOMAP 45CV) which has a NMEA0183 interface, which is connected through a USB Serial adapter to my Raspberry PI running OpenPlotter 2.

The input side works properly; I see the depth data coming into SignalK.

However, this device is able to display AIS data, which I was able to do under OpenPlotter 1 using Kplex.

How do I do that in OpenPlotter 2? The data I want is available from the SignalK output plugin on TCP port 10110, but I want to send it out through a serial port.

I'll also need to be able to do that with my VHF radio, so I have GPS position for DSC distress call.

Any ideas?
  Reply
#2
Until an OP2 version of Kplex is ready, have you tried using OpenCPN? You can define output streams there. You can also install Kplex on your RPI4 directly using apt (sudo apt install kplex). You'd have to get it going manually, though. That means creating a config file and setting it up so that it starts when your RPI starts. Probably the easiest way to do that would be inserting a command in /etc/rc.local to start kplex with your config file.
  Reply
#3
Oh yeah, I didn't think about using OpenCPN! I think I'll try that. I had a lot of issues with kplex and serial ports, both with OpenPlotter as well as standalone. The connection seemed pretty fragile, and I had to restart it manually every time.
  Reply
#4
Okay, I just tried that, and it works pretty well. Even unconnecting an re-connecting the USB-Serial dongle worked perfectly; it reconnected automatically. One slight issue, though, is that I can't connect the input to SignalK anymore, I have to go through OpenCPN. Anyway, it does solve the issue for my VHF radio; I don't need any inputs from that one.

I guess I'll have to wait for Kplex to come out. I hope they fix the serial port issue by that time; it was pretty annoying.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)