This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Authorized to see data log files
#1
Goodmorning,

Last evening I was playing around with the new OP2.x and it tried the datalogging feature for the signalK data. 

At first it worked, I could see the data files showing in the signalK web-area (10.10.10.1:3000). One for every hour.
But at some point, it showed that I am not authorized to see these files. 

The only thing I added in between is that In installed InfluxDB. Maybe this has something to do with it?

Hoep somebody can help,

regards,
Vic
  Reply
#2
files proprietary and permissions?
  Reply
#3
(02-04-2020, 11:05 AM)Sailoog Wrote: files proprietary and permissions?

I didn't change anything (I think Angel). So the question is, how to resolve!

Link to screenshot
  Reply
#4
Does anybody now where the log files are located? So I can try to access them thru vnc and the folder structure.

regards,
V
  Reply
#5
(02-05-2020, 03:29 AM)Vic Wrote: Does anybody now where the log files are located? So I can try to access them thru vnc and the folder structure.

regards,
V

I've just enabled logging for a connection, file is in  /home/pi/.signalk/
So for the first few lines of my newly created file>
cat  /home/pi/.signalk/skserver-raw_2020-02-05T09.log | head


Though if you have influxdb installed then it's actually much more informative saving the data in  there using the influxdb signalk app then view with either chronograf or grafana. One tip about influxdb, I have problems with it using lots of resources and this helped lots >
In the influxdb settings file,  /etc/influxdb/influxdb.conf, there's a setting which should be false, 
In the ...
[monitor]   
section set ....
   store-enabled = false

So using the nano text editor , type in a terminal >
 sudo nano /etc/influxdb/influxdb.conf
Find the store-enabled setting and change to '= false', press ctrl x to exit and 'Y' to save the file then enter. 

Should be plenty links with how to install influxdb & chronograf, though maybe worth someone doing  a quick how to for openplotter for the manual as it's such a wonderful tool? Cool
  Reply
#6
Influxdb and Signal K log files are different things, I think your problem is with SK node server. Have you tried to update to 1.20?

PaddyB, influxdb & chronograf & grafana are already included in OP2. See openplotter-dashboards app.
  Reply
#7
I made a mistake in the influxdb screen. In the openplotter manual on grafana/influxdb, it say that I have to create a data base in openplotter. Instead of doing this, I made a folder "boatdata" for the logfiles in the signalK/influx app. After removing this, the logfiles became visible and accessible again.

Last night I got the grafana graphs working. And I will try to get a write up on how i did this.
  Reply
#8
(02-07-2020, 03:28 AM)Vic Wrote: I made a mistake in the influxdb screen. In the openplotter manual on grafana/influxdb, it say that I have to create a data base in openplotter. Instead of doing this, I made a folder "boatdata" for the logfiles in the signalK/influx app. After removing this, the logfiles became visible and accessible again.

Last night I got the grafana graphs working. And I will try to get a write up on how i did this.

Ops that chapter is obsolete. Please send us any text you do to update it.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)